Bug 115534 - kontact crashes whenever kmail puts a mail in the outbox
Summary: kontact crashes whenever kmail puts a mail in the outbox
Status: RESOLVED DUPLICATE of bug 110495
Alias: None
Product: kontact
Classification: Applications
Component: mail (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash
Target Milestone: ---
Assignee: kdepim bugs
Depends on:
Reported: 2005-11-02 14:23 UTC by Derek Broughton
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:

Backtrace of crash (8.15 KB, text/plain)
2005-11-02 14:24 UTC, Derek Broughton

Note You need to log in before you can comment on or make changes to this bug.
Description Derek Broughton 2005-11-02 14:23:28 UTC
Version:           unknown (using KDE 3.4.3, Kubuntu Package 4:3.4.3-0ubuntu2 )
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.12-6-686

kontact 1.1.2, kmail 1.8.3

After composing a mail, clicking on either the "Send Now" or "Send Later" buttons causes kontact to crash, leaving no trace of the composed mail.  If I initially save it as a draft, edit & send, there's still no copy of the composed mail in any folder.

This doesn't happen when KMail runs standalone (thankfully). 

The problem started after a system upgrade that install libgnutls11 (1.0.16-14) and the backtrace shows /lib/tls... coincidence?

Upgrading to libgnutls12 fixed the problem, so I guess not!
Comment 1 Derek Broughton 2005-11-02 14:24:37 UTC
Created attachment 13248 [details]
Backtrace of crash
Comment 2 Derek Broughton 2005-11-02 15:03:00 UTC
Oh, #$%^.  After installing libgnutls12, sending via KMail worked _exactly_ once.  Now it's failing again.
Comment 3 Tommi Tervo 2005-11-02 15:52:03 UTC

*** This bug has been marked as a duplicate of 107754 ***
Comment 4 Thiago Macieira 2005-11-02 18:07:34 UTC
Please don't mark duplicates of other bugs that are duplicates.

Comment 5 Thiago Macieira 2005-11-02 18:08:39 UTC
BTW, yes, it was a coincidence :-)

This bug is in gcc (more specifically, in the STL headers from libstdc++)

*** This bug has been marked as a duplicate of 110495 ***