Bug 114539 - CORE : removable media management
Summary: CORE : removable media management
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Database-Media (show other bugs)
Version: 0.8.2
Platform: Gentoo Packages Linux
: NOR wishlist with 497 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-16 23:26 UTC by Sorin Milutinovici
Modified: 2017-07-26 04:43 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sorin Milutinovici 2005-10-16 23:26:20 UTC
Version:            (using KDE KDE 3.4.2)
Installed from:    Gentoo Packages
OS:                Linux

I am sure that many users have photos archived on DVD-s or CD-s. It would be usefull to be able to imtegrate these in Digikam workflow (tags, searches, etc.). For this, we need an offline manager that will have, possibly, the following:

1. A menu item - Add offline album
2. A dialog with several options mainly related to the image cache from the disk: 
2.1. Do we keep local copies of the images?
2.2. If we do, what should be the size (in pixels) and compression factor? (a default should be available)
2.3. Name of the disk, location of the disk.
3. General settings: CDROM drive for offline manager, default size and compression factor for image caches, Image cache location (directory).

Offline albums should have a diffrent icon than online albums. Thumbnails of the pictures that belong to offline albums should have a visual marker (different border, etc.)
Comment 1 Adam Porter 2005-11-26 09:27:57 UTC
This is an important feature.  Hard disks keep growing, but they are not suitable for long-term archiving.  One could use external programs to copy photos to disc and keep a catalog of them, but that is cumbersome to keep up-to-date, and removes the advantages of saving hard disk space, and the all-in-one-ness of digiKam.  It's also a feature of Picasa.  ;)  Please consider this feature for 0.9 or 1.0 at least.
Comment 2 Benny Rochwerger 2005-12-17 22:12:42 UTC
*** This bug has been confirmed by popular vote. ***
Comment 3 Tom Albers 2005-12-30 13:04:08 UTC
*** Bug 119228 has been marked as a duplicate of this bug. ***
Comment 4 Mikolaj Machowski 2007-06-16 15:29:33 UTC
*** Bug 146868 has been marked as a duplicate of this bug. ***
Comment 5 Mikolaj Machowski 2007-10-31 18:26:47 UTC
*** Bug 151607 has been marked as a duplicate of this bug. ***
Comment 6 Jasper 2008-01-05 04:16:21 UTC
I am using digikam 0.10.0 so as to be able to work on albums on a file server.
 This has similar issues to albums on cd, usbdrive etc. 
The features I think are needed in the situation of an nfs, samba, or whatever network mounted album are as follows:
 i) That digikam is aware that the album is on a network drive, and as such may not always be available. (status shown)
 ii) All thumbnails are generated and stored locally. (no limit to cache)
  iia) What size? I like big thumbnails - I like lots of otions, here it would be good to choose what sizes you wanted genereate. i.e 96 and 256.
 iii) That the thumbnails be accesable even when the network drive is not mounted, and changes to meta-data and captions (whether exif change or database change) are synced to the remote files when available.
 iv) That files on the network mounted album can be flagged for local storage, and this list be obvious somewhow, maybee a 'local' album. Also possible through criteria - tags or rating etc.
  iva) The OPTION to sync changes from local -> remote or remote -> local (reload) be available.

I think these features are an essential bare minimum - not confusing - but logical and understandable considering the remote nature of the storage medium.
Comment 7 Murray Strome 2008-05-13 19:45:22 UTC
I think that digiKam is probably the best software package for photo organization. However, the ability to include photos that are NOT on the local hard drive (e.g. on CDs and DVDs or other computers) is the one most desirable feature lacking.

In KPhotoAlbum, you can include such photos in your database very easily:

Copy the photos from the CD/DVD to the directory where you have your KPhotoAlbum.
Rescan the photos, an tag all the new ones you are adding.
Delete the photos you have copied from the CD/DVD

Now, in your Thumbnails view, all of those photos still appear. All the attributes are there as well. The only difference in the Thumbnails is that the upper right hand corner is clipped off to indicate that the photo is not on disk.

If this feature were to be added to digiKam, I think it would be the perfect solution for my photo organizing needs.  

I really don't want to have to run two programs, but digiKam does not have this feature, and I have found too many other difficulties with KPhotoAlbum to use it exclusively.

Comment 8 caulier.gilles 2008-05-13 19:56:26 UTC
Murray,

removable and multiple root album support have been implemented to KDE4 port (0.10.0) of digiKam, but code still not yet finalized.

Gilles Caulier
Comment 9 Murray Strome 2008-05-24 01:33:03 UTC
Gilles,
Is there any estimate of when this might become available? I just upgraded my Kubuntu to 8.04 and DigiKam to 0.9.3 (using KDE 3.5.9). KDE 4.04 is available now for Kubuntu 8.04 but I would not likely want to try it unless (or until) the version of DigiKam which would support inclusion of off-line images becomes available.
Murray
Comment 10 caulier.gilles 2008-05-24 08:21:08 UTC
Murray,

Look release plan web page :

http://www.digikam.org/?q=about/releaseplan

Gilles
Comment 11 Carlo Russo 2009-04-04 09:01:27 UTC
Ok, now that Digikam 0.10 is out, does this bug is still unresolved?
Just to know...
Comment 12 Vincent Tassy 2011-08-11 14:57:08 UTC
Hi
Digikam 2.0.0 still doesn't provide support for viewing collections offline !
We have a thumbnails database that should enable that so what's missing to have a thumbnails view of disconnected network collections or DVD collections and be able to perform search on them too ?
Comment 13 Marcel Wiesweg 2011-08-11 16:53:08 UTC
missing: enabling this in the backend, UI support, a lot of provisions at various places because we know that these files cannot be accessed, good testing. Writing metadata to these items being a story of its own.

See also bugs 191494, 225177, 215990
Comment 14 caulier.gilles 2014-08-24 08:22:41 UTC
*** Bug 215990 has been marked as a duplicate of this bug. ***
Comment 15 caulier.gilles 2014-11-15 18:04:46 UTC
This entry is also relevant indirectly  of bug #191494
Comment 16 caulier.gilles 2014-12-15 13:05:23 UTC
Git commit 3daab2fc8a17e20d68a69c319ab65edcca3fc876 by Marcel Wiesweg.
Committed on 15/11/2014 at 17:14.
Pushed by mwiesweg into branch 'master'.

Allow to use the notification tooltip with some more safety also from other sources than overlays

M  +13   -0    libs/widgets/itemview/dcategorizedview.cpp
M  +1    -0    libs/widgets/itemview/dcategorizedview.h

http://commits.kde.org/digikam/3daab2fc8a17e20d68a69c319ab65edcca3fc876

diff --git a/libs/widgets/itemview/dcategorizedview.cpp b/libs/widgets/itemview/dcategorizedview.cpp
index 1f1b406..d98069b 100644
--- a/libs/widgets/itemview/dcategorizedview.cpp
+++ b/libs/widgets/itemview/dcategorizedview.cpp
@@ -769,6 +769,11 @@ void DCategorizedView::contextMenuEvent(QContextMenuEvent* event)
     }
 }

+void DCategorizedView::leaveEvent(QEvent*)
+{
+    hideIndexNotification();
+}
+
 void DCategorizedView::mousePressEvent(QMouseEvent* event)
 {
     userInteraction();
@@ -835,6 +840,14 @@ void DCategorizedView::mouseMoveEvent(QMouseEvent* event)
         unsetCursor();
     }

+    if (d->notificationToolTip && d->notificationToolTip->isVisible())
+    {
+        if (!d->notificationToolTip->rect().adjusted(-50, -50, 50, 50).contains(event->pos()))
+        {
+            hideIndexNotification();
+        }
+    }
+
     DigikamKCategorizedView::mouseMoveEvent(event);

     d->delegate->mouseMoved(event, indexVisualRect, index);
diff --git a/libs/widgets/itemview/dcategorizedview.h b/libs/widgets/itemview/dcategorizedview.h
index f07fc3f..31d1adb 100644
--- a/libs/widgets/itemview/dcategorizedview.h
+++ b/libs/widgets/itemview/dcategorizedview.h
@@ -143,6 +143,7 @@ protected:
     // reimplemented from parent class
     void contextMenuEvent(QContextMenuEvent* event);
     void keyPressEvent(QKeyEvent* event);
+    void leaveEvent(QEvent* event);
     void mouseMoveEvent(QMouseEvent* event);
     void mousePressEvent(QMouseEvent* event);
     void mouseReleaseEvent(QMouseEvent* event);
Comment 17 caulier.gilles 2014-12-15 13:06:06 UTC
Git commit 6c9241b209855a40a731b1918eff0c5d557f6e94 by Marcel Wiesweg.
Committed on 15/11/2014 at 17:16.
Pushed by mwiesweg into branch 'master'.

Support listing of images on not-available collections

M  +3    -1    kioslave/digikamalbums.cpp
M  +1    -0    kioslave/digikamdates.cpp
M  +1    -0    kioslave/digikammapimages.cpp
M  +1    -0    kioslave/digikamsearch.cpp
M  +2    -0    kioslave/digikamtags.cpp
M  +10   -0    libs/database/imageinfo.cpp
M  +7    -0    libs/database/imageinfo.h
M  +25   -4    libs/models/imagealbummodel.cpp
M  +2    -0    libs/models/imagealbummodel.h

http://commits.kde.org/digikam/6c9241b209855a40a731b1918eff0c5d557f6e94
Comment 18 caulier.gilles 2014-12-15 13:06:32 UTC
Git commit 44ed4eacf9c9439c3b892f9a3a65c9231dd88e28 by Marcel Wiesweg.
Committed on 15/11/2014 at 17:16.
Pushed by mwiesweg into branch 'master'.

Enable showing albums on collections which are not available (removable media)
There is currently no option in the UI to switch this off,
though there is a simple method in album manager to toggle this setting

M  +120  -21   app/album/albummanager.cpp
M  +6    -0    app/album/albummanager.h

http://commits.kde.org/digikam/44ed4eacf9c9439c3b892f9a3a65c9231dd88e28
Comment 19 caulier.gilles 2014-12-15 13:07:19 UTC
Git commit 8fa0304a3144cbf9da29a734622fa6f501c4a1b6 by Marcel Wiesweg.
Committed on 15/11/2014 at 17:17.
Pushed by mwiesweg into branch 'master'.

If the user tries to open an image which is not availabe, display a tooltip to explain the situation

M  +5    -0    app/items/imagecategorizedview.cpp
M  +2    -0    app/items/imagecategorizedview.h
M  +14   -5    app/views/digikamview.cpp

http://commits.kde.org/digikam/8fa0304a3144cbf9da29a734622fa6f501c4a1b6
Comment 20 caulier.gilles 2014-12-15 13:08:04 UTC
Git commit 5ef8b08f7cbe18b1cfd4b0629020361414966353 by Marcel Wiesweg.
Committed on 16/11/2014 at 15:35.
Pushed by mwiesweg into branch 'master'.

Chnge the thumbnail loading API to be based on ThumbnailIdentifier

M  +28   -3    libs/threadimageio/loadingdescription.cpp
M  +8    -6    libs/threadimageio/loadingdescription.h
M  +54   -24   libs/threadimageio/thumbnailcreator.cpp
M  +13   -58   libs/threadimageio/thumbnailcreator.h
M  +60   -56   libs/threadimageio/thumbnailloadthread.cpp
M  +20   -19   libs/threadimageio/thumbnailloadthread.h
M  +4    -4    libs/threadimageio/thumbnailtask.cpp

http://commits.kde.org/digikam/5ef8b08f7cbe18b1cfd4b0629020361414966353
Comment 21 caulier.gilles 2014-12-15 13:10:26 UTC
Git commit 0e9549a3822ef30809dc8a7e91393765f51d3ba7 by Marcel Wiesweg.
Committed on 16/11/2014 at 16:18.
Pushed by mwiesweg into branch 'master'.

The final fixes to make thumbnails for offline collections work

M  +12   -2    libs/models/imagethumbnailmodel.cpp
M  +6    -1    libs/threadimageio/thumbnailcreator.cpp

http://commits.kde.org/digikam/0e9549a3822ef30809dc8a7e91393765f51d3ba7
Comment 22 caulier.gilles 2014-12-15 13:12:26 UTC
For next 4.6.0, Marcel has commit a lots of fix to fix this entry.

Gilles Caulier
Comment 23 caulier.gilles 2015-11-28 18:53:00 UTC
Removable media is no fully implemented since 4.x releases.

I close this file.

Gilles Caulier