Bug 114055 - Error installing new themes with characters like 'á', 'ñ', ... in the name
Summary: Error installing new themes with characters like 'á', 'ñ', ... in the name
Status: RESOLVED UNMAINTAINED
Alias: None
Product: superkaramba
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Ryan Nickell
URL:
Keywords:
: 114553 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-10-08 12:03 UTC by Antonio E.
Modified: 2014-08-17 10:13 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antonio E. 2005-10-08 12:03:43 UTC
Version:           0.37-RC2 (kde-3.5_beta1) (using KDE Devel)
Installed from:    Compiled sources
Compiler:          gcc-3.3.6 
OS:                Linux

I can't install themes through the install new them tool. Using that tool I connect perfectly to KDE-loo.org Karamba. And I get the three list with the available karambas. The first thing that I can see is that all names with spanish characters as 'á', 'ñ' are lost. Example:

"Info Sistema y amaroK en Español" is shown as "Info Sistem y amaroK en Espaol".

That's not only the problem. The real problem is that when I click on it and then the install button, if the file name contains one those "problematic" chars, I get an error dialog saying that the file or folder http://xxxxxxxxxxxxxxxx/xxxxx-Info_sistema_espaol.tar doesn't exist (the xxxxx is just to don't write the full url). And of course, that file doesn't exist, because the real one contains a 'ñ', being español instead of espaol.

Then, after getting that error, the failed to install element in the list looks like if it was installed, having the green mark icon on the left, and I can't reinstall it. The only way to remove it from that list is editing manually the superkarambarc file.

So this seems to be a problem with the utf-8 charset support.
Comment 1 Thiago Macieira 2005-10-18 02:55:28 UTC
*** Bug 114553 has been marked as a duplicate of this bug. ***