Bug 114553 - SuperKaramba themes cannot display Japanese characters.
Summary: SuperKaramba themes cannot display Japanese characters.
Status: RESOLVED DUPLICATE of bug 114055
Alias: None
Product: superkaramba
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Ryan Nickell
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-10-17 09:12 UTC by Horacio Sanson
Modified: 2006-12-18 21:58 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Horacio Sanson 2005-10-17 09:12:42 UTC
Version:           3.4.91 (using KDE KDE 3.4.91)
Installed from:    Gentoo Packages
Compiler:          gcc-3.3.6 
OS:                Linux

If I use japanese characters in a simple theme I get a buch of ???? instead of the japanese characters.

I can see japanese correctly while editing the theme file using any editor but superkaramba does not display them correctly.


############test.theme#######################
karamba x=50 y=50 w=200 h=200 interval=1000 LOCKED=false
defaultfont fontsize=10 color=255,255,255 font="Bitstream Charter" shadow=1 bgcolor=100,100,100

<group> x=0 y=4
text x=34 y=0 value="Wireless ネット" color=255,255,255 fontsize=12 font="Bitstream Charter" shadow=2
text x=34 y=20 value="Japanese Test (日本語テスト)" color=255,255,255 fontsize=12 font="Sans Serif" shadow=2
text x=34 y=35 value="Japanese Test (日本語テスト)" color=255,255,255 fontsize=12 font="Times" shadow=2
</group>


########################################

No matter what font I use the japanese chars appear as ????.

My system is set to en_US.UTF-8
Comment 1 Thiago Macieira 2005-10-18 02:55:27 UTC

*** This bug has been marked as a duplicate of 114055 ***
Comment 2 Daniel 2006-12-18 21:58:52 UTC
Confirming the bug as fixed. (I am not the original bug author)

Created a theme out of the provided example and used with SVN version:

Last Changed Author: wirr
Last Changed Rev: 612312
Last Changed Date: 2006-12-10 12:52:32 -0800 (Sun, 10 Dec 2006)

Thx. wirr.