Bug 112437 - amarok crash when working with a proxy in KDE
Summary: amarok crash when working with a proxy in KDE
Status: RESOLVED INTENTIONAL
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 1.2.3
Platform: unspecified Linux
: NOR crash with 106 votes (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
: 109766 110921 114452 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-09-11 21:03 UTC by Fran
Modified: 2008-09-09 14:11 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fran 2005-09-11 21:03:23 UTC
Version:           1.2.3 (using KDE 3.4.2, Kubuntu Package 4:3.4.2-0ubuntu0hoary2 )
Compiler:          gcc version 3.3.5 (Debian 1:3.3.5-8ubuntu2)
OS:                Linux (i686) release 2.6.10-5-386

I set up a proxy in the KDE control center, so all the connections were made through it. Then the tab "current" started not working (after a song change it didn't change) or being blank. Usually, when I closed the program, I got a crash.

In any case, I was not able to get any lyrics when any of the problems started.

I made a new user and I started a new clean session in KDE, and everything worked fine. Plus, when I unset the proxy - in the original user - I had no problems anymore.

All my music is in a FAT32 partition, I'm not using any plugins, nor MySQL.

When I got the crashes I sent some bug reports, when I was asked to do it (via mail with Kmail). In one of them I give a detailed description of my frustration, thought at that point I didn't know it was because of the proxy.
Comment 1 Thiago Macieira 2005-09-11 21:05:59 UTC
What kind of proxy did you set up? HTTP or SOCKS? Can you paste the backtrace?
Comment 2 Fran 2005-09-11 21:29:17 UTC
It was an HTTP proxy, set up with a script (http://proxy.karlshof.de/proxy.pac)

I sent this mail today morning to the backtraces list. I hope this helps.

______________________________________________ 

1.2.3 [___stripped][validity: 0.80][frames: 100][]
De: 
Francisco Joaquín Rodríguez Prados <prados@gmail.com>
  Para: 
amarok-backtraces@lists.sf.net
  Fecha: 
Hoy 15:01:20
   
This has happen several times. The tab "current" doesn't work properly, and 
sometimes there's nothing there (just a blank tab). And when I try to 
download some cover or get a lyric (I guess it has something to do with the 
internet connection) it crashes. I deleted al my amarok configuration in 
$HOME/.kde/share/apps/amarok and the file $HOME/.kde/share/config. And I 
don't have any idea of why this is happening :(

All my music is in a FAT32 partition... I don't know if that has something to 
do.

_______________________

amaroK has crashed! We're terribly sorry about this :(

But, all is not lost! You could potentially help us fix the crash. amaroK has 
attached a backtrace that describes the crash, so just click send, or if you 
have time, write a brief description of how the crash happened first.

Many thanks.

Engine:     
Build date: Apr  6 2005
CC version: 3.3.5 (Debian 1:3.3.5-8ubuntu2)
KDElibs:    3.4.0
TagLib:     1.3.1
NDEBUG:     true



______________________________________________ backtrace file:


==== file `which amarokapp` =======


==== (gdb) bt =====================
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1237933248 (LWP 16308)]
[New Thread -1250796624 (LWP 16333)]
0xffffe410 in ?? ()
#0  0xffffe410 in ?? ()
#1  0xbffff258 in ?? ()
#2  0x00000008 in ?? ()
#3  0x08341158 in ?? ()
#4  0xb76db4fb in __read_nocancel () from /lib/tls/i686/cmov/libpthread.so.0
#5  0xb66c4a60 in _kde_IceConnectionClosed () from /usr/lib/libDCOP.so.4
#6  0xb66c56cf in _kde_IceTransRead () from /usr/lib/libDCOP.so.4
#7  0xb66bd12e in _kde_IceRead () from /usr/lib/libDCOP.so.4
#8  0xb66bd747 in KDE_IceProcessMessages () from /usr/lib/libDCOP.so.4
#9  0xb66b3c30 in DCOPClient::callInternal () from /usr/lib/libDCOP.so.4
#10 0xb66b362c in DCOPClient::callInternal () from /usr/lib/libDCOP.so.4
#11 0xb66b30f5 in DCOPClient::call () from /usr/lib/libDCOP.so.4
#12 0xb66b2f1a in DCOPClient::call () from /usr/lib/libDCOP.so.4
#13 0xb66b4d52 in DCOPClient::disconnectDCOPSignal ()
   from /usr/lib/libDCOP.so.4
#14 0xb66a8b8e in DCOPObject::~DCOPObject () from /usr/lib/libDCOP.so.4
#15 0xb756ef2e in KBookmarkManager::~KBookmarkManager ()
   from /usr/lib/libkio.so.4
#16 0xb758d9de in QPtrList<KBookmarkManager>::deleteItem ()
   from /usr/lib/libkio.so.4
#17 0xb7e285cc in QGList::clear () from /usr/lib/libqt-mt.so.3
#18 0xb758d99d in QPtrList<KBookmarkManager>::~QPtrList ()
   from /usr/lib/libkio.so.4
#19 0xb758dd1f in KStaticDeleter<QPtrList<KBookmarkManager> >::destructObject
    () from /usr/lib/libkio.so.4
#20 0xb6f69ba5 in KGlobal::deleteStaticDeleters ()
   from /usr/lib/libkdecore.so.4
#21 0xb6ed3e8e in KApplication::~KApplication () from /usr/lib/libkdecore.so.4
#22 0x08087edc in KToggleAction::metaObject ()
#23 0x08175d81 in QWizard::setFinish ()
#24 0xb66e18c8 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#25 0x080830f1 in ?? ()
#0  0xffffe410 in ?? ()
No symbol table info available.
#1  0xbffff258 in ?? ()
No symbol table info available.
#2  0x00000008 in ?? ()
No symbol table info available.
#3  0x08341158 in ?? ()
No symbol table info available.
#4  0xb76db4fb in __read_nocancel () from /lib/tls/i686/cmov/libpthread.so.0
No symbol table info available.
#5  0xb66c4a60 in _kde_IceConnectionClosed () from /usr/lib/libDCOP.so.4
No symbol table info available.
#6  0xb66c56cf in _kde_IceTransRead () from /usr/lib/libDCOP.so.4
No symbol table info available.
#7  0xb66bd12e in _kde_IceRead () from /usr/lib/libDCOP.so.4
No symbol table info available.
#8  0xb66bd747 in KDE_IceProcessMessages () from /usr/lib/libDCOP.so.4
No symbol table info available.
#9  0xb66b3c30 in DCOPClient::callInternal () from /usr/lib/libDCOP.so.4
No symbol table info available.
#10 0xb66b362c in DCOPClient::callInternal () from /usr/lib/libDCOP.so.4
No symbol table info available.
#11 0xb66b30f5 in DCOPClient::call () from /usr/lib/libDCOP.so.4
No symbol table info available.
#12 0xb66b2f1a in DCOPClient::call () from /usr/lib/libDCOP.so.4
No symbol table info available.
#13 0xb66b4d52 in DCOPClient::disconnectDCOPSignal ()
   from /usr/lib/libDCOP.so.4
No symbol table info available.
#14 0xb66a8b8e in DCOPObject::~DCOPObject () from /usr/lib/libDCOP.so.4
No symbol table info available.
#15 0xb756ef2e in KBookmarkManager::~KBookmarkManager ()
   from /usr/lib/libkio.so.4
No symbol table info available.
#16 0xb758d9de in QPtrList<KBookmarkManager>::deleteItem ()
   from /usr/lib/libkio.so.4
No symbol table info available.
#17 0xb7e285cc in QGList::clear () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#18 0xb758d99d in QPtrList<KBookmarkManager>::~QPtrList ()
   from /usr/lib/libkio.so.4
No symbol table info available.
#19 0xb758dd1f in KStaticDeleter<QPtrList<KBookmarkManager> >::destructObject
    () from /usr/lib/libkio.so.4
No symbol table info available.
#20 0xb6f69ba5 in KGlobal::deleteStaticDeleters ()
   from /usr/lib/libkdecore.so.4
No symbol table info available.
#21 0xb6ed3e8e in KApplication::~KApplication () from /usr/lib/libkdecore.so.4
No symbol table info available.
#22 0x08087edc in KToggleAction::metaObject ()
No symbol table info available.
#23 0x08175d81 in QWizard::setFinish ()
No symbol table info available.
#24 0xb66e18c8 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#25 0x080830f1 in ?? ()
No symbol table info available.
==== (gdb) thread apply all bt ====
Thread 2 (Thread -1250796624 (LWP 16333)):
#0  0xffffe410 in ?? ()
#1  0xb572492c in ?? ()
#2  0x00000000 in ?? ()
#3  0x00000000 in ?? ()
#4  0xb76dc48b in __waitpid_nocancel ()
   from /lib/tls/i686/cmov/libpthread.so.0
#5  0x0817ae28 in amaroK::Crash::crashHandler ()
#6  <signal handler called>
#7  0xb7e42301 in QString::deref () from /usr/lib/libqt-mt.so.3
#8  0xb7e423dd in QString::operator= () from /usr/lib/libqt-mt.so.3
#9  0xb6f622c6 in KURL::operator= () from /usr/lib/libkdecore.so.4
#10 0xb74492a2 in KProtocolManager::slaveProtocol () from /usr/lib/libkio.so.4
#11 0xb7453ff7 in KIO::Scheduler::_doJob () from /usr/lib/libkio.so.4
#12 0xb745ad7b in KIO::SimpleJob::SimpleJob () from /usr/lib/libkio.so.4
#13 0xb745e508 in KIO::TransferJob::TransferJob () from /usr/lib/libkio.so.4
#14 0xb74603dc in KIO::http_post () from /usr/lib/libkio.so.4
#15 0x0813b47b in QValueListPrivate<KAction*>::insert ()
#16 0x080a9747 in QListView::removeItem ()
#17 0x080cb3b8 in QMapPrivate<QString, QString>::copy ()
#18 0x08159b3b in KSystemTray::metaObject ()
#19 0xb7b2a465 in QThreadInstance::start () from /usr/lib/libqt-mt.so.3
#20 0xb76d6ae0 in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#21 0xb679ec9a in clone () from /lib/tls/i686/cmov/libc.so.6
Thread 1 (Thread -1237933248 (LWP 16308)):
#0  0xffffe410 in ?? ()
#1  0xbffff258 in ?? ()
#2  0x00000008 in ?? ()
#3  0x08341158 in ?? ()
#4  0xb76db4fb in __read_nocancel () from /lib/tls/i686/cmov/libpthread.so.0
#5  0xb66c4a60 in _kde_IceConnectionClosed () from /usr/lib/libDCOP.so.4
#6  0xb66c56cf in _kde_IceTransRead () from /usr/lib/libDCOP.so.4
#7  0xb66bd12e in _kde_IceRead () from /usr/lib/libDCOP.so.4
#8  0xb66bd747 in KDE_IceProcessMessages () from /usr/lib/libDCOP.so.4
#9  0xb66b3c30 in DCOPClient::callInternal () from /usr/lib/libDCOP.so.4
#10 0xb66b362c in DCOPClient::callInternal () from /usr/lib/libDCOP.so.4
#11 0xb66b30f5 in DCOPClient::call () from /usr/lib/libDCOP.so.4
#12 0xb66b2f1a in DCOPClient::call () from /usr/lib/libDCOP.so.4
#13 0xb66b4d52 in DCOPClient::disconnectDCOPSignal ()
   from /usr/lib/libDCOP.so.4
#14 0xb66a8b8e in DCOPObject::~DCOPObject () from /usr/lib/libDCOP.so.4
#15 0xb756ef2e in KBookmarkManager::~KBookmarkManager ()
   from /usr/lib/libkio.so.4
#16 0xb758d9de in QPtrList<KBookmarkManager>::deleteItem ()
   from /usr/lib/libkio.so.4
#17 0xb7e285cc in QGList::clear () from /usr/lib/libqt-mt.so.3
#18 0xb758d99d in QPtrList<KBookmarkManager>::~QPtrList ()
   from /usr/lib/libkio.so.4
#19 0xb758dd1f in KStaticDeleter<QPtrList<KBookmarkManager> >::destructObject
    () from /usr/lib/libkio.so.4
#20 0xb6f69ba5 in KGlobal::deleteStaticDeleters ()
   from /usr/lib/libkdecore.so.4
#21 0xb6ed3e8e in KApplication::~KApplication () from /usr/lib/libkdecore.so.4
#22 0x08087edc in KToggleAction::metaObject ()
#23 0x08175d81 in QWizard::setFinish ()
#24 0xb66e18c8 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#25 0x080830f1 in ?? ()
#0  0xffffe410 in ?? ()


==== kdBacktrace() ================
Comment 3 Mark Kretschmann 2005-10-15 17:54:07 UTC
*** Bug 110921 has been marked as a duplicate of this bug. ***
Comment 4 Mark Kretschmann 2005-10-15 17:55:13 UTC
*** Bug 114452 has been marked as a duplicate of this bug. ***
Comment 5 Mark Kretschmann 2005-10-15 17:56:05 UTC
*** Bug 109766 has been marked as a duplicate of this bug. ***
Comment 6 Martin Heusel 2005-10-15 18:11:10 UTC
Hi, i'm coming from this duplicate
http://bugs.kde.org/show_bug.cgi?id=110921 :)

Excellent Bugmanagement btw!

I too set my proxy settings with a proxy.pac from a webserver which is the proxy.
Setting the proxy manually gives no DCOPerror(s)/freezes!
Is this a bug in the KDE-libs?

Comment 7 Alexandre Oliveira 2006-03-01 22:01:41 UTC
This looks like a bug on KDELibs, not amaroK.
Anyway, does it still happen?
I wonder where we should move this report to.
Comment 8 Martin Heusel 2006-03-02 09:40:04 UTC
still there, only manual proxy settings are safe
kde 3.4.3, amarok 1.3.8
Comment 9 Fran 2006-03-06 12:05:01 UTC
franqui@Atlantis:~$ amarok --version
Qt: 3.3.4
KDE: 3.5.1
amaroK: 1.3.1

The bug is still here. It still freezes. The music goes on, but the "current" tab in the context section doesn't change. I can do things, like adding a track to the queue, but the mouse shows a busy clock all the time.

No crashes, however. I'm still running it with the proxy set with a proxy.pac script.
Comment 10 Fran 2006-03-06 12:15:42 UTC
Whoa. Just sen the previous message, I got a crash. I closed Amarok (it was freezed as I explained before) and, when I opened it again, I got this crash. Btw, lately - since I have the proxy - it has not been closing properly, and I have to do an "killall amarokapp" before restarting.

Here I paste the backtrace:

Engine:     arts-engine
Build date: Oct  4 2005
CC version: 4.0.2 20050808 (prerelease) (Ubuntu 4.0.1-4ubuntu9)
KDElibs:    3.4.2
TagLib:     1.3.1
NDEBUG:     true


==== file /usr/lib/amarok/amarokapp =======
/usr/lib/amarok/amarokapp: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.2.0, dynamically linked (uses shared libs), stripped


==== (gdb) bt =====================
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.
[Thread debugging using libthread_db enabled]
[New Thread -1241217344 (LWP 13969)]
0xffffe410 in __kernel_vsyscall ()
#0  0xffffe410 in __kernel_vsyscall ()
#1  0xb751c4ab in __waitpid_nocancel ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0820ccf7 in amaroK::Crash::crashHandler ()
#3  <signal handler called>
#4  0x000000c1 in ?? ()
#5  0xb7ab6abe in QWidget::setShown () from /usr/lib/libqt-mt.so.3
#6  0x08194e31 in QMapPrivate<QString, KURL>::QMapPrivate ()
#7  0x0808b552 in KToggleAction::metaObject ()
#8  0x081f2f55 in amaroK::DcopPlayerHandler::staticMetaObject ()
#9  0x081f9a14 in amaroK::DcopPlayerHandler::staticMetaObject ()
#10 0xb63a0475 in DCOPClient::receive () from /usr/lib/libDCOP.so.4
#11 0xb63a1afb in DCOPClient::find () from /usr/lib/libDCOP.so.4
#12 0xb63a23d5 in DCOPClient::find () from /usr/lib/libDCOP.so.4
#13 0xb63aed4e in KDE_IceProcessMessages () from /usr/lib/libDCOP.so.4
#14 0xb63a2db9 in DCOPClient::callInternal () from /usr/lib/libDCOP.so.4
#15 0xb63a2fca in DCOPClient::callInternal () from /usr/lib/libDCOP.so.4
#16 0xb63a366e in DCOPClient::call () from /usr/lib/libDCOP.so.4
#17 0xb63a36bc in DCOPClient::call () from /usr/lib/libDCOP.so.4
#18 0xb63a6394 in DCOPClient::disconnectDCOPSignal ()
   from /usr/lib/libDCOP.so.4
#19 0xb63a6c2a in DCOPObject::~DCOPObject () from /usr/lib/libDCOP.so.4
#20 0xb7335868 in KDirListerCache::~KDirListerCache ()
   from /usr/lib/libkio.so.4
#21 0xb739d4c3 in KStaticDeleter<KDirListerCache>::destructObject ()
   from /usr/lib/libkio.so.4
#22 0xb6d58bb5 in KGlobal::deleteStaticDeleters ()
   from /usr/lib/libkdecore.so.4
#23 0xb6de334f in KApplication::~KApplication () from /usr/lib/libkdecore.so.4
#24 0x0808d805 in KToggleAction::metaObject ()
#25 0x081ef926 in QWizard::setFinish ()
#26 0xb63d0ea2 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#27 0x08086791 in ?? ()
#0  0xffffe410 in __kernel_vsyscall ()
No symbol table info available.
#1  0xb751c4ab in __waitpid_nocancel ()
   from /lib/tls/i686/cmov/libpthread.so.0
No symbol table info available.
#2  0x0820ccf7 in amaroK::Crash::crashHandler ()
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x000000c1 in ?? ()
No symbol table info available.
#5  0xb7ab6abe in QWidget::setShown () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#6  0x08194e31 in QMapPrivate<QString, KURL>::QMapPrivate ()
No symbol table info available.
#7  0x0808b552 in KToggleAction::metaObject ()
No symbol table info available.
#8  0x081f2f55 in amaroK::DcopPlayerHandler::staticMetaObject ()
No symbol table info available.
#9  0x081f9a14 in amaroK::DcopPlayerHandler::staticMetaObject ()
No symbol table info available.
#10 0xb63a0475 in DCOPClient::receive () from /usr/lib/libDCOP.so.4
No symbol table info available.
#11 0xb63a1afb in DCOPClient::find () from /usr/lib/libDCOP.so.4
No symbol table info available.
#12 0xb63a23d5 in DCOPClient::find () from /usr/lib/libDCOP.so.4
No symbol table info available.
#13 0xb63aed4e in KDE_IceProcessMessages () from /usr/lib/libDCOP.so.4
No symbol table info available.
#14 0xb63a2db9 in DCOPClient::callInternal () from /usr/lib/libDCOP.so.4
No symbol table info available.
#15 0xb63a2fca in DCOPClient::callInternal () from /usr/lib/libDCOP.so.4
No symbol table info available.
#16 0xb63a366e in DCOPClient::call () from /usr/lib/libDCOP.so.4
No symbol table info available.
#17 0xb63a36bc in DCOPClient::call () from /usr/lib/libDCOP.so.4
No symbol table info available.
#18 0xb63a6394 in DCOPClient::disconnectDCOPSignal ()
   from /usr/lib/libDCOP.so.4
No symbol table info available.
#19 0xb63a6c2a in DCOPObject::~DCOPObject () from /usr/lib/libDCOP.so.4
No symbol table info available.
#20 0xb7335868 in KDirListerCache::~KDirListerCache ()
   from /usr/lib/libkio.so.4
No symbol table info available.
#21 0xb739d4c3 in KStaticDeleter<KDirListerCache>::destructObject ()
   from /usr/lib/libkio.so.4
No symbol table info available.
#22 0xb6d58bb5 in KGlobal::deleteStaticDeleters ()
   from /usr/lib/libkdecore.so.4
No symbol table info available.
#23 0xb6de334f in KApplication::~KApplication () from /usr/lib/libkdecore.so.4
No symbol table info available.
#24 0x0808d805 in KToggleAction::metaObject ()
No symbol table info available.
#25 0x081ef926 in QWizard::setFinish ()
No symbol table info available.
#26 0xb63d0ea2 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#27 0x08086791 in ?? ()
No symbol table info available.
==== (gdb) thread apply all bt ====
Thread 1 (Thread -1241217344 (LWP 13969)):
#0  0xffffe410 in __kernel_vsyscall ()
#1  0xb751c4ab in __waitpid_nocancel ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0820ccf7 in amaroK::Crash::crashHandler ()
#3  <signal handler called>
#4  0x000000c1 in ?? ()
#5  0xb7ab6abe in QWidget::setShown () from /usr/lib/libqt-mt.so.3
#6  0x08194e31 in QMapPrivate<QString, KURL>::QMapPrivate ()
#7  0x0808b552 in KToggleAction::metaObject ()
#8  0x081f2f55 in amaroK::DcopPlayerHandler::staticMetaObject ()
#9  0x081f9a14 in amaroK::DcopPlayerHandler::staticMetaObject ()
#10 0xb63a0475 in DCOPClient::receive () from /usr/lib/libDCOP.so.4
#11 0xb63a1afb in DCOPClient::find () from /usr/lib/libDCOP.so.4
#12 0xb63a23d5 in DCOPClient::find () from /usr/lib/libDCOP.so.4
#13 0xb63aed4e in KDE_IceProcessMessages () from /usr/lib/libDCOP.so.4
#14 0xb63a2db9 in DCOPClient::callInternal () from /usr/lib/libDCOP.so.4
#15 0xb63a2fca in DCOPClient::callInternal () from /usr/lib/libDCOP.so.4
#16 0xb63a366e in DCOPClient::call () from /usr/lib/libDCOP.so.4
#17 0xb63a36bc in DCOPClient::call () from /usr/lib/libDCOP.so.4
#18 0xb63a6394 in DCOPClient::disconnectDCOPSignal ()
   from /usr/lib/libDCOP.so.4
#19 0xb63a6c2a in DCOPObject::~DCOPObject () from /usr/lib/libDCOP.so.4
#20 0xb7335868 in KDirListerCache::~KDirListerCache ()
   from /usr/lib/libkio.so.4
#21 0xb739d4c3 in KStaticDeleter<KDirListerCache>::destructObject ()
   from /usr/lib/libkio.so.4
#22 0xb6d58bb5 in KGlobal::deleteStaticDeleters ()
   from /usr/lib/libkdecore.so.4
#23 0xb6de334f in KApplication::~KApplication () from /usr/lib/libkdecore.so.4
#24 0x0808d805 in KToggleAction::metaObject ()
#25 0x081ef926 in QWizard::setFinish ()
#26 0xb63d0ea2 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#27 0x08086791 in ?? ()
#0  0xffffe410 in __kernel_vsyscall ()


==== kdBacktrace() ================
Comment 11 Mark Kretschmann 2006-03-06 12:29:34 UTC
On Monday 06 March 2006 12:05, Fran wrote:
> franqui Atlantis:~$ amarok --version
> Qt: 3.3.4
> KDE: 3.5.1
> amaroK: 1.3.1


You realize that 1.3.1 is completely outdated?
Comment 12 Jaakko Lintula 2006-05-19 10:28:26 UTC
KDE 3.5.2, amaroK 1.4.0: this bug still exists, only manual proxy settings are safe.
Comment 13 Stan Vernaillen 2006-10-14 09:52:59 UTC
confirmed on amarok 1.4.3 on kde 3.5.3
Comment 14 Alexandre Oliveira 2006-11-02 02:41:44 UTC
Dude, that's a bizarre bug.
Comment 15 Alexandre Oliveira 2006-11-02 11:00:07 UTC
SVN commit 601148 by aoliveira:

The bizarre "hangs when using a proxy set by a script" bug was just QString thread unsafety showing up once again.
BUG: 112437



 M  +3 -1      scrobbler.cpp  


--- trunk/extragear/multimedia/amarok/src/scrobbler.cpp #601147:601148
@@ -19,6 +19,7 @@
 #include <unistd.h>
 
 #include <qdatetime.h>
+#include <qdeepcopy.h>
 
 #include <kapplication.h>
 #include <kio/job.h>
@@ -65,6 +66,7 @@
  */
 void Scrobbler::similarArtists( const QString & artist )
 {
+    QString safeArtist = QDeepCopy<QString>( artist );
     if ( AmarokConfig::retrieveSimilarArtists() )
     {
 //         Request looks like this:
@@ -97,7 +99,7 @@
         QDomElement param1 = reqdoc.createElement( "param" );
         QDomElement value1 = reqdoc.createElement( "value" );
         QDomElement type1 = reqdoc.createElement( "string" );
-        QDomText param1Value = reqdoc.createTextNode( artist );
+        QDomText param1Value = reqdoc.createTextNode( safeArtist );
         type1.appendChild( param1Value );
         value1.appendChild( type1 );
         param1.appendChild( value1 );
Comment 16 Marc Cramdal 2006-11-29 13:44:16 UTC
I reopen the bug since it occurs again.

http://mail.kde.org/pipermail/amarok/2006-November/002090.html

Actually, I have this bug since Magnatune integration or so. I'm running current svn. And it only crashes when I automatically gets the proxy configuration. If set manually, it works like a charm.
Comment 17 LuRan 2006-12-16 14:26:18 UTC
I confirm the bug is still there, with svn snapshot from yesterday. But amarok does not crash, most of the time just the context browser hangs, and when I close amarok the programe does not quit, saying it's waiting for some thread to end, I have to kill it by hand since appearently the thread never end :(
Comment 18 Michael Scherer 2007-04-02 15:30:46 UTC
I also have the problem, and i am only using the last.fm plugin ( using global tags, but also the neighboor radio ). I use a squid http proxy, sound is playing, but the interface is not responding. I see this in console :

$ LC_ALL=C LANG=C amarok
Amarok: [Loader] Starting amarokapp..
Amarok: [Loader] Don't run gdb, valgrind, etc. against this binary! Use amarokapp.
kdecore (KAction): WARNING: KAction::insertKAccel( kaccel = 0x8091b08 ): KAccel object already contains an action name "play_pause"
QLayout "unnamed" added to QVBox "unnamed", which already has a layout
kdecore (KAction): WARNING: KAction::insertKAccel( kaccel = 0x8091b08 ): KAccel object already contains an action name "play_pause"
QLayout: Adding KToolBar/mainToolBar (child of QVBox/unnamed) to layout for PlaylistWindow/PlaylistWindow
~ $ QColor::setRgb: RGB parameter(s) out of range
QColor::setRgb: RGB parameter(s) out of range
QColor::setRgb: RGB parameter(s) out of range
amarok: ERROR: : couldn't create slave : Impossible de créer le module d'entrées/sorties :
klauncher a retourné : Problème de chargement de «amarok "%u"».
amarok:

then it work for some time.

Very strange! got a DCOPReply opcode, but we were not waiting for a reply!

and then, after some time, amarok interface do not respond ( like 5 minutes after ). Using strace and lsof, i see that amarokapp is waiting on a answer from a socket, and this socket is linked to dcopserver. dcopserver is running fine however.
Comment 19 Michael Scherer 2007-04-02 16:05:55 UTC
For the record, direct connection to the internet are fordidden on the lan, and there is no drop in the firewall log, nor anything special in the proxy log.

However, I have noticed the error didn't appeared until I started to surf the web with konqueror. It worked for 15 minutes without problem, then, i browsed the web, and the DCOPReply error appeared, and soon after, amarok interface freezed. 
Comment 20 Dimitriy Remerov 2007-09-23 07:03:04 UTC
griffon@analytic:~/.kde/share/apps/amarok$ amarok --version
Qt: 3.3.7
KDE: 3.5.7
Amarok: 1.4.7

Bug confirmed in this version. As said before, only when using proxy script in KDE Network Settings. With manual proxy all is okay.
Comment 21 Jeff Mitchell 2007-09-23 17:24:19 UTC
I've been behind a PAC file for two years and I've never had this problem...
Comment 22 Paul Wijhenke 2008-02-20 20:47:08 UTC
Qt: 3.3.7
KDE: 3.5.9
Amarok: 1.4.8

confirmed in Kubuntu Gutsy, also on the official KDE: 3.5.8.

this seems to be a nice indication, when running from a console of from .xsession-errors:
Very strange! got a DCOPReply opcode, but we were not waiting for a reply! 
 
Comment 23 Lydia Pintscher 2008-08-05 23:46:09 UTC
Is this still happening with Amarok 2 and KDE 4.1?
Comment 24 Jeff Mitchell 2008-09-09 14:11:39 UTC
"Very strange! got a DCOPReply opcode, but we were not waiting for a reply! "

No, that actually is not an indication, it's quite common and means nothing.

Anyways, A1 is no longer actively developed, in security-only mode, so this will not be getting fixed.  Hopefully A2 will work better for you.  If it's actually various QString thread-unsafety issues, that shouldn't be a problem any longer in A2, as Qt4 is much better in that regard (and so is our code :-) )