Bug 110077 - Knode interpretes Message-Id when MID doesn't have "news:" identifier - $ is translated to %24
Summary: Knode interpretes Message-Id when MID doesn't have "news:" identifier - $ is ...
Status: RESOLVED FIXED
Alias: None
Product: knode
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-08-03 06:29 UTC by Alexander Skwar
Modified: 2007-12-06 11:24 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Message referenced to in the bug. (1.98 KB, text/plain)
2005-08-03 06:31 UTC, Alexander Skwar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Skwar 2005-08-03 06:29:24 UTC
Version:           0.9.2 (using KDE KDE 3.4.2)
Installed from:    Gentoo Packages
OS:                Linux

Please see the article <news:dcpinl.28c.1@news.christoph.schneegans.de> in the German newsgroup de.comm.software.newsreader

Quoting from that article:


>>>> <dcjbm2$a02$1@online.de>
[...]
> 2005.08.02 20:33:30 I   {68c} > ARTICLE <dcjbm2%24a02%241@online.de>
> 2005.08.02 20:33:30 I   {68c} < 430 Gesuchter Artikel wird beim nächsten News-Pull auf allen Servern gesucht.


Here, the Knode 0.9.2 (and also 0.8.1) user left clicked on the Message-Id <dcjbm2$a02$1@online.de>. Since that string/item doesn't start with "news: in between the angles, Knode prompts if this "thing" is supposed to be a Message-Id or a E-Mail address. Upon selecting "Message-Id", Knode tries to download the message using the Message-Id.

As you can see a few lines further down (excerpt from a Hamster log), it tried to fetch the article with the Message-Id

          <dcjbm2%24a02%241@online.de>

The correct ID is:

          <dcjbm2$a02$1@online.de>

As you can see, the "$" got translated to "%24". That's, obviously, wrong.

The error is not related to Hamster. On my system, I've got Leafnode running and I'm also unable to fetch a message that way.
Comment 1 Alexander Skwar 2005-08-03 06:31:06 UTC
Created attachment 12056 [details]
Message referenced to in the bug.
Comment 2 Volker Krause 2005-10-01 12:05:22 UTC
This works with KDE3.5 if you either have the news: prefix or use Edit -> Fetch article by ID. 
Without the news: prefix KNode interprets such URL's now as email addresses per default.
Comment 3 Arne Schmitz 2007-12-06 10:27:23 UTC
This is a duplicate of bug 117273 (or the other way around). Also I think this bug should be reopened, since the new default behaviour is more complicated than in KDE 3.4.
Comment 4 Rolf Eike Beer 2007-12-06 10:51:26 UTC
No, they have nothing to do with each other. This bug is about a bad "translation" of characters in the message-id.
Comment 5 Arne Schmitz 2007-12-06 11:24:37 UTC
ok, my bad. sorry.