Bug 109059 - expired OpenPGP key gives bogus time to expiration in "OpenPGP Key Expires Soon" dialog
Summary: expired OpenPGP key gives bogus time to expiration in "OpenPGP Key Expires So...
Status: RESOLVED DUPLICATE of bug 83079
Alias: None
Product: kmail
Classification: Applications
Component: encryption (show other bugs)
Version: 1.8
Platform: unspecified Linux
: NOR normal with 10 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-07-14 09:54 UTC by Leo Davis
Modified: 2007-09-19 19:20 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Dialog Windows Screenshot German Language (23.78 KB, image/jpeg)
2007-06-13 15:02 UTC, sven
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leo Davis 2005-07-14 09:54:27 UTC
Version:           1.8 (using KDE 3.4.0 Level "b" , SUSE 9.3 UNSUPPORTED)
Compiler:          gcc version 3.3.5 20050117 (prerelease) (SUSE Linux)
OS:                Linux (i686) release 2.6.11.4-20a-smp

I have an expired OpenPGP signing and encryption key configured in the Cryptography section of my identity.  Now when I:

1) Compose a new message
2) Click on the Send Now toolbar button
3) Click the Continue button on the "Unusable Encryption Keys" dialog.
4) Observe the contents of the "OpenPGP Key Expires Soon" dialog:

Your OpenPGP signing key
... (KeyID 0x3FE2F152)
expires in less than 4294967276 days.

I should not be in this dialog at all -- my key expired 22 days ago. The large number has apparently underflowed an unsigned quantity.
Comment 1 sven 2007-06-13 15:02:22 UTC
Created attachment 20846 [details]
Dialog Windows Screenshot German Language
Comment 2 sven 2007-06-13 15:04:04 UTC
Also in KMail Version 1.9.1 (debian based)
Comment 3 Rolf Eike Beer 2007-09-19 19:20:59 UTC

*** This bug has been marked as a duplicate of 83079 ***