Bug 83079 - openPGP expire warning states 4Gig days left
Summary: openPGP expire warning states 4Gig days left
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail
Classification: Applications
Component: encryption (show other bugs)
Version: 1.6.52
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: triaged
: 85787 109059 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-06-09 09:19 UTC by Martin Koller
Modified: 2015-04-12 09:57 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
a snapshot of the error window (26.56 KB, image/png)
2004-07-12 21:26 UTC, Simone Piunno
Details
KMail 1.9.5 compiled for x86-64 Debian ‘Etch‘ (16.31 KB, image/png)
2008-01-05 16:03 UTC, Daniel Aleksandersen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Koller 2004-06-09 09:19:56 UTC
Version:           1.6.52 (using KDE 3.2.90 (3.3 alpha1, CVS >= 20040522), compiled sources)
Compiler:          gcc version 3.2.3
OS:                Linux (i686) release 2.4.22

Trying to send a mail which shall be signed pops up a dialog:

Your OpenPGP signing key
Martin Koller (KeyID 0x8DFB0F86)
expires in less than 4294954719 days.

Well, yes ... and ? ;-)

(The key has unlimited expiration)
Comment 1 Simone Piunno 2004-07-12 21:26:14 UTC
Created attachment 6645 [details]
a snapshot of the error window

look here for an example.
Comment 2 David Faure 2004-07-23 15:56:36 UTC
*** Bug 85787 has been marked as a duplicate of this bug. ***
Comment 3 Marcin Kasperski 2004-07-23 15:59:17 UTC
Note: in my case (bug 85787) I got this error although the message has *NOT* been signed.
Comment 4 Till Maas 2004-07-28 18:43:08 UTC
Got the same error in 3.2.92
Comment 5 Marc Mutz 2004-10-07 19:40:36 UTC
Can s/o of you please attach a gdb to and say something like:

gdb> break 'GpgME::Key::neverExpires()'
<let it hit the breakpoint>
gdb> print *theGpgMEKeyObject.d->key

Thanks.
Comment 6 Martin Koller 2004-10-07 21:28:26 UTC
As I have already upgraded to latest CVS, and also updated all the crypto stuff kmail uses, I can no longer reproduce this.
Comment 7 Trejkaz Xaoza 2004-10-08 02:19:37 UTC
Me neither.  I'm not even on the latest CVS but on 3.3.0 with all the crypto dependencies updated, it's not happening anymore.
Comment 8 Tom Albers 2004-10-08 09:51:30 UTC
I have seen it in a beta 3.3 as well, but not in the official 3.3. Lets close until someone reports it again.
Comment 9 Stephan Fudeus 2005-03-03 17:37:45 UTC
Ok, lets report it again:

I just saw a message saying that my key expires in less than 4294967294 days while sending a message.
I did NOT sign it and the key expired 4 days ago.
I'm using KDE 3.3.2.
Comment 10 David Faure 2005-03-03 18:22:42 UTC
Reopening then - can you try the gdb session suggested by Marc?
Comment 11 Stephan Fudeus 2005-03-13 14:59:50 UTC
Ok, I tried but I'm not quite expirienced with gdb. 
I tried to break on GpgME::Key::neverExpires() and on GpgME::Key::isExpired() (because in my case the key is already expired), but I'm afraid gdb did not stop when I sent the message (and got again the message, that my key expires in 4......... days).

This might be a silly question but might it be a problem that gdb says:
(gdb) break 'GpgME::Key::isExpired()'
Function "GpgME::Key::isExpired()" not defined.
Make breakpoint pending on future shared library load? (y or [n]) y
Breakpoint 1 ('GpgME::Key::isExpired()') pending.

Are there any special flags i have to compile gpgme or kdepim with?
fyi: I am using gpgme-1.0.2
Comment 12 David Faure 2005-03-13 15:56:45 UTC
> (gdb) break 'GpgME::Key::isExpired()'

Try
break 'GpgME::Key::isExpired(
and then press <tab> to complete it.

Make sure to start kmail first [in gdb], set the breakpoint only after interrupting kmail with Ctrl+C in gdb.
Comment 13 Stephan Fudeus 2005-03-13 16:25:49 UTC
Ok, no it hit the breakpoint, but the symbol Marc mentioned was not found. 
This might be a special case for keys that never expire. For which symbol shall I look?

(gdb) print *theGpgMEKeyObject.d->key
No symbol "theGpgMEKeyObject" in current context.
Comment 14 Stephan Fudeus 2005-03-25 16:27:31 UTC
This bug is also valid for me in kde-3.4.
Comment 15 Rolf Eike Beer 2007-09-19 19:21:00 UTC
*** Bug 109059 has been marked as a duplicate of this bug. ***
Comment 16 Daniel Tryba 2007-10-22 11:01:01 UTC
This bug still exists in kmail/1.9.7 (kontact/1.2.5) with KDE 3.5.7.
A key that expired 5 days ago, will expire in less than 4294967293 days according to the dialog
Comment 17 Daniel Aleksandersen 2008-01-05 16:03:17 UTC
Created attachment 22848 [details]
KMail 1.9.5 compiled for x86-64 Debian ‘Etch‘
Comment 18 Florian Reinhard 2008-03-10 17:32:38 UTC
same here for kmail "Version 1.9.6 (enterprise 0.20070907.709405)" on Kubuntu 7.10-x86 with kde 3.5.8. Expired 3days ago and shows 4294967294.
Comment 19 Salvatore Brigaglia 2008-11-09 15:03:32 UTC
Tested with a certificate expired two days ago. It says that the key is expiring in less than -2 Days...

So Kmail threats expired certificates as an expiring one.
(bug triage day 09 november 2008), opensourcecat.
Comment 20 Laurent Montel 2015-04-12 09:57:13 UTC
Thank you for taking the time to file a bug report.

KMail2 was released in 2011, and the entire code base went through significant changes. We are currently in the process of porting to Qt5 and KF5. It is unlikely that these bugs are still valid in KMail2.

We welcome you to try out KMail 2 with the KDE 4.14 release and give your feedback.