Bug 109035 - Kalzium crashes after clicking on Next/Previous in element detail info dialog
Summary: Kalzium crashes after clicking on Next/Previous in element detail info dialog
Status: CLOSED WORKSFORME
Alias: None
Product: kalzium
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kalzium Developers
URL:
Keywords:
: 115767 122268 123883 135077 142131 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-07-13 19:50 UTC by Jure Repinc
Modified: 2007-02-24 11:17 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
hacky work around (1) (626 bytes, patch)
2005-07-31 16:33 UTC, Joseph Wenninger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jure Repinc 2005-07-13 19:50:35 UTC
Version:           SVN (using KDE Devel)
Installed from:    Compiled sources
Compiler:          GCC 3.4.4 
OS:                Linux

I just compiled Kalzium from SVN and I it crashes if you open a detailed info dialog for any element, go to section Chemical Data (or Energies or Miscellaneous or Spectrum) and then click on the Next or Previous button.

Here is the backtrace:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 46912589574528 (LWP 8021)]
0x00002aaaaf193054 in waitpid () from /lib/libpthread.so.0
#0  0x00002aaaaf193054 in waitpid () from /lib/libpthread.so.0
#1  0x00002aaaacbab0e1 in KCrash::defaultCrashHandler (sig=11)
    at /home/kdedev/src/kde/kdelibs/kdecore/kcrash.cpp:251
#2  0x00002aaaaf74c4a0 in killpg () from /lib/libc.so.6
#3  0x0000000000000000 in ?? ()
#4  0x0000000000000000 in ?? ()
#5  0x0000000000000000 in ?? ()
#6  0x00007fff00000002 in ?? ()
#7  0x0000000000000000 in ?? ()
#8  0x00000000008d33f0 in ?? ()
#9  0x0000000000000029 in ?? ()
#10 0x00000000008d3400 in ?? ()
#11 0x00002aaaad8f800c in QWidget::QWidget () at qwidget.cpp:921
#12 0x00002aaaada089fa in QWidgetStack::raiseWidget (this=0xa10f90, w=0x8b0870)
    at qwidgetstack.cpp:383
#13 0x00002aaaac4a1e2c in KJanusWidget::showPage (this=0x866770, w=0x8b0870)
    at /home/kdedev/src/kde/kdelibs/kdeui/kjanuswidget.cpp:598
#14 0x00002aaaac4a2049 in KJanusWidget::showPage (this=0x866770, index=2)
    at /home/kdedev/src/kde/kdelibs/kdeui/kjanuswidget.cpp:584
#15 0x00002aaaac4a1c94 in KJanusWidget::slotShowPage (this=0x866770)
    at /home/kdedev/src/kde/kdelibs/kdeui/kjanuswidget.cpp:569
#16 0x00002aaaac4a3068 in KJanusWidget::qt_invoke (this=0x866770, _id=46, 
    _o=0x7ffffffedfe0) at kjanuswidget.moc:128
#17 0x00002aaaad8c9f3f in QObject::activate_signal (this=0xa4aae0, 
    clist=0xa4a640, o=0x7ffffffedfe0) at qobject.cpp:2355
#18 0x00002aaaad8c9df1 in QObject::activate_signal (this=0xa4aae0, signal=13)
    at qobject.cpp:2324
#19 0x00002aaaadbfd819 in QListBox::selectionChanged (this=0xa4aae0)
    at moc_qlistbox.cpp:305
#20 0x00002aaaad99e1a1 in QListBox::takeItem (this=0xa4aae0, item=0x947830)
    at qlistbox.cpp:4255
#21 0x00002aaaad9938ce in ~QListBoxItem (this=0x947830) at qlistbox.cpp:393
#22 0x00002aaaac4a56b3 in ~IconListItem (this=0x947830)
    at /home/kdedev/src/kde/kdelibs/kdeui/kjanuswidget.cpp:1150
#23 0x00002aaaac4a2f4c in KJanusWidget::removePage (this=0x866770, 
    page=0x947aa0) at qmap.h:133
#24 0x00002aaaac4a30b3 in KJanusWidget::qt_invoke (this=0x866770, _id=49, 
    _o=0x7ffffffee260) at qucom_p.h:312
#25 0x00002aaaad8c9f3f in QObject::activate_signal (this=0x947aa0, 
    clist=0x8d44f0, o=0x7ffffffee260) at qobject.cpp:2355
#26 0x00002aaaadbeb6e1 in QObject::destroyed (this=0x947aa0, t0=0x947aa0)
    at moc_qobject.cpp:118
#27 0x00002aaaad8c6b50 in ~QObject (this=0x947aa0) at qobject.cpp:445
#28 0x00002aaaad8f82b5 in ~QWidget (this=0x947aa0) at qwidget.cpp:983
#29 0x00002aaaadbf86b1 in ~QFrame (this=0x947aa0) at moc_qframe.cpp:49
#30 0x000000000042842f in DetailedInfoDlg::setElement (this=0x866a10, 
    element=0x0) at qvaluelist.h:110
#31 0x000000000042869b in DetailedInfoDlg::slotUser1 (this=0x866a10)
    at /home/kdedev/src/kde/kdeedu/kalzium/src/detailinfodlg.cpp:374
#32 0x00002aaaac49ae70 in KDialogBase::qt_invoke (this=0x866a10, _id=72, 
    _o=0x7ffffffee4c0) at kdialogbase.moc:358
#33 0x00000000004257ef in DetailedInfoDlg::qt_invoke (this=0x866a10, _id=72, 
    _o=0x7ffffffee4c0) at detailinfodlg.moc:106
#34 0x00002aaaad8c9f3f in QObject::activate_signal (this=0x803800, 
    clist=0x9d89b0, o=0x7ffffffee4c0) at qobject.cpp:2355
#35 0x00002aaaad8c9df1 in QObject::activate_signal (this=0x803800, signal=4)
    at qobject.cpp:2324
#36 0x00002aaaadbf37f1 in QButton::clicked (this=0x803800)
    at moc_qbutton.cpp:152
#37 0x00002aaaad9560ac in QButton::mouseReleaseEvent (this=0x803800, 
    e=0x7ffffffeea50) at qbutton.cpp:836
#38 0x00002aaaad8fdcd8 in QWidget::event (this=0x803800, e=0x7ffffffeea50)
    at qwidget.cpp:4676
#39 0x00002aaaad86ca5c in QApplication::internalNotify (this=0x7ffffffef100, 
    receiver=0x803800, e=0x7ffffffeea50) at qapplication.cpp:2635
#40 0x00002aaaad86c330 in QApplication::notify (this=0x7ffffffef100, 
    receiver=0x803800, e=0x7ffffffeea50) at qapplication.cpp:2421
#41 0x00002aaaacb06d61 in KApplication::notify (this=0x7ffffffef100, 
    receiver=0x803800, event=0x7ffffffeea50)
    at /home/kdedev/src/kde/kdelibs/kdecore/kapplication.cpp:549
#42 0x00002aaaad8022ac in QApplication::sendSpontaneousEvent (
    receiver=0x803800, event=0x7ffffffeea50) at qapplication.h:494
#43 0x00002aaaad7fcd60 in QETWidget::translateMouseEvent (this=0x803800, 
    event=0x7ffffffeef80) at qapplication_x11.cpp:4292
#44 0x00002aaaad7faac4 in QApplication::x11ProcessEvent (this=0x7ffffffef100, 
    event=0x7ffffffeef80) at qapplication_x11.cpp:3443
#45 0x00002aaaad8144e6 in QEventLoop::processEvents (this=0x6b2180, flags=4)
    at qeventloop_x11.cpp:192
#46 0x00002aaaad87f98c in QEventLoop::enterLoop (this=0x6b2180)
    at qeventloop.cpp:198
#47 0x00002aaaad87f889 in QEventLoop::exec (this=0x6b2180)
    at qeventloop.cpp:145
#48 0x00002aaaad86cb74 in QApplication::exec (this=0x7ffffffef100)
    at qapplication.cpp:2758
#49 0x0000000000415684 in main (argc=5685456, argv=0x73b0a0)
    at /home/kdedev/src/kde/kdeedu/kalzium/src/main.cpp:77
Comment 1 Carsten Niehaus 2005-07-14 17:13:06 UTC
Please try again. I fixed a million things in the spectrum code. For example, that widget only shows up when there is acutally data for the widget to display. If you cannot confirm I will close this as fixed.
For me it works.
Comment 2 Jure Repinc 2005-07-14 22:36:55 UTC
Just updated sources a few minutes ago and recompiled kdeedu and it still crashes.
Comment 3 Jure Repinc 2005-07-18 16:20:18 UTC
Still crashes using todays SVN. But this time I get a little bit different backtrace.

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 46912589578624 (LWP 29853)]
0x00002aaaaf194054 in waitpid () from /lib/libpthread.so.0
#0  0x00002aaaaf194054 in waitpid () from /lib/libpthread.so.0
#1  0x00002aaaacbac0e1 in KCrash::defaultCrashHandler (sig=11)
    at /home/kdedev/src/kde/kdelibs/kdecore/kcrash.cpp:251
#2  0x00002aaaaf74d4a0 in killpg () from /lib/libc.so.6
#3  0x0000000000000000 in ?? ()
#4  0x0000000000000000 in ?? ()
#5  0x0000000000000000 in ?? ()
#6  0x00007fff00000002 in ?? ()
#7  0x0000000000000000 in ?? ()
#8  0x000000000074b160 in ?? ()
#9  0x0000000000000029 in ?? ()
#10 0x000000000074b170 in ?? ()
#11 0x0000000000000020 in ?? ()
#12 0x00007fffff9cd970 in ?? ()
#13 0x0000000000a06a70 in ?? ()
#14 0x00007fffff9ce3e0 in ?? ()
#15 0x000000000093cc50 in ?? ()
#16 0x00000000009b83a0 in ?? ()
#17 0x0000000000000008 in ?? ()
#18 0x00007fffff9cd760 in ?? ()
#19 0x0000000000007fff in ?? ()
#20 0x0000000000000008 in ?? ()
#21 0x00007fffff9cd738 in ?? ()
#22 0x0000000000b0f6b0 in ?? ()
#23 0x00007fffff9cd720 in ?? ()
#24 0x00002aaaad8c9886 in QObject::checkConnectArgs (this=0x9b83a0, 
    signal=0x8 <Address 0x8 out of bounds>, member=0xb0f6b0 "°ůó­Ş*")
    at qobject.cpp:1615
#25 0x00002aaaada099fa in QWidgetStack::raiseWidget (this=0xb862e0, w=0x765410)
    at qwidgetstack.cpp:383
#26 0x00002aaaac4a2eec in KJanusWidget::showPage (this=0xa06930, w=0x765410)
    at /home/kdedev/src/kde/kdelibs/kdeui/kjanuswidget.cpp:598
#27 0x00002aaaac4a3109 in KJanusWidget::showPage (this=0xa06930, index=156)
    at /home/kdedev/src/kde/kdelibs/kdeui/kjanuswidget.cpp:584
#28 0x00002aaaac4a2d54 in KJanusWidget::slotShowPage (this=0xa06930)
    at /home/kdedev/src/kde/kdelibs/kdeui/kjanuswidget.cpp:569
#29 0x00002aaaac4a4128 in KJanusWidget::qt_invoke (this=0xa06930, _id=46, 
    _o=0x7fffff9cd970) at kjanuswidget.moc:128
#30 0x00002aaaad8caf3f in QObject::activate_signal (this=0x741b60, 
    clist=0x925370, o=0x7fffff9cd970) at qobject.cpp:2355
#31 0x00002aaaad8cadf1 in QObject::activate_signal (this=0x741b60, signal=13)
    at qobject.cpp:2324
#32 0x00002aaaadbfe819 in QListBox::selectionChanged (this=0x741b60)
    at moc_qlistbox.cpp:305
#33 0x00002aaaad99f1a1 in QListBox::takeItem (this=0x741b60, item=0x867810)
    at qlistbox.cpp:4255
#34 0x00002aaaad9948ce in ~QListBoxItem (this=0x867810) at qlistbox.cpp:393
#35 0x00002aaaac4a6773 in ~IconListItem (this=0x867810)
    at /home/kdedev/src/kde/kdelibs/kdeui/kjanuswidget.cpp:1150
#36 0x00002aaaac4a400c in KJanusWidget::removePage (this=0xa06930, 
    page=0x9b83a0) at qmap.h:133
#37 0x00002aaaac4a4173 in KJanusWidget::qt_invoke (this=0xa06930, _id=49, 
    _o=0x7fffff9cdbf0) at qucom_p.h:312
#38 0x00002aaaad8caf3f in QObject::activate_signal (this=0x9b83a0, 
    clist=0xadca40, o=0x7fffff9cdbf0) at qobject.cpp:2355
#39 0x00002aaaadbec6e1 in QObject::destroyed (this=0x9b83a0, t0=0x9b83a0)
    at moc_qobject.cpp:118
#40 0x00002aaaad8c7b50 in ~QObject (this=0x9b83a0) at qobject.cpp:445
#41 0x00002aaaad8f92b5 in ~QWidget (this=0x9b83a0) at qwidget.cpp:983
#42 0x00002aaaadbf96b1 in ~QFrame (this=0x9b83a0) at moc_qframe.cpp:49
#43 0x0000000000424b5f in DetailedInfoDlg::setElement (this=0xaf2930, 
    element=0x0) at qvaluelist.h:110
#44 0x0000000000424dcb in DetailedInfoDlg::slotUser1 (this=0xaf2930)
    at /home/kdedev/src/kde/kdeedu/kalzium/src/detailinfodlg.cpp:378
#45 0x00002aaaac49bf30 in KDialogBase::qt_invoke (this=0xaf2930, _id=72, 
    _o=0x7fffff9cde50) at kdialogbase.moc:358
#46 0x0000000000421cef in DetailedInfoDlg::qt_invoke (this=0xaf2930, _id=72, 
    _o=0x7fffff9cde50) at detailinfodlg.moc:106
#47 0x00002aaaad8caf3f in QObject::activate_signal (this=0x93cc50, 
    clist=0x9e3c30, o=0x7fffff9cde50) at qobject.cpp:2355
#48 0x00002aaaad8cadf1 in QObject::activate_signal (this=0x93cc50, signal=4)
    at qobject.cpp:2324
#49 0x00002aaaadbf47f1 in QButton::clicked (this=0x93cc50)
    at moc_qbutton.cpp:152
#50 0x00002aaaad9570ac in QButton::mouseReleaseEvent (this=0x93cc50, 
    e=0x7fffff9ce3e0) at qbutton.cpp:836
#51 0x00002aaaad8fecd8 in QWidget::event (this=0x93cc50, e=0x7fffff9ce3e0)
    at qwidget.cpp:4676
#52 0x00002aaaad86da5c in QApplication::internalNotify (this=0x7fffff9cea90, 
    receiver=0x93cc50, e=0x7fffff9ce3e0) at qapplication.cpp:2635
#53 0x00002aaaad86d330 in QApplication::notify (this=0x7fffff9cea90, 
    receiver=0x93cc50, e=0x7fffff9ce3e0) at qapplication.cpp:2421
#54 0x00002aaaacb07d61 in KApplication::notify (this=0x7fffff9cea90, 
    receiver=0x93cc50, event=0x7fffff9ce3e0)
    at /home/kdedev/src/kde/kdelibs/kdecore/kapplication.cpp:549
#55 0x00002aaaad8032ac in QApplication::sendSpontaneousEvent (
    receiver=0x93cc50, event=0x7fffff9ce3e0) at qapplication.h:494
#56 0x00002aaaad7fdd60 in QETWidget::translateMouseEvent (this=0x93cc50, 
    event=0x7fffff9ce910) at qapplication_x11.cpp:4292
#57 0x00002aaaad7fbac4 in QApplication::x11ProcessEvent (this=0x7fffff9cea90, 
    event=0x7fffff9ce910) at qapplication_x11.cpp:3443
#58 0x00002aaaad8154e6 in QEventLoop::processEvents (this=0x6b4b10, flags=4)
    at qeventloop_x11.cpp:192
#59 0x00002aaaad88098c in QEventLoop::enterLoop (this=0x6b4b10)
    at qeventloop.cpp:198
#60 0x00002aaaad880889 in QEventLoop::exec (this=0x6b4b10)
    at qeventloop.cpp:145
#61 0x00002aaaad86db74 in QApplication::exec (this=0x7fffff9cea90)
    at qapplication.cpp:2758
#62 0x0000000000415844 in main (argc=5697808, argv=0x73dcd0)
    at /home/kdedev/src/kde/kdeedu/kalzium/src/main.cpp:77
Comment 4 Carsten Niehaus 2005-07-18 18:48:23 UTC
These are the problematic lines:

#30 0x000000000042842f in DetailedInfoDlg::setElement (this=0x866a10, 
     element=0x0) at qvaluelist.h:110 
#31 0x000000000042869b in DetailedInfoDlg::slotUser1 (this=0x866a10) 
     at /home/kdedev/src/kde/kdeedu/kalzium/src/detailinfodlg.cpp:374 

But I have 0.0 clue, how this can happen. I clicked on those buttons a hundred times since you reported, it never crashed. Same for others... Did you do a "make install" after "svn up"? Did you try to "make clean"?
Please tell me which distro you are using, which Qt, which KDE-version. I will ask more people to try to reproduce this.
Comment 5 Jure Repinc 2005-07-18 18:56:40 UTC
Yup. I did try with clean kdeedu sources and with clean kdeedu build dir. I'm using Gentoo Linux (64-bit AMD64 mode). Qt is 3.3.4 from qt-copy from KDE SVN, KDE is 3.5 trunk from SVN.
Comment 6 Carsten Niehaus 2005-07-19 11:07:14 UTC
Backtrace from Martin Pfeiffer, also a 64-bit machine, but running in 32-bit mode. 

Using host libthread_db library "/lib/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 1102096992 (LWP 23712)]
[KCrash handler]
#7  0x00000002 in ?? ()
#8  0x4137e2fd in QWidgetStack::raiseWidget ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#9  0x40b7c30a in KJanusWidget::showPage (this=)
    at /home/kdesrc/trunk/KDE/kdelibs/kdeui/kjanuswidget.cpp:598
#10 0x40b7c51a in KJanusWidget::showPage (this=)
    at /home/kdesrc/trunk/KDE/kdelibs/kdeui/kjanuswidget.cpp:584
#11 0x40b7c015 in KJanusWidget::slotShowPage (this=)
    at /home/kdesrc/trunk/KDE/kdelibs/kdeui/kjanuswidget.cpp:561
#12 0x40b7c119 in KJanusWidget::qt_invoke (this=) at kjanuswidget.moc:128
#13 0x412372ee in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#14 0x41237a96 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#15 0x4159054c in QListBox::selectionChanged ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#16 0x4130c21b in QListBox::takeItem () from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0x41310f2c in QListBoxItem::~QListBoxItem ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#18 0x40b7fe53 in ~IconListItem (this=0xbfffe164) at kjanuswidget.moc:171
#19 0x40b7ad78 in KJanusWidget::removePage (this=) at qmap.h:133
#20 0x40b7ae80 in KJanusWidget::pageGone (this=0x81aedc0, obj=0x82f1d68)
    at /home/kdesrc/trunk/KDE/kdelibs/kdeui/kjanuswidget.cpp:253
#21 0x40b7c0ef in KJanusWidget::qt_invoke (this=) at qucom_p.h:312
#22 0x412372ee in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#23 0x4157cfc3 in QObject::destroyed () from /usr/lib/qt3/lib/libqt-mt.so.3
#24 0x4123ab21 in QObject::~QObject () from /usr/lib/qt3/lib/libqt-mt.so.3
#25 0x41271e16 in QWidget::~QWidget () from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0x4158a83b in QFrame::~QFrame () from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0x080753b0 in DetailedInfoDlg::setElement (this=0x83eb608, 
    element=0x8418378) at qvaluelist.h:110
#28 0x080755cc in DetailedInfoDlg::slotUser1 (this=0x83eb608)
    at /home/kdesrc/trunk/KDE/kdeedu/kalzium/src/detailinfodlg.cpp:378
#29 0x40b76f4f in KDialogBase::qt_invoke (this=0x83eb608, _id=)
    at kdialogbase.moc:358
#30 0x080722f6 in DetailedInfoDlg::qt_invoke (this=0x83eb608, _id=73, 
    _o=0xbfffe670) at detailinfodlg.moc:106
#31 0x412372ee in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#32 0x41237a96 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0x415860bc in QButton::clicked () from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0x412cddb4 in QButton::mouseReleaseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#35 0x4126d045 in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#36 0x411d571f in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#37 0x411d7a88 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#38 0x40d76777 in KApplication::notify (this=0xbffff100, receiver=0x81f92e0, 
    event=0xbfffeba0)
    at /home/kdesrc/trunk/KDE/kdelibs/kdecore/kapplication.cpp:549
#39 0x41174033 in QETWidget::translateMouseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#40 0x41172f0d in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#41 0x411837c5 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#42 0x411ed3c1 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#43 0x411ed206 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#44 0x411d719f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#45 0x0805a7bf in main (argc=1, argv=0xbffff2b4)
    at /home/kdesrc/trunk/KDE/kdeedu/kalzium/src/main.cpp:77
Comment 7 cniehaus 2005-07-19 18:18:40 UTC
On Tuesday, 19. July 2005 06:05 pm, Jason Harris wrote:
> > I can try on my amd64 machine at home tonight...
>
> I *do* get the crash on my amd64 machine, but only on those tabs which
> contain an HTMLView part.


Ok, this means three persons can reproduce this crash, all on amd64. All 
non-amd64-machines cannot reproduce this.
I have no access to a amd64-machine so I don't know what to do about it...

Carsten
Comment 8 Carsten Niehaus 2005-07-29 15:54:48 UTC
I changed quite a lot code in the last couple of weeks including the deleting of the spectrum. Would you please check if it is still crashing?
Comment 9 Jure Repinc 2005-07-29 17:40:59 UTC
Just updated the code and recompilled and it stil crashes :(
Comment 10 Joseph Wenninger 2005-07-31 16:33:20 UTC
Created attachment 12013 [details]
hacky work around (1)

Since the what from what I understand the crash happens only happens on amd64
and the stacktraces look severly corrupted, I think it could even be a compiler
bug (would not be the first for that plattform).

The patch is not a real solution, but at least on my amd64 system the crash
vanishes with the small modification
Comment 11 Carsten Niehaus 2005-09-11 15:13:11 UTC
Ok, I just got this crash on a 32bit computer.

Target: i486-linux-gnu
Configured with: ../src/configure -v --enable-languages=c,c++,java,f95,objc,ada,treelang --prefix=/usr --with-gxx-include-dir=/usr/include/c++/4.0.2 --enable-shared --with-system-zlib --libexecdir=/usr/lib --enable-nls --without-included-gettext --enable-threads=posix --program-suffix=-4.0 --enable-__cxa_atexit --enable-libstdcxx-allocator=mt --enable-clocale=gnu --enable-libstdcxx-debug --enable-java-gc=boehm --enable-java-awt=gtk --enable-gtk-cairo --with-java-home=/usr/lib/jvm/java-1.4.2-gcj-4.0-1.4.2.0/jre --enable-mpfr --disable-werror --enable-checking=release i486-linux-gnu
Thread model: posix
gcc version 4.0.2 20050808 (prerelease) (Debian 4.0.1-4ubuntu6)


Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1236724032 (LWP 30528)]
[KCrash handler]
#7  0xb6d460a5 in QListBox::itemRect () from /usr/lib/libqt-mt.so.3
#8  0xb75bfb75 in KJanusWidget::IconListItem::highlight ()
   from /usr/lib/libkdeui.so.4
#9  0xb75bfe44 in KJanusWidget::IconListBox::slotOnItem ()
   from /usr/lib/libkdeui.so.4
#10 0xb75bfe8e in KJanusWidget::slotOnItem () from /usr/lib/libkdeui.so.4
#11 0xb75c05b7 in KJanusWidget::qt_invoke () from /usr/lib/libkdeui.so.4
#12 0xb6c5ea56 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#13 0xb6fd2ac3 in QListBox::onItem () from /usr/lib/libqt-mt.so.3
#14 0xb6d49cd7 in QListBox::mouseMoveEvent () from /usr/lib/libqt-mt.so.3
#15 0xb6c992cd in QWidget::event () from /usr/lib/libqt-mt.so.3
#16 0xb6bf5f80 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#17 0xb6bf6500 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#18 0xb7340ae7 in KApplication::notify () from /usr/lib/libkdecore.so.4
#19 0xb6b86e25 in QApplication::sendSpontaneousEvent ()
   from /usr/lib/libqt-mt.so.3
#20 0xb6b82325 in QETWidget::translateMouseEvent () from /usr/lib/libqt-mt.so.3
#21 0xb6b80c38 in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#22 0xb6b99fff in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#23 0xb6c0dcfb in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#24 0xb6c0dc1e in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#25 0xb6bf4c13 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#26 0x0805f016 in main (argc=1, argv=0xbfb57a44) at main.cpp:92
Comment 12 Carsten Niehaus 2005-11-06 10:37:00 UTC
*** Bug 115767 has been marked as a duplicate of this bug. ***
Comment 13 Volker Hemmann 2006-01-21 07:34:39 UTC
Hi,
I have an amd64 bit system (gentoo), KDe 3.5, used gcc 3.4.4 for most of it and 3.4.5 for kalzium - and it just does not crash. 
I can forward/backward through the whole table, at each view, and it does not crash.

I would like to help you find bugs, but exepct that each element has an abundance of 12 ppm, there are none I can find, sorry.
Comment 14 cniehaus 2006-01-21 18:09:49 UTC
Am Samstag, 21. Januar 2006 07:34 schrieb Volker Hemmann:
> I would like to help you find bugs, but exepct that each element has an
> abundance of 12 ppm, there are none I can find, sorry.


sorry, Kalzium shows you a abundance of 12ppm on every element? Please report 
that as a bug as well.
Comment 15 Pino Toscano 2006-02-14 14:43:50 UTC
SVN commit 509359 by pino:

Ok, here we hare.
I'm backporting almost all the improved Detail Info Dialog from kalzium trunk
(ie kde4) to the 3.5 branch, as last resource to have a Detail Info Dialog
really working without any bug and/or crash.

So, please please, please, reporters and readers of bug 109035, update your
kalzium from kdeedu 3.5.x and say whether it works well without the reported
crash. In case, we'll close this bug.

CCBUG: 109035


 M  +103 -106  detailinfodlg.cpp  
 M  +26 -23    detailinfodlg.h  
 M  +2 -0      orbitswidget.cpp  
 M  +1 -0      spectrumwidget.h  
Comment 16 Krzysztof Lichota 2006-02-15 16:34:51 UTC
I have compiled and installed newest version from Subversion and stressed it for about 10 minutes going back and forth elements in all these tabs (Spectrum, chemical data, Energies) and couldn't reproduce it. I think it is fixed.
Comment 17 Jure Repinc 2006-02-17 17:47:23 UTC
I'll test it out as soon as I get KDE compilling with X.org 7.0.
Comment 18 Pino Toscano 2006-02-19 12:30:18 UTC
*** Bug 122268 has been marked as a duplicate of this bug. ***
Comment 19 Carsten Niehaus 2006-03-19 11:17:38 UTC
*** Bug 123883 has been marked as a duplicate of this bug. ***
Comment 20 Jure Repinc 2006-03-26 04:24:04 UTC
OK I finally got KDE from SVN compilling with the new Xorg and managed to compile kdeedu without solver. And I'm happy to report that there is no more crash for me. So I guess I can safely close the bug and mark it as resolved.
Comment 21 Carsten Niehaus 2006-10-04 09:18:51 UTC
*** Bug 135077 has been marked as a duplicate of this bug. ***
Comment 22 Pino Toscano 2007-02-24 11:17:57 UTC
*** Bug 142131 has been marked as a duplicate of this bug. ***