Bug 109032 - Large images in klipper freeze desktop
Summary: Large images in klipper freeze desktop
Status: RESOLVED FIXED
Alias: None
Product: klipper
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Esben Mose Hansen
URL:
Keywords:
: 113980 124182 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-07-13 17:27 UTC by airfullbete
Modified: 2006-04-08 16:58 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description airfullbete 2005-07-13 17:27:02 UTC
Version:           v0.9.6 (using KDE 3.4.1-1.0.fc4.kde, Fedora)
Compiler:          Target: i386-redhat-linux
OS:                Linux (i686) release 2.6.11-1.1369_FC4

When copying large images, the transfert of the clipboard to klipper takes a long time (several seconds, e.g. 10-20s) and during this time the desktop freezes and is unusable. For example, if I ctrl-c on a 6Mpx image in the gimp, it takes 30 seconds for klipper to load 3 versions of the image. As a result ctrl-c is of no practical use in gimp since the desktop freezes every time.

** The image feature of klipper should be turnable to off **

Currently, the only way I found to have ctrl-c work normally in gimp is to quit klipper.

Thank you.
Comment 2 Lubos Lunak 2006-01-31 15:46:35 UTC
The real solution should be using TARGET_SIZES from http://freedesktop.org/wiki/ClipboardManager . However a quick grep shows Gtk doesn't support it, nor I'd expect anything else to support it :-/, so this wouldn't help right now anyway.
I'll add config option klipperrc:[General]:IgnoreImages defaulting to true to at least disable tracking images completely. Will be in 3.5.2.

Oh, and as for the link posted in comment #1, that person clearly doesn't have much clue about Klipper and its purpose (although the problem mentioned there is true, but as said above, that's fixable).
Comment 3 Lubos Lunak 2006-01-31 15:57:40 UTC
Actually size limiting is a duplicate of bug #33747, so I consider this one fixed.
Comment 4 Lubos Lunak 2006-02-01 15:41:39 UTC
*** Bug 113980 has been marked as a duplicate of this bug. ***
Comment 5 Lubos Lunak 2006-03-27 15:35:50 UTC
*** Bug 124182 has been marked as a duplicate of this bug. ***
Comment 6 Lubos Lunak 2006-03-28 08:40:43 UTC
*** Bug 124182 has been marked as a duplicate of this bug. ***
Comment 7 Maksim Orlovich 2006-04-08 16:58:38 UTC
*** Bug 125170 has been marked as a duplicate of this bug. ***