Bug 108899 - Odd "Show Desktop" behavior returned?
Summary: Odd "Show Desktop" behavior returned?
Status: RESOLVED DUPLICATE of bug 67406
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal with 2 votes (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 129709 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-07-11 05:53 UTC by Brent Kelly
Modified: 2006-10-13 16:55 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brent Kelly 2005-07-11 05:53:36 UTC
Version:            (using KDE KDE 3.4.1)
Installed from:    Gentoo Packages
Compiler:          3.3.5-20050130 
OS:                Linux

Here's the rundown:

- Have a few windows open
- Hit the "Show Desktop" button to minimize all the windows
- Launch an app or file from the desktop or panel
- app is launched an all windows minimized by the "Show Desktop" click are restored

I would figure this was a "feature", but it was quite apparenly labeled as a bug when it existed in kde 3.2
http://bugs.kde.org/show_bug.cgi?id=67406
Comment 1 Lubos Lunak 2005-07-19 15:00:20 UTC
That's intended, it's called "Show Desktop" and not "Minimize All Windows".
Comment 2 Brent Kelly 2005-07-19 16:30:36 UTC
I don't mean to beat a dead horse, but I can't see how a behavior which hasn't exisited in KDE's history except for one time when it was clearly labeled a bug could possibly be intended.  Additionally, I'm confused as to why you would be so quick to label this an intended behaviour when you touched the previous bug 6 times without doing so?
Comment 3 Lubos Lunak 2005-07-26 11:20:01 UTC
If my memory serves me well this feature has worked in several different ways over the time. And I personally think marking the current behaviour as bug back than was a mistake. As for the intention, it's called "Show desktop" - I don't see anything unclear about that. It's meant for temporarily making the desktop available.
If you want a "Minimize all" action, I suggest you submit a wish to Kicker.
Comment 4 John McCawley 2005-07-26 16:38:43 UTC
The current bahavior of "Show Desktop" is, in my opinion, extremely undesirable.

Windows XP has a very smooth behavior.  When you click "Show Desktop", all of your windows are minimized.  If you choose to open only one window, or launch a single program, only that one window is then shown.  If you want your entire desktop back the way it was previously, clicking "Show Desktop" again will bring it back.

In KDE, If I click "Show Desktop", all of my windows are minimized.  (And I'm pretty sure they are minimized, because if I right click on them on the kicker, minimized is checked).  I simply don't understand why restoring an individual window from the taskbar will only restore that one Window, but launching an application from the Kicker or the desktop will restore all of the Windows.  

It just doesn't make any sense.
Comment 5 Lubos Lunak 2005-07-27 10:08:29 UTC
It makes about as much sense as a "show desktop" feature that doesn't sometimes show you the desktop.
And this is not the right place to discuss this anyway, as almost nobody besides me and you reads this. If you feel it's wrong, find some mailing list for the discussion (say, kde-usability).
Comment 6 Richard Neill 2006-02-22 14:43:34 UTC
I agree with comment #4, as do the people in bug 113552. The new behaviour is definitely a mis-feature: it's inconsistent with KDE's behaviour in every version for the last 4 years; it's confusing and it's unhelpful. KDE here is trying to second-guess what I want, and it is doing so wrongly. 

"Show desktop" quite correctly toggles all windows to minimise and back again. BUT, if I press "show desktop" only once, and then start some new window, I don't want all the other windows to suddenly re-maximise. If I wanted that to happen, I'd ask for it by clicking "show desktop" again. 

If this is to be the new behaviour, is there any workaround for it? 


Comment 7 Richard Neill 2006-02-24 03:12:17 UTC
The real problem arises when you want to show desktop and then do stuff on the desktop itself, rather than just temporarily expose it. 

Eg if I right-click a desktop file/icon, and choose properties, then the properties window does come up on top, but it is very confusing to find all the other windows have re-maximised without being requested, and are now obscuring the desktop which I was trying to look at!

That part is definitely a bug: please can we have the old behaviour back, [and a pref to configure it if some people prefer the new behaviour]

Workaround:

Unfortunately, kicker/DCOP don't expose sufficient functionality to 
restore the old behaviour (there is no "listAllWindows() function, nor is there a maximiseWindow() or minimiseWindow() function). 

However, there is wmctrl:  http://sweb.cz/tripie/utils/wmctrl/
So, I shall write a shell script to do this....
Comment 8 Richard Neill 2006-04-23 06:42:35 UTC
Unfortunately, wmctrl doesn't support the one feature necessary: minimising windows. (It can maximis, raise, shade, slice and dice, but it can't minimise!)

Is there *any* way to emulate the old behaviour? I used to use it 20 times a day, and I very much miss it! Please, someone...HELP!
Comment 9 Ronny Standtke 2006-05-14 10:57:49 UTC
I also find the current behavior (v3.5.2) very confusing. I am sorry to say this but the way Windows handles this feature makes much more sense.
Comment 10 Richard Neill 2006-05-22 06:11:14 UTC
Good news: I have finally managed to create a workaround - which exactly mimics the old behaviour. It's a bit of an ugly hack, but so far, it works great :-)

You can download it all (~800kB) from here:
  http://www.richardneill.org/src/kshowdesktop.tar.gz
Read the source kshowdesktop.sh for explanations.

[The 800kB includes the source for wmctrl and devilspie, and some RPMs for Mandriva 2006]

Here's how it works:

1)Use wmctrl to list the windows on the current desktop. Also list sticky windows on all desktops; filter out kicker and KDE Desktop.

2)xwininfo tells us which windows are visible.

3)Either read in the previous state, or save the current state of relevant windows. Ignore old state if it is stale.

4)Write a devilspie rule to match the relevant windows. [I had to add support for unminimize to devilspie]

5)Invoke, then kill devilspie to make it happen.
Comment 11 Philip Rodrigues 2006-06-23 21:13:12 UTC
*** Bug 129709 has been marked as a duplicate of this bug. ***
Comment 12 vatbier 2006-10-12 11:57:36 UTC
In 3.5.4 I also suffer from this "intended feature".
I want my windows minimized unless I tell them myself to restore.
Please change this behaviour.

Thank you,
vatbier
Comment 13 Lubos Lunak 2006-10-13 16:55:19 UTC
.
Comment 14 Lubos Lunak 2006-10-13 16:55:38 UTC

*** This bug has been marked as a duplicate of 67406 ***