Bug 108812 - sftp: changing URL in location bar pops up error messages
Summary: sftp: changing URL in location bar pops up error messages
Status: RESOLVED FIXED
Alias: None
Product: kio
Classification: Unclassified
Component: sftp (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal with 40 votes (vote)
Target Milestone: ---
Assignee: Dawit Alemayehu
URL:
Keywords:
: 118409 168908 173185 180118 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-07-09 17:25 UTC by Marcel Martin
Modified: 2010-02-18 21:24 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
kurlcompletion.diff (477 bytes, text/x-diff)
2005-07-13 19:25 UTC, Dawit Alemayehu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel Martin 2005-07-09 17:25:07 UTC
Version:            (using KDE KDE 3.4.1)
Installed from:    Gentoo Packages
Compiler:          GCC 3.4.4 
OS:                Linux

Assume I view a remote location via SFTP, the address is:
sftp://user@my-sftp-host.example.com/

When I now want to change the address in the location bar, for example changing "my-sftp-host" to "my-other-sftp-host", then after each typed character a dialog pops up saying:

Unexpected SFTP error: 2
Error encountered while talking to ssh.

It looks as if after each keystroke an attempt is made to connect to that incomplete and therefore incorrect URL.
Comment 1 Dawit Alemayehu 2005-07-13 19:25:35 UTC
Hi,

The autocompletion provided by KURLCompletion causes problems for remote 
protocols that support listing, e.g ftp and sftp. If the user tries to edit 
the url in Konqueror's location bar (s)he is liable to get and error message 
because KURLCompletion attempts to provide autocompletion for an invalid URL. 
See http://bugs.kde.org/show_bug.cgi?id=108812. The attached patch disables 
completion support for remote protocols by default.


Created an attachment (id=11789)
kurlcompletion.diff
Comment 2 Dik Takken 2006-01-24 22:09:14 UTC
I also experience this problem on KDE 3.5.0. Autocompletion fails when authentication to the remote host is not completed, so it should be disabled *until* the authentication information has been provided.

The status of this bug is 'unconfirmed', shouldn't this be changed to 'new' or 'assigned'?
Comment 3 Dirk Stoecker 2006-08-18 09:56:15 UTC
*** Bug 118409 has been marked as a duplicate of this bug. ***
Comment 4 Brendon Higgins 2006-11-04 02:58:41 UTC
Same deal here, Debian testing, kde 3.5.5.

sftp doesn't show the error window when trying to autocomplete folders and files that don't exist on the server. What reason does it have to complain when the server it tries to connect to doesn't exist? (I figure that's basically what happens when autocomplete sends the incomplete URL. Not that I actually know how any of it works, though. :-) )
Comment 5 Arne Schmitz 2007-03-13 16:25:28 UTC
Is there any news on this one? The default behaviour is quite annoying. It would be nice if the autocompletion would silently fail, but still be there.
Comment 6 Mats Ahlgren 2007-06-07 13:36:48 UTC
same problem here

seems pretty simple to fix (albeit I haven't looked at the code), see comment #2

I'm not sure what's going on, but if this bug is sending any information to the server behind the user's back, it should be fixed immediately (just my 2 cents)
Comment 7 Tommi Tervo 2009-01-09 12:27:42 UTC
*** Bug 180118 has been marked as a duplicate of this bug. ***
Comment 8 Tommi Tervo 2009-01-09 12:29:26 UTC
*** Bug 173185 has been marked as a duplicate of this bug. ***
Comment 9 David Faure 2009-01-09 13:16:32 UTC
I don't think autocompletion should be disabled, I think errors from kioslaves during autocompletion should simply not show message boxes.
Comment 10 David Faure 2009-01-09 13:50:39 UTC
SVN commit 908187 by dfaure:

Don't call messageBox! Leave GUI handling to the apps - e.g. during autocompletion we certainly don't want a messagebox
Fix will be in 4.2.
BUG: 108812


 M  +11 -4     kio_sftp.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=908187
Comment 11 Marcel Martin 2009-01-09 23:20:00 UTC
Great, thanks for fixing this!
Comment 12 David Faure 2010-02-18 21:24:38 UTC
*** Bug 168908 has been marked as a duplicate of this bug. ***