Bug 108137 - Switching layouts in kdesktop_lock doesn't work
Summary: Switching layouts in kdesktop_lock doesn't work
Status: CLOSED DUPLICATE of bug 102149
Alias: None
Product: kdesktop
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Andriy Rysin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-06-26 00:40 UTC by Omri Mezrich
Modified: 2009-01-02 20:31 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Fix to lockdlg.cc - patched against latest 3.4 branch (1.29 KB, patch)
2005-06-26 00:42 UTC, Omri Mezrich
Details
Fix to lockdlg.h - patched against latest 3.4 branch (356 bytes, patch)
2005-06-26 00:42 UTC, Omri Mezrich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Omri Mezrich 2005-06-26 00:40:14 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
Compiler:          gcc version 3.3.5 (Debian 1:3.3.5-8ubuntu2) 
OS:                Linux

When clicking on the layout switcher in kdesktop_lock, it changes to "err".

From what I traced, the problem is in PasswordDlg::layoutClicked:

QStringList::iterator it = layoutsList.find( mLayoutButton->text() );
if( it == layoutsList.end() ) {  // huh?
    setLayoutText( "err" );

mLayoutButton->text() contains an ampersand due to KCheckAccelerators adding an accel key. (That's something I don't understand - every button on every dialog becomes automatically accelerated?)

anyway - patch attached which just keeps an iterator to the current layout in layoutsList.
Comment 1 Omri Mezrich 2005-06-26 00:42:21 UTC
Created attachment 11583 [details]
Fix to lockdlg.cc - patched against latest 3.4 branch
Comment 2 Omri Mezrich 2005-06-26 00:42:50 UTC
Created attachment 11584 [details]
Fix to lockdlg.h - patched against latest 3.4 branch
Comment 3 David Faure 2005-06-26 10:07:59 UTC
Andy Rysin: this seems to be your code. Or Ossi can have a look, maybe.
Comment 4 Andriy Rysin 2005-06-29 00:42:22 UTC
I really don't have a way to test it all, as I don't have an environment for
compiling and running this as I haven't been doing active KDE development for
more than a year now. I'll try to take a look at the code but without testing
not sure how useful it'd be.

Andriy

--- David Faure <faure@kde.org> wrote:

[bugs.kde.org quoted mail]



		
____________________________________________________ 
Yahoo! Sports 
Rekindle the Rivalries. Sign up for Fantasy Football 
http://football.fantasysports.yahoo.com
Comment 5 Oswald Buddenhagen 2005-07-09 22:11:05 UTC
i will have a look ...


*** This bug has been marked as a duplicate of 102149 ***
Comment 6 FiNeX 2009-01-02 20:31:04 UTC
Bug closed. Kdesktop is no more mantained.