Bug 102149 - Lock Screen window change language error
Summary: Lock Screen window change language error
Status: RESOLVED FIXED
Alias: None
Product: kscreensaver
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 40 votes (vote)
Target Milestone: ---
Assignee: kscreensaver bugs tracking
URL:
Keywords:
: 108137 109234 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-03-22 10:50 UTC by Artem Yankov
Modified: 2008-05-19 17:59 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Fix (1.08 KB, patch)
2005-07-14 20:28 UTC, Michael Ballbach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Artem Yankov 2005-03-22 10:50:24 UTC
Version:            (using KDE KDE 3.4.0)
Installed from:    Compiled From Sources
OS:                Linux

In KDE 3.4 in "Lock screen" or "Lock session" window, don't work switch keyboard layout. If I click on button "en", it change to "err", rather then "ru". In KDE 3.3.1 was all right. Inside KDE all right, keyboard switching fine. If I lock screen, when layout is "ru", then I have no chance to reverse to the KDE.
Comment 1 Yuri Khotyaintsev 2005-05-23 10:48:14 UTC
See the same thing on KDE 3.4.0 and FreeBSD 5.4 with non-Latin keyboard layouts (uk,ru).
Comment 2 Oswald Buddenhagen 2005-07-09 22:11:08 UTC
*** Bug 108137 has been marked as a duplicate of this bug. ***
Comment 3 Michael Ballbach 2005-07-14 20:28:54 UTC
Created attachment 11809 [details]
Fix

This is because '&' gets stuck in there automatically by something associating
an accelerator. If the text attached to the button cannot be found, the patch
will strip '&' and try again.
Comment 4 Omri Mezrich 2005-07-14 22:55:40 UTC
Yeah, this is because by default KCheckAccelerators runs and calls KAccelManager. (Which is kind of weird, IMHO) 

Check out the patch in http://bugs.kde.org/show_bug.cgi?id=108137 , 
I just hold an iterator to the layouts list, instead of using the button text.
Comment 5 Oswald Buddenhagen 2005-07-17 22:49:58 UTC
fixed in trunk and 3.4 branch.
i committed mostly omri's patch ... unfortunately i forgot to credit him ...
Comment 6 Thiago Macieira 2005-07-18 04:54:44 UTC
*** Bug 109234 has been marked as a duplicate of this bug. ***