Bug 107945 - wrong/strange autocomplete in composer addressfield
Summary: wrong/strange autocomplete in composer addressfield
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 104436 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-06-22 23:17 UTC by Christian Schaarschmidt
Modified: 2007-09-14 12:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
introduce KMailCompletion (9.91 KB, patch)
2006-06-03 22:34 UTC, Christian Schaarschmidt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Schaarschmidt 2005-06-22 23:17:09 UTC
Version:           Unbekannt (using KDE 3.4.0, Debian Package 4:3.4.0-0pre4 (3.1))
Compiler:          gcc version 3.3.5 (Debian 1:3.3.5-12)
OS:                Linux (i686) release 2.4.22

Example:

addressbook entry
Firstname: FIRST
Lastname:  LAST
e-mail:    FIRST.LAST@foo.com

when I start typing e.g. FIR
autocomplete will list in the drop down box:
           FIRST.LAST@foo.com (LAST, FIRST)

using this list-entry results in an error because kmail sends out mails to three recipients
FIRST.LAST@foo.com , LAST@mydomain.com , FIRST@mydomain.com

It is good that the lookup works on e-mail address as well as name, but IMHO
autocomplete should in both cases stick to the "normal" format
"FIRST, LAST" <FIRST.LAST@foo.com>
Comment 1 Christian Schaarschmidt 2006-06-03 22:34:58 UTC
Created attachment 16455 [details]
introduce KMailCompletion

this patch requires deactivating autocompletion, because lookup is done on
givenName, familyName, nickName, email but fullEmail is returned from
s_completion.allMatches, which is (most likely) not what has been typed.
Basic idea:
store some keywords for each addressee (fullEmail); let KCompletion find the
keyword and then lookup corresponding addressee.
Advantage:
- no more "first.name@org (First Name)"; Bug 107945
- lookup any part; Bug 77342
- email-addr will only be listed once; Bug 109798
Comment 2 Christian Schaarschmidt 2006-11-07 19:50:03 UTC
SVN commit 603074 by schaarsc:

address completion redesign
 - lookup: nickname, first/lastname, email, domain
 - disable unsupported completion modes
 - select first item in popup, pick with return

CCBUG: 98691, 76739, 77342, 109798, 107945, 82699


 M  +1 -1      branches/work/kdepim-3.5.5+/libkdepim/Makefile.am  
 M  +174 -70   branches/work/kdepim-3.5.5+/libkdepim/addresseelineedit.cpp  
 M  +21 -3     branches/work/kdepim-3.5.5+/libkdepim/addresseelineedit.h  
 A             branches/work/kdepim-3.5.5+/libkdepim/kmailcompletion.cpp   [License: LGPL (v2+)]
 A             branches/work/kdepim-3.5.5+/libkdepim/kmailcompletion.h   [License: LGPL (v2+)]
Comment 3 Christian Schaarschmidt 2006-11-25 22:56:00 UTC
SVN commit 607833 by schaarsc:

port of revsion 603074, 605966

address completion redesign
 - lookup: nickname, first/lastname, email, domain
 - disable unsupported completion modes
 - select first item in popup, pick with return

BUG: 98691, 76739, 77342, 109798, 107945, 82699


 M  +6 -1      kdelibs/kabc/scripts/addressee.src.cpp  
 M  +1 -1      kdepim/libkdepim/Makefile.am  
 M  +174 -70   kdepim/libkdepim/addresseelineedit.cpp  
 M  +21 -3     kdepim/libkdepim/addresseelineedit.h  
 A             kdepim/libkdepim/kmailcompletion.cpp   branches/work/kdepim-3.5.5+/libkdepim/kmailcompletion.cpp#603074 [License: LGPL (v2+)]
 A             kdepim/libkdepim/kmailcompletion.h   branches/work/kdepim-3.5.5+/libkdepim/kmailcompletion.h#603074 [License: LGPL (v2+)]
Comment 4 Christian Schaarschmidt 2006-12-19 18:44:32 UTC
*** Bug 104436 has been marked as a duplicate of this bug. ***