Bug 77342 - include nicknames in address lookup
Summary: include nicknames in address lookup
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.6.1
Platform: Debian testing Linux
: NOR wishlist with 21 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-03-12 01:00 UTC by Szokovacs Robert
Modified: 2007-09-14 12:17 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Szokovacs Robert 2004-03-12 01:00:05 UTC
Version:           1.6.1 (using KDE KDE 3.2.1)
Installed from:    Debian testing/unstable Packages
OS:          Linux

Among several other languages, the hungarian has the names "backward" compared to the other languages: my name is "Szokovacs Robert", where Robert is my given name. So when I start typing a name into the to: field, I start with the family name, but the lookup doesn't include the formatted name, neither the family name, so it's not working. 
Kaddressbook has a field for nickname, it would be logical to do a lookup for nicks too for name autocomplete.
The other thing is how the kmail generates the name included in the email address: its alway "givenname familyname <name@domain>", it should be "formattedname <name@domain>", thats what formatted name is for, I guess.
Also it would be nice if kaddressbook would include the "backward" name order for the predefinec options for given name.
Comment 1 Ingo Klöcker 2004-03-12 17:14:59 UTC
- The nickname will be automatically replaced when the message is sent.
- Checking for the last name is bug 76739.
- Formatted names in the form "Lastname Firstname" has already been added to KAddressBook.

So I'll change this report into a wish for including the nicknames in the address lookup.
Comment 2 Szokovacs Robert 2004-03-12 17:35:16 UTC
It seems true that the nick gets replaced, but the user don't get any feedback. I would suggest to replace it immediately, as it was in the older kmail for distribution lists. And this is independent of the address lookup. Btw, it would be nice to bring back that behaviour to distribution lists also.

br

Szo
Comment 3 Harald Frießnegger 2005-10-05 14:26:11 UTC
in the contacts view of kontact searching for contacts by nickname works.
i'd love to see this feature in the "new message dialog" of future kmail releases ;-)
Comment 4 Christian Schaarschmidt 2006-11-07 19:52:08 UTC
SVN commit 603074 by schaarsc:

address completion redesign
 - lookup: nickname, first/lastname, email, domain
 - disable unsupported completion modes
 - select first item in popup, pick with return

CCBUG: 98691, 76739, 77342, 109798, 107945, 82699


 M  +1 -1      branches/work/kdepim-3.5.5+/libkdepim/Makefile.am  
 M  +174 -70   branches/work/kdepim-3.5.5+/libkdepim/addresseelineedit.cpp  
 M  +21 -3     branches/work/kdepim-3.5.5+/libkdepim/addresseelineedit.h  
 A             branches/work/kdepim-3.5.5+/libkdepim/kmailcompletion.cpp   [License: LGPL (v2+)]
 A             branches/work/kdepim-3.5.5+/libkdepim/kmailcompletion.h   [License: LGPL (v2+)]
Comment 5 Christian Schaarschmidt 2006-11-25 22:55:56 UTC
SVN commit 607833 by schaarsc:

port of revsion 603074, 605966

address completion redesign
 - lookup: nickname, first/lastname, email, domain
 - disable unsupported completion modes
 - select first item in popup, pick with return

BUG: 98691, 76739, 77342, 109798, 107945, 82699


 M  +6 -1      kdelibs/kabc/scripts/addressee.src.cpp  
 M  +1 -1      kdepim/libkdepim/Makefile.am  
 M  +174 -70   kdepim/libkdepim/addresseelineedit.cpp  
 M  +21 -3     kdepim/libkdepim/addresseelineedit.h  
 A             kdepim/libkdepim/kmailcompletion.cpp   branches/work/kdepim-3.5.5+/libkdepim/kmailcompletion.cpp#603074 [License: LGPL (v2+)]
 A             kdepim/libkdepim/kmailcompletion.h   branches/work/kdepim-3.5.5+/libkdepim/kmailcompletion.h#603074 [License: LGPL (v2+)]
Comment 6 Christian Schaarschmidt 2006-12-19 18:16:54 UTC
*** Bug 92744 has been marked as a duplicate of this bug. ***