Bug 106818 - separate "skip taskbar" from (not) receiving focus
Summary: separate "skip taskbar" from (not) receiving focus
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist with 2 votes (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 105809 120168 142382 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-06-05 05:27 UTC by kde
Modified: 2012-03-11 08:13 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kde 2005-06-05 05:27:41 UTC
Version:            (using KDE KDE 3.4.1)
Installed from:    Gentoo Packages
OS:                Linux

The Window-Specific Settings applet allows to set a per-window preference to "Skip taskbar". This also makes the window in question absent from the Alt+Tab window list, so it's impossible to focus on without using the mouse.

Wish: Please separate those two attributes ("skip taskbar", "skip alt+tab list") for better granularity.
Comment 1 kde 2005-06-05 05:30:18 UTC
Oops, sorry, I filed this as a bug. I don't know how to change the severity to a wish, please do.
Comment 2 poelzi 2005-06-20 20:54:07 UTC
First i thought the "Skip Pager" option does this and thought it was a bug (not even the #kde channel know this). I thought the pager option is exactly for this not the kpager program.
Seperate options would be very, very usefull for multi screen setups where you have a program running on the second screen but doesn't need focus, like a media player.
Comment 3 Lubos Lunak 2006-01-17 15:38:42 UTC
*** Bug 120168 has been marked as a duplicate of this bug. ***
Comment 4 Lubos Lunak 2007-03-06 16:58:32 UTC
*** Bug 142382 has been marked as a duplicate of this bug. ***
Comment 5 Lubos Lunak 2007-06-04 13:52:28 UTC
*** Bug 105809 has been marked as a duplicate of this bug. ***
Comment 6 Martin Flöser 2012-03-11 08:13:42 UTC
This feature request has in fact been implemented in a 4.x release. There is now a window specific setting called "Skip switcher" which excludes windows from any window switcher including Alt+Tab and there is a separate option to Skip the taskbar.