Bug 102924 - Creating hyperlinks in composer
Summary: Creating hyperlinks in composer
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: composer (show other bugs)
Version: 1.7.2
Platform: Debian testing Linux
: NOR wishlist with 178 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 136468 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-03-31 12:00 UTC by Ryszard Lach
Modified: 2008-04-08 20:18 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryszard Lach 2005-03-31 12:00:27 UTC
Version:           1.7.2 (using KDE KDE 3.3.2)
Installed from:    Debian testing/unstable Packages
OS:                Linux

I would like to be able to create hyperlinks 'explicit', named by a word, for example in that way:

1. select fragment of text in composer window
2. right click on it and select 'create hyperlink' (or click a button on taskbar)
3. enter target hyperlink address

resulting in hyperlink like <a href="http://very.pretty.site">text fragment</a>

This feature exists in most graphical e-mail clients and I cannot find it in kmail. Am I missing something?
Comment 1 Vlad Lungeanu 2006-07-06 08:52:02 UTC
I confirm the bug. I work in a corporate environment where HTML email messages are the standard. I cannot insert hyperlinks in HTML messages using Composer (either automatically or manually). The only workaround that I found is to save a draft of the message, open the message file as text in a text editor and add the respective HTML code by hand.
I use Kubuntu 6.06 with KDE 3.5.3.
Comment 2 Benjamin Lee Solosy 2006-10-15 23:22:55 UTC
*** This bug has been confirmed by popular vote. ***
Comment 3 Thomas McGuire 2007-03-03 13:55:57 UTC
*** Bug 136468 has been marked as a duplicate of this bug. ***
Comment 4 FiNeX 2007-06-24 01:37:25 UTC
This should be an useful feature! (for who use HTML email, not for me :-D )
Comment 5 Dan Keenan 2007-10-24 03:10:56 UTC
Nowadays, this is a necessary feature to have in ANY email client.  KMail Composer not having this is a serious deficiency.
Comment 6 Julian Mehnle 2008-01-25 14:11:21 UTC
Will this be added in KDE 4?
Comment 7 Thomas McGuire 2008-04-01 18:08:20 UTC
SVN commit 792567 by tmcguire:

Add the ability to create hyperlinks in the composer.
Patch by Stephen Kelly <steveire at gmail dot com>, many thanks!

I'll work on it a bit more and iron the last small problems out, and
prepare this for inclusion in kdelibs.

FEATURE: 102924



 M  +2 -1      kmail/kmcomposerui.rc  
 M  +15 -0     kmail/kmcomposewin.cpp  
 M  +1 -0      kmail/kmcomposewin.h  
 M  +1 -0      libkdepim/CMakeLists.txt  
 A             libkdepim/klinkdialog.cpp   [License: LGPL (v2.1+)]
 A             libkdepim/klinkdialog.h   [License: LGPL (v2.1+)]
 M  +123 -0    libkdepim/kmeditor.cpp  
 M  +27 -0     libkdepim/kmeditor.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=792567
Comment 8 FiNeX 2008-04-08 12:38:27 UTC
Hi!
I've just tested the new "link" feature. It is working right.
There are only two small issues. One is about the Icon which actually is not set. The second is about switching from HTML mode to plain text. Doing that the URL is lost. Shouldn't be converted in plain text?
Comment 9 Stephen Kelly 2008-04-08 20:18:47 UTC
Hi,

I've still got some work I want to do with this. The icon is out of my hands but requested on:
http://techbase.kde.org/index.php?title=Projects/Oxygen/Missing_Icons

I notice you put it on another icon page too on techbase. Thanks for that.

I'll look into the HTML mode -> text mode thing. I was thinking about that during the week, so it should be fixable quite nicely.

There's also a bug when removing the link that the link formatting is not removed, but I have an idea of a workaround for that.

Cheers,

Steve.