Bug 101636 - All icons in the services sidebar become folders when pressing plus sign
Summary: All icons in the services sidebar become folders when pressing plus sign
Status: RESOLVED WORKSFORME
Alias: None
Product: konqueror
Classification: Applications
Component: sidebar (show other bugs)
Version: unspecified
Platform: Slackware Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Joseph Wenninger
URL:
Keywords:
: 116686 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-03-16 19:15 UTC by Vlad C.
Modified: 2008-10-04 10:38 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Example of icon change from individual icon to folder (245.76 KB, image/png)
2005-03-16 20:23 UTC, Vlad C.
Details
patch (570 bytes, patch)
2006-08-05 21:46 UTC, Simon Edwards
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vlad C. 2005-03-16 19:15:27 UTC
Version:            (using KDE KDE 3.4.0)
Installed from:    Slackware Packages
OS:                Linux

After opening the Services sidebar, I click on the 'plus' sign that is to the left of any node (i.e. Internet, Multimedia, Graphics Games, etc.). The icon of that node used to be specific to the node: for example, the icon for the Internet node used to be a globe. However, after pressing the plus sign, the icon turns to a blue folder.

If the node has children, then pressing the minus sign usually brings back the individualized icon of the node. However, if the node has no children, it is stuck being a folder. In either case, I don't think individualized icons should become folders while being expanded.

Thanks for taking the time to look at this bug.
Comment 1 Vlad C. 2005-03-16 20:23:23 UTC
Created attachment 10155 [details]
Example of icon change from individual icon to folder

The icons that have changed to a folder after I have clicked on the plus sign
to their left are pointed out by red arrows.
Comment 2 lexual 2005-10-31 10:40:19 UTC
confirming for 3.4.3 from kubuntu breezy
Comment 3 Simon Edwards 2006-08-05 21:34:11 UTC
*** Bug 116686 has been marked as a duplicate of this bug. ***
Comment 4 Simon Edwards 2006-08-05 21:36:17 UTC
I can confirm this in 3.5.4 on kubuntu dapper.
Comment 5 Simon Edwards 2006-08-05 21:46:33 UTC
Created attachment 17238 [details]
patch

This patch is for kde 3.5.4 and fixes the problem for me. (kubuntu dapper).
Comment 6 Jaime Torres 2008-08-07 17:32:36 UTC
This works for me as expected in 4.1 (in all the sidebar modules).