Bug 101619 - Konsole1.5 does not manage tabs with equal titles
Summary: Konsole1.5 does not manage tabs with equal titles
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: 1.5
Platform: unspecified Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
: 103542 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-03-16 14:24 UTC by Amund Sjaavaag
Modified: 2005-11-08 14:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Amund Sjaavaag 2005-03-16 14:24:24 UTC
Version:           1.5 (using KDE KDE 3.4.0)
Installed from:    Unlisted Binary Package
OS:                Linux

If i have 2 or more tabs with the equal titles, then Konsole changes the titles during start up.

Example:
If my original titles looks like this:

$ grep Title .kde/share/apps/konsole/profiles/2
Title0=amuns
Title1=root
Title10=noc2-nms
Title11=Shell
Title12=Shell
Title13=supersession
Title14=Shell No. 2
Title2=Nextb
Title3=Nextb
Title4=Nextb
Title5=t.net
Title6=t.net
Title7=t.net
Title8=Shell No. 9
Title9=tollt

When Konsole starts, the titles are changed to this:

$ grep Title .kde/share/apps/konsole/profiles/test2
Title0=amuns
Title1=root
Title10=noc2-nms
Title11=Shell No. 2
Title12=Shell No. 3
Title13=supersession
Title14=Shell No. 4
Title2=Nextb
Title3=Nextb No. 2
Title4=Nextb No. 3
Title5=t.net
Title6=t.net No. 2
Title7=t.net No. 3
Title8=Shell
Title9=tollt
Comment 1 Thiago Macieira 2005-03-16 16:13:58 UTC
I think that's intentional.
Comment 2 Kurt Hindenburg 2005-03-28 21:46:07 UTC
It is intentional when creating new sessions to add the 'No #'.  However, if you are using --profile, I think Konsole should leave the titles as the user has them.
Comment 3 Amund Sjaavaag 2005-03-29 21:57:30 UTC
The comment #2 makes sense to me, and i really hopes that is the intention!
 When creating a new session, it is up to the application to generate an initial title for this session.
 When i as a user, configure my profile configuration file, then i want the application to use the Titles i have chosen. I don't think it is the intention that Konsole overrides my configuration on its own.
 When you are working with lot of sessions, then Konsole is a must. I have never seen any other smart terminal like that. When i start Konsole, it automaticly starts a lot of tabbed SSH-sessions to different servers, and i am ready to work.  If you are running 10-15 sessions, it become a real mess, when Konsole changes to numbered titles with too many letters. With version 1.8, i have to edit my titles every time after starting Konsole.
  On my wish list, there is an option for multiple lines of tabs, or other ways for organizing high number of sessions.
Comment 4 Kurt Hindenburg 2005-03-30 06:53:30 UTC
CVS commit by hindenburg: 

Don't alter session title when using --profile or session management.

BUGS: 101619


  M +8 -0      konsole.cpp   1.525
  M +1 -0      konsole.h   1.204
  M +1 -0      main.cpp   1.290


--- kdebase/konsole/konsole/konsole.h  #1.203:1.204
@@ -86,4 +86,5 @@ public:
   void setSchema(const QString & path);
   void setEncoding(int);
+  void setSessionTitle(QString&, TESession* = 0);
 
   void enableFullScripting(bool b);

--- kdebase/konsole/konsole/konsole.cpp  #1.524:1.525
@@ -3473,4 +3473,12 @@ void Konsole::attachSession(TESession* s
 }
 
+void Konsole::setSessionTitle( QString& title, TESession* ses )
+{
+   if ( !ses )
+      ses = se;
+   ses->setTitle( title );
+   slotRenameSession( ses, title );
+}
+
 void Konsole::renameSession(TESession* ses) {
   QString title = ses->Title();

--- kdebase/konsole/konsole/main.cpp  #1.289:1.290
@@ -531,4 +531,5 @@ extern "C" int KDE_EXPORT kdemain(int ar
           sCwd = sessionconfig->readPathEntry(key);
           m->newSession(sPgm, eargs, sTerm, sIcon, sTitle, sCwd);
+          m->setSessionTitle(sTitle);  // Use title as is
           key = QString("Schema%1").arg(counter);
           m->setSchema(sessionconfig->readEntry(key));
Comment 5 Kurt Hindenburg 2005-04-09 11:15:45 UTC
*** Bug 103542 has been marked as a duplicate of this bug. ***
Comment 6 Amund Sjaavaag 2005-11-08 14:36:53 UTC
Yes! 
 I just upgraded to KDE 3.5, and Konsole works fine!!