Bug 75837

Summary: Netscape Flash plugin doesn't seem to accept keyboard events
Product: konqueror Reporter: ironfroggy
Component: nspluginsAssignee: George Staikos <staikos>
Status: RESOLVED WORKSFORME    
Severity: normal CC: colesen, hasso, l.lunak, larkang, maarizwan, mcguire, pasrospa, tdfischer
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Gentoo Packages   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: a ninja game in Flash

Description ironfroggy 2004-02-22 16:01:04 UTC
Version:            (using KDE KDE 3.2.0)
Installed from:    Gentoo Packages
Compiler:          gcc 3.3.2 
OS:          Linux

Many Flash files use keyboard events, such as for interactive games. In Konq, however, the plugin doesnt receive keyboard events and thus any flash files that rely on the keyboard are useless.
Comment 1 Dawit Alemayehu 2004-02-23 01:02:42 UTC
Please provide an example site...
Comment 2 ironfroggy 2004-02-23 06:38:40 UTC
sorry, i thought i had. here:
http://www.sfdt.com/flash/movies/8538.html
Comment 3 Dawit Alemayehu 2004-03-04 07:19:27 UTC
I do not see the problem. If you put the mouse over the flash plugin and then press the the TAB key, the keyboard events are handled by the plugin. This is exactly how Mozilla works as well. So what exactly is the problem ?
Comment 4 ironfroggy 2004-03-05 01:25:31 UTC
I never remember needing to press tab. The flash plugin should accept keyboard events under the same conditions as anything as, following normal focus rules. Preferably, it should accept keyboard input whenever the mouse is over the flash movie, or perhaps according to window focus rules.

in any case, the need to press tab is obscure and a hinderance.
Comment 5 Teemu Autto 2004-03-27 15:04:28 UTC
I can confirm that this problem is real. Example: http://av02c.kicks-ass.org/pelaabeta.php.
If you try to move paddle with cursor buttons, some times it works, and moretimes it won't. If you try it with mozilla, it works allways.
As I said, it works sometimes, but usually won't.
BUT, if I have multiple tabs open, and after loading page-with-flash switch to another tab an back, keyboard events seems to work.
Comment 6 Paul Hoepfner-Homme 2004-04-07 17:54:14 UTC
Another example is the game N. I will attach an SWF file. Try to run this in Konqueror and it won't react to keyboard events, which makes it impossible to play it in Konqueror. The prompt says "press [spacebar] to begin" after you click "new game" on the main screen, but pressing the spacebar has no effect - regardless of whether you pressed TAB, moved the mouse cursor over the game, clicked in the game, or anything else. Konqueror doesn't send keyboard events to the game in any situation I've tried.
Comment 7 Paul Hoepfner-Homme 2004-04-07 17:56:31 UTC
Created attachment 5569 [details]
a ninja game in Flash

Navigate to this Flash file in Konqueror and try to play it. It is impossible
because Konqueror doesn't pass it keyboard any events.
Comment 8 George Staikos 2004-04-20 08:43:06 UTC
*** Bug 79983 has been marked as a duplicate of this bug. ***
Comment 9 George Staikos 2004-08-08 23:44:39 UTC
*** Bug 80579 has been marked as a duplicate of this bug. ***
Comment 10 Pascal Maillard 2004-11-07 03:48:39 UTC
I can confirm the described problem. I encountered it while playing the sixth and seventh Yetisports game (www.yetisports.org). Strangely, the flash plugin did recieve keyboard events when I pressed on a letter (e.g. 'b'), but not when I pressed the arrow keys.

I also noticed how you can make the keyboard work for the Ninja game: Open it in a new tab, select the tab, change back to another tab and back to the tab with the ninja game.
Comment 11 George Staikos 2005-02-21 12:25:05 UTC
Reproduced with testcases.
Comment 12 George Staikos 2005-02-23 07:39:24 UTC
inst->_toplevel is getting the key events at first.  Switching tabs and back results in _form getting the events as required.  Very strange.
Comment 13 George Staikos 2005-02-24 00:27:38 UTC
*** Bug 99267 has been marked as a duplicate of this bug. ***
Comment 14 Mark Martin 2005-02-27 22:40:57 UTC
Another confirmed case is with the following Flash game: http://www.miniclip.com/gamefiles0304/heli2miniclip.swf  Under Konq the keyboard presses appear to be ignored.  When trying the same test with Firefox all required key presses DO work.
Comment 15 Toby Dickenson 2005-07-16 20:45:26 UTC
Confirmed this is still a problem in 3.4.0
Comment 16 Luk van den Borne 2005-10-28 22:08:36 UTC
The problem is still there in 3.4.3...
Comment 17 Michael Rolf 2005-10-29 14:24:43 UTC
And also still a problem in 3.5.0 Beta 2
Comment 18 Luk van den Borne 2005-12-25 10:17:16 UTC
Problem still exists in in KDE3.5. Workarounds like pressing tab or switching to another tab just won't work. Please fix this. This is VERY annoying.
Comment 19 Pablo 2006-02-17 01:32:47 UTC
Also present in 3.5.1, I was trying to play: http://www.teagames.com/games/bmxstar/play.php
Comment 20 Martin van Es 2006-09-19 17:08:23 UTC
Still not fixed in KDE 3.5.4
Comment 21 Thomas McGuire 2006-10-19 17:04:17 UTC
This seems to be fixed with the new flashplayer beta 9 which was released today.
I checked the games from Comment #2 and Comment #19, they both work with version 9, but not with version 7.
Comment 22 Leo Spalteholz 2006-11-01 22:28:16 UTC
I can also confirm that this works with the new flash player (KDE 3.5.5).  Given how long this bug has been around, and that the new plash player is such a huge step up from the old one, is it worth keeping this bug open?
Comment 23 Henrik Segesten 2006-11-02 08:41:57 UTC
The keyboard events works for me as well with the new flash player beta. So go ahead and close this bug.
Comment 24 Lubos Lunak 2007-08-24 17:10:47 UTC
Closing per the last comments.