Bug 457856

Summary: dolphin crashed inKIO::SkipDialog::SkipDialog() while copying large amount of files to external hard drive
Product: [Frameworks and Libraries] frameworks-kio Reporter: seby.trello
Component: Overwrite dialogAssignee: KIO Bugs <kio-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash CC: gtx.swift, kdelibs-bugs, kfm-devel, nate, nicolas.fella
Priority: NOR Keywords: drkonqi
Version: 5.92.0   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: New crash information added by DrKonqi

Description seby.trello 2022-08-13 23:40:24 UTC
Application: dolphin (21.12.3)

Qt Version: 5.15.3
Frameworks Version: 5.92.0
Operating System: Linux 5.15.0-43-generic x86_64
Windowing System: X11
Distribution: Ubuntu 22.04.1 LTS
DrKonqi: 5.24.4 [KCrashBackend]

-- Information about the crash:
- What I was doing when the application crashed:

I copied a large amount of files (140GB in total, containing pdfs, images, videos and more) from my a partition A to partition B. Partition A was on a different SSD in the laptop, sized 210GB and FAT format. Partition B was an external SSD, connected via a docking station, 1TB large, basically new, exFAT format. 

Dolphin only crashed after about an hour.

I was using the laptop for other stuff at the same time. What might have been a problem that I added files to a folder in partition A during the copying process.

The reporter is unsure if this crash is reproducible.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault

[KCrash Handler]
#4  0x00007f8a18990bb2 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f8a19482702 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#6  0x00007f8a18990e2a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f8a194c694b in QWidget::setParent(QWidget*, QFlags<Qt::WindowType>) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#8  0x00007f8a194c6dee in QWidgetPrivate::init(QWidget*, QFlags<Qt::WindowType>) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#9  0x00007f8a19692403 in QDialog::QDialog(QWidget*, QFlags<Qt::WindowType>) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#10 0x00007f8a1a6417fc in KIO::SkipDialog::SkipDialog(QWidget*, QFlags<KIO::SkipDialog_Option>, QString const&) () from /lib/x86_64-linux-gnu/libKF5KIOWidgets.so.5
#11 0x00007f8a1a6495f1 in KIO::WidgetsAskUserActionHandler::askUserSkip(KJob*, QFlags<KIO::SkipDialog_Option>, QString const&) () from /lib/x86_64-linux-gnu/libKF5KIOWidgets.so.5
#12 0x00007f8a1a387e20 in ?? () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#13 0x00007f8a189c8783 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#14 0x00007f8a19bcee70 in KJob::result(KJob*, KJob::QPrivateSignal) () from /lib/x86_64-linux-gnu/libKF5CoreAddons.so.5
#15 0x00007f8a19bd33db in KJob::finishJob(bool) () from /lib/x86_64-linux-gnu/libKF5CoreAddons.so.5
#16 0x00007f8a189c8783 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#17 0x00007f8a19bcee70 in KJob::result(KJob*, KJob::QPrivateSignal) () from /lib/x86_64-linux-gnu/libKF5CoreAddons.so.5
#18 0x00007f8a19bd33db in KJob::finishJob(bool) () from /lib/x86_64-linux-gnu/libKF5CoreAddons.so.5
#19 0x00007f8a189c8783 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#20 0x00007f8a1a3abd1a in KIO::SlaveInterface::error(int, QString const&) () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#21 0x00007f8a1a3ade77 in KIO::SlaveInterface::dispatch(int, QByteArray const&) () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#22 0x00007f8a1a3ac47d in KIO::SlaveInterface::dispatch() () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#23 0x00007f8a1a3b0ba2 in KIO::Slave::gotInput() () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#24 0x00007f8a189c8783 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#25 0x00007f8a189be40e in QObject::event(QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#26 0x00007f8a19482713 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#27 0x00007f8a18990e2a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#28 0x00007f8a18993f17 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#29 0x00007f8a189eaa57 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#30 0x00007f8a165c9d1b in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f8a1661e6f8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f8a165c73c3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#33 0x00007f8a189ea0a8 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#34 0x00007f8a1898f74b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#35 0x00007f8a18997ce4 in QCoreApplication::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#36 0x000055e8c6161ade in ?? ()
#37 0x00007f8a182acd90 in __libc_start_call_main (main=main@entry=0x55e8c615c260, argc=argc@entry=1, argv=argv@entry=0x7ffffaa06008) at ../sysdeps/nptl/libc_start_call_main.h:58
#38 0x00007f8a182ace40 in __libc_start_main_impl (main=0x55e8c615c260, argc=1, argv=0x7ffffaa06008, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffffaa05ff8) at ../csu/libc-start.c:392
#39 0x000055e8c6162265 in ?? ()
[Inferior 1 (process 2799) detached]

The reporter indicates this bug may be a duplicate of or related to bug 457313.

Possible duplicates by query: bug 457741, bug 457722, bug 457437, bug 457420, bug 457313.

Reported using DrKonqi
Comment 1 gtx.swift 2022-08-19 12:37:37 UTC
Created attachment 151431 [details]
New crash information added by DrKonqi

dolphin (22.04.3) using Qt 5.15.5

Screen was locked Super + L & crashed Dolphin file copy in backround.

-- Backtrace (Reduced):
#4  0x00007f35e3410d64 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#5  0x00007f35e408840e in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#6  0x00007f35e3410fb8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#7  0x00007f35e40cb0eb in QWidget::setParent(QWidget*, QFlags<Qt::WindowType>) () from /lib64/libQt5Widgets.so.5
#8  0x00007f35e40cb5c6 in QWidgetPrivate::init(QWidget*, QFlags<Qt::WindowType>) () from /lib64/libQt5Widgets.so.5
Comment 2 Nicolas Fella 2022-09-04 23:08:41 UTC

*** This bug has been marked as a duplicate of bug 448532 ***