Bug 457437 - Dolphin crashes when I click 'Properties...' in directory context menu
Summary: Dolphin crashes when I click 'Properties...' in directory context menu
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 22.04.3
Platform: Kubuntu Linux
: NOR crash
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2022-08-03 05:38 UTC by Artem
Modified: 2023-12-11 13:11 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (5.26 KB, text/plain)
2022-08-04 23:59 UTC, jasoncollege24
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Artem 2022-08-03 05:38:21 UTC
Application: dolphin (22.04.3)

Qt Version: 5.15.3
Frameworks Version: 5.95.0
Operating System: Linux 5.15.0-43-generic x86_64
Windowing System: X11
Distribution: Ubuntu 22.04.1 LTS
DrKonqi: 5.24.5 [KCrashBackend]

-- Information about the crash:
- What I was doing when the application crashed:

Opened an arbitrary directory, found subdirectory and opened it's context menu. The crash happened when I chose 'Properties...' item.

- Custom settings of the application:

Locale: RU

The crash can be reproduced every time.

-- Backtrace:
Application: Dolphin (dolphin), signal: Aborted

[KCrash Handler]
#4  __pthread_kill_implementation (no_tid=0, signo=6, threadid=140417869059520) at ./nptl/pthread_kill.c:44
#5  __pthread_kill_internal (signo=6, threadid=140417869059520) at ./nptl/pthread_kill.c:78
#6  __GI___pthread_kill (threadid=140417869059520, signo=signo@entry=6) at ./nptl/pthread_kill.c:89
#7  0x00007fb59a159476 in __GI_raise (sig=sig@entry=6) at ../sysdeps/posix/raise.c:26
#8  0x00007fb59a13f7f3 in __GI_abort () at ./stdlib/abort.c:79
#9  0x00007fb59a5fbba3 in QMessageLogger::fatal(char const*, ...) const () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007fb59907ae95 in ?? () from /lib/x86_64-linux-gnu/libQt5QuickWidgets.so.5
#11 0x00007fb59907b1ff in ?? () from /lib/x86_64-linux-gnu/libQt5QuickWidgets.so.5
#12 0x00007fb59907d3e5 in QQuickWidget::resizeEvent(QResizeEvent*) () from /lib/x86_64-linux-gnu/libQt5QuickWidgets.so.5
#13 0x00007fb59b359f6c in QWidget::event(QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#14 0x00007fb59b316713 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#15 0x00007fb59a824e2a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#16 0x00007fb59b351366 in QWidgetPrivate::sendPendingMoveAndResizeEvents(bool, bool) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#17 0x00007fb59b355e07 in QWidgetPrivate::show_helper() () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#18 0x00007fb59b358fe3 in QWidgetPrivate::setVisible(bool) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#19 0x00007fb59b355d89 in QWidgetPrivate::showChildren(bool) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#20 0x00007fb59b355e23 in QWidgetPrivate::show_helper() () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#21 0x00007fb59b355da9 in QWidgetPrivate::showChildren(bool) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#22 0x00007fb59b355e23 in QWidgetPrivate::show_helper() () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#23 0x00007fb59b358fe3 in QWidgetPrivate::setVisible(bool) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#24 0x00007fb59b33d2f5 in QStackedLayout::setCurrentIndex(int) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#25 0x00007fb59b33d85f in QStackedLayout::takeAt(int) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#26 0x00007fb59b33804e in QLayout::removeWidget(QWidget*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#27 0x00007fb59be4a2ae in ?? () from /lib/x86_64-linux-gnu/libKF5WidgetsAddons.so.5
#28 0x00007fb59a85c783 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#29 0x00007fb59a7bdb3a in QAbstractItemModel::layoutChanged(QList<QPersistentModelIndex> const&, QAbstractItemModel::LayoutChangeHint) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#30 0x00007fb59be5a9f0 in KPageWidgetModel::addPage(KPageWidgetItem*) () from /lib/x86_64-linux-gnu/libKF5WidgetsAddons.so.5
#31 0x00007fb59be5aa7e in KPageWidgetModel::addPage(QWidget*, QString const&) () from /lib/x86_64-linux-gnu/libKF5WidgetsAddons.so.5
#32 0x00007fb58cccbbb0 in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/propertiesdialog/baloofilepropertiesplugin.so
#33 0x00007fb59a85c783 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#34 0x00007fb59c3506d9 in Baloo::FileMetaDataWidget::metaDataRequestFinished(KFileItemList const&) () from /lib/x86_64-linux-gnu/libKF5BalooWidgets.so.5
#35 0x00007fb59c35831a in ?? () from /lib/x86_64-linux-gnu/libKF5BalooWidgets.so.5
#36 0x00007fb59a85c783 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#37 0x00007fb59c362f68 in ?? () from /lib/x86_64-linux-gnu/libKF5BalooWidgets.so.5
#38 0x00007fb59a85c783 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#39 0x00007fb59ba6305d in KJob::finished(KJob*, KJob::QPrivateSignal) () from /lib/x86_64-linux-gnu/libKF5CoreAddons.so.5
#40 0x00007fb59ba674c3 in KJob::finishJob(bool) () from /lib/x86_64-linux-gnu/libKF5CoreAddons.so.5
#41 0x00007fb59c35a27f in ?? () from /lib/x86_64-linux-gnu/libKF5BalooWidgets.so.5
#42 0x00007fb59a85240e in QObject::event(QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#43 0x00007fb59b316713 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#44 0x00007fb59a824e2a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#45 0x00007fb59a827f17 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#46 0x00007fb59a87ea57 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#47 0x00007fb598448d1b in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#48 0x00007fb59849d6f8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#49 0x00007fb5984463c3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#50 0x00007fb59a87e0a8 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#51 0x00007fb59a82374b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#52 0x00007fb59a82bce4 in QCoreApplication::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#53 0x0000564d692e9ccb in ?? ()
#54 0x00007fb59a140d90 in __libc_start_call_main (main=main@entry=0x564d692e46a0, argc=argc@entry=1, argv=argv@entry=0x7ffdaf2c39f8) at ../sysdeps/nptl/libc_start_call_main.h:58
#55 0x00007fb59a140e40 in __libc_start_main_impl (main=0x564d692e46a0, argc=1, argv=0x7ffdaf2c39f8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffdaf2c39e8) at ../csu/libc-start.c:392
#56 0x0000564d692ea455 in ?? ()
[Inferior 1 (process 28238) detached]

Possible duplicates by query: bug 456532, bug 455949, bug 455731, bug 453774, bug 453582.

Reported using DrKonqi
Comment 1 jasoncollege24 2022-08-04 23:59:45 UTC
Created attachment 151123 [details]
New crash information added by DrKonqi

dolphin (21.12.3) using Qt 5.15.3

- What I was doing when the application crashed:
I'm pretty sure this is the same bug. Caused by right clicking the drive name, in the left panel, and choose the "Properties..." item.

As soon as the properties window appears, Dolphin crashes. Can be reproduced every time. (couldn't find where to change this option)

-- Backtrace (Reduced):
#4  __pthread_kill_implementation (no_tid=0, signo=6, threadid=140517759497664) at ./nptl/pthread_kill.c:44
#5  __pthread_kill_internal (signo=6, threadid=140517759497664) at ./nptl/pthread_kill.c:78
#6  __GI___pthread_kill (threadid=140517759497664, signo=signo@entry=6) at ./nptl/pthread_kill.c:89
#7  0x00007fccdc035476 in __GI_raise (sig=sig@entry=6) at ../sysdeps/posix/raise.c:26
#8  0x00007fccdc01b7f3 in __GI_abort () at ./stdlib/abort.c:79
Comment 2 Akseli Lahtinen 2023-12-11 13:11:04 UTC
Can't reproduce, likely fixed.