Bug 457313 - Dolphin Crashes on File Transfer
Summary: Dolphin Crashes on File Transfer
Status: RESOLVED DUPLICATE of bug 448532
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 22.04.3
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2022-07-30 19:28 UTC by xunilhcra
Modified: 2023-11-27 10:41 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (58.39 KB, text/plain)
2023-04-02 16:08 UTC, niklas312
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xunilhcra 2022-07-30 19:28:24 UTC
Application: dolphin (22.04.3)

Qt Version: 5.15.5
Frameworks Version: 5.96.0
Operating System: Linux 5.18.11-1-default x86_64
Windowing System: X11
Distribution: openSUSE Tumbleweed
DrKonqi: 5.25.3 [KCrashBackend]

-- Information about the crash:
Dolphin will crash when copying many GB of files from one hard drive to another. In this case, files were being copied to an external HDD.

The crash can be reproduced sometimes.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault

[KCrash Handler]
#4  0x00007f86ef3d9ce6 in QWidgetPrivate::createWinId() () from /lib64/libQt5Widgets.so.5
#5  0x00007f86ef3d9aa0 in QWidget::create(unsigned long long, bool, bool) () from /lib64/libQt5Widgets.so.5
#6  0x00007f86ef3e66ba in QWidgetPrivate::setVisible(bool) () from /lib64/libQt5Widgets.so.5
#7  0x00007f86ef5adc65 in QDialog::setVisible(bool) () from /lib64/libQt5Widgets.so.5
#8  0x00007f86f01e8dca in ?? () from /lib64/libKF5KIOCore.so.5
#9  0x00007f86ee712e6f in ?? () from /lib64/libQt5Core.so.5
#10 0x00007f86efa46615 in KJob::result(KJob*, KJob::QPrivateSignal) () from /lib64/libKF5CoreAddons.so.5
#11 0x00007f86efa4a7cb in KJob::finishJob(bool) () from /lib64/libKF5CoreAddons.so.5
#12 0x00007f86ee712e6f in ?? () from /lib64/libQt5Core.so.5
#13 0x00007f86efa46615 in KJob::result(KJob*, KJob::QPrivateSignal) () from /lib64/libKF5CoreAddons.so.5
#14 0x00007f86efa4a7cb in KJob::finishJob(bool) () from /lib64/libKF5CoreAddons.so.5
#15 0x00007f86ee712e6f in ?? () from /lib64/libQt5Core.so.5
#16 0x00007f86f0209f16 in KIO::SlaveInterface::error(int, QString const&) () from /lib64/libKF5KIOCore.so.5
#17 0x00007f86f020ecf8 in KIO::SlaveInterface::dispatch(int, QByteArray const&) () from /lib64/libKF5KIOCore.so.5
#18 0x00007f86f0209dc6 in KIO::SlaveInterface::dispatch() () from /lib64/libKF5KIOCore.so.5
#19 0x00007f86f020c369 in KIO::Slave::gotInput() () from /lib64/libKF5KIOCore.so.5
#20 0x00007f86ee712e6f in ?? () from /lib64/libQt5Core.so.5
#21 0x00007f86ee707760 in QObject::event(QEvent*) () from /lib64/libQt5Core.so.5
#22 0x00007f86ef3a541e in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#23 0x00007f86ee6dbfb8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#24 0x00007f86ee6def51 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /lib64/libQt5Core.so.5
#25 0x00007f86ee733c53 in ?? () from /lib64/libQt5Core.so.5
#26 0x00007f86ec26cea0 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#27 0x00007f86ec26d258 in ?? () from /lib64/libglib-2.0.so.0
#28 0x00007f86ec26d2ec in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#29 0x00007f86ee733456 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#30 0x00007f86ee6daa2b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#31 0x00007f86ee6e2b96 in QCoreApplication::exec() () from /lib64/libQt5Core.so.5
#32 0x000055d466c4f212 in ?? ()
#33 0x00007f86edc405b0 in __libc_start_call_main () from /lib64/libc.so.6
#34 0x00007f86edc40679 in __libc_start_main_impl () from /lib64/libc.so.6
#35 0x000055d466c4f815 in ?? ()
[Inferior 1 (process 10018) detached]

Reported using DrKonqi
Comment 1 xunilhcra 2022-10-09 21:43:11 UTC
I was able to reproduce the crash. This time it occurred when unplugging a USB flash drive while a file transfer was in process from an internal HDD to an external HDD. As soon as the USB flash drive was unplugged, Dolphin crashed and the tile transfer failed.

Application: Dolphin (dolphin), signal: Segmentation fault

[KCrash Handler]
#4  0x00007f94126dbf24 in QList<QPointer<QObject> >::Node::t (this=0x559d26965180) at ../../include/QtCore/../../src/corelib/tools/qlist.h:153
#5  QList<QPointer<QObject> >::at (i=0, this=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qlist.h:572
#6  QCoreApplicationPrivate::sendThroughObjectEventFilters (receiver=receiver@entry=0x559faef2a1e0, event=event@entry=0x7ffffe4096a0) at kernel/qcoreapplication.cpp:1183
#7  0x00007f94133a53ee in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x559faef2a1e0, e=0x7ffffe4096a0) at kernel/qapplication.cpp:3631
#8  0x00007f94126dc178 in QCoreApplication::notifyInternal2 (receiver=0x559faef2a1e0, event=0x7ffffe4096a0) at kernel/qcoreapplication.cpp:1064
#9  0x00007f94133e80cb in QWidget::setParent (this=this@entry=0x559faf5f8470, parent=<optimized out>, parent@entry=0x559faef2a1e0, f=...) at kernel/qwidget.cpp:10497
#10 0x00007f94133e85a6 in QWidgetPrivate::init (this=0x559faf3fdb40, parentWidget=<optimized out>, f=...) at kernel/qwidget.cpp:1044
#11 0x00007f94135ac42c in QDialog::QDialog (this=this@entry=0x559faf5f8470, parent=0x559faef2a1e0, f=..., f@entry=...) at dialogs/qdialog.cpp:400
#12 0x00007f94144c5e79 in KIO::SkipDialog::SkipDialog (this=<optimized out>, parent=<optimized out>, options=..., _error_text=..., this=<optimized out>, parent=<optimized out>, options=..., _error_text=...) at /usr/include/qt5/QtCore/qflags.h:120
#13 0x00007f94144d0a3f in KIO::WidgetsAskUserActionHandler::askUserSkip (this=0x559faf660460, job=0x559faf661e20, options=..., errorText=...) at /usr/src/debug/kio-5.98.0-1.1.x86_64/src/widgets/widgetsaskuseractionhandler.cpp:176
#14 0x00007f941424564a in KIO::CopyJobPrivate::slotResultErrorCopyingFiles (this=<optimized out>, job=0x559fb05f3340) at /usr/src/debug/kio-5.98.0-1.1.x86_64/src/core/copyjob.cpp:1766
#15 0x00007f941271305d in QtPrivate::QSlotObjectBase::call (a=0x7ffffe409b20, r=0x559faf661e20, this=0x559fb0a7fdf0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#16 doActivate<false> (sender=0x559fb05f3340, signal_index=6, argv=0x7ffffe409b20) at kernel/qobject.cpp:3919
#17 0x00007f941270c4df in QMetaObject::activate (sender=sender@entry=0x559fb05f3340, m=<optimized out>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7ffffe409b20) at kernel/qobject.cpp:3979
#18 0x00007f9413aaabd5 in KJob::result (this=this@entry=0x559fb05f3340, _t1=<optimized out>, _t1@entry=0x559fb05f3340, _t2=...) at /usr/src/debug/kcoreaddons-5.98.0-1.1.x86_64/build/src/lib/KF5CoreAddons_autogen/include/moc_kjob.cpp:633
#19 0x00007f9413aaee1b in KJob::finishJob (this=0x559fb05f3340, emitResult=<optimized out>) at /usr/src/debug/kcoreaddons-5.98.0-1.1.x86_64/src/lib/jobs/kjob.cpp:98
#20 0x00007f941271305d in QtPrivate::QSlotObjectBase::call (a=0x7ffffe409c40, r=0x559fb05f3340, this=0x559fb0666630) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#21 doActivate<false> (sender=0x559fb00958f0, signal_index=6, argv=0x7ffffe409c40) at kernel/qobject.cpp:3919
#22 0x00007f941270c4df in QMetaObject::activate (sender=sender@entry=0x559fb00958f0, m=<optimized out>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7ffffe409c40) at kernel/qobject.cpp:3979
#23 0x00007f9413aaabd5 in KJob::result (this=this@entry=0x559fb00958f0, _t1=<optimized out>, _t1@entry=0x559fb00958f0, _t2=...) at /usr/src/debug/kcoreaddons-5.98.0-1.1.x86_64/build/src/lib/KF5CoreAddons_autogen/include/moc_kjob.cpp:633
#24 0x00007f9413aaee1b in KJob::finishJob (this=0x559fb00958f0, emitResult=<optimized out>) at /usr/src/debug/kcoreaddons-5.98.0-1.1.x86_64/src/lib/jobs/kjob.cpp:98
#25 0x00007f941271305d in QtPrivate::QSlotObjectBase::call (a=0x7ffffe409d60, r=0x559fb00958f0, this=0x559fb1075c80) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#26 doActivate<false> (sender=0x559faefedd10, signal_index=5, argv=0x7ffffe409d60) at kernel/qobject.cpp:3919
#27 0x00007f941270c4df in QMetaObject::activate (sender=sender@entry=0x559faefedd10, m=<optimized out>, local_signal_index=local_signal_index@entry=2, argv=argv@entry=0x7ffffe409d60) at kernel/qobject.cpp:3979
#28 0x00007f94142689e6 in KIO::SlaveInterface::error (this=this@entry=0x559faefedd10, _t1=<optimized out>, _t2=...) at /usr/src/debug/kio-5.98.0-1.1.x86_64/build/src/core/KF5KIOCore_autogen/include/moc_slaveinterface.cpp:452
#29 0x00007f941426d838 in KIO::SlaveInterface::dispatch (this=0x559faefedd10, _cmd=102, rawdata=...) at /usr/src/debug/kio-5.98.0-1.1.x86_64/src/core/slaveinterface.cpp:181
#30 0x00007f9414268826 in KIO::SlaveInterface::dispatch (this=0x559faefedd10) at /usr/src/debug/kio-5.98.0-1.1.x86_64/src/core/slaveinterface.cpp:78
#31 0x00007f941426ae99 in KIO::Slave::gotInput (this=0x559faefedd10) at /usr/src/debug/kio-5.98.0-1.1.x86_64/src/core/slave.cpp:346
#32 0x00007f941271305d in QtPrivate::QSlotObjectBase::call (a=0x7ffffe409f70, r=0x559faefedd10, this=0x559faf10e0e0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#33 doActivate<false> (sender=0x559faea1b100, signal_index=3, argv=0x7ffffe409f70) at kernel/qobject.cpp:3919
#34 0x00007f94127079d0 in QObject::event (this=0x559faea1b100, e=0x559faf598560) at kernel/qobject.cpp:1347
#35 0x00007f94133a53fe in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x559faea1b100, e=0x559faf598560) at kernel/qapplication.cpp:3637
#36 0x00007f94126dc178 in QCoreApplication::notifyInternal2 (receiver=0x559faea1b100, event=0x559faf598560) at kernel/qcoreapplication.cpp:1064
#37 0x00007f94126df111 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x559fae72cad0) at kernel/qcoreapplication.cpp:1821
#38 0x00007f9412734003 in postEventSourceDispatch (s=0x559fae8ac350) at kernel/qeventdispatcher_glib.cpp:277
#39 0x00007f9410320a50 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#40 0x00007f9410320e08 in ?? () from /lib64/libglib-2.0.so.0
#41 0x00007f9410320e9c in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#42 0x00007f9412733806 in QEventDispatcherGlib::processEvents (this=0x559fae8ba810, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#43 0x00007f94126dabeb in QEventLoop::exec (this=this@entry=0x7ffffe40a360, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#44 0x00007f94126e2d56 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#45 0x0000559fada38244 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/dolphin-22.08.1-1.1.x86_64/src/main.cpp:223
[Inferior 1 (process 21510) detached]
Comment 2 niklas312 2023-04-02 16:08:10 UTC
Created attachment 157794 [details]
New crash information added by DrKonqi

dolphin (22.12.3) using Qt 5.15.8

I think this is the same issue here. I was copying 134,1 GiB of files to a Network  drive. The network drive went offline, so I paused the file transfer and resumed it after the drive was back online. Some time after that (I'm not sure how long it took, if it was immediately or after some time), Dolphin crashed

-- Backtrace (Reduced):
#6  0x00007fd27c398f55 in QWidget::testAttribute_helper(Qt::WidgetAttribute) const () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#7  0x00007fd27c3a22af in QWidgetPrivate::createWinId() () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#8  0x00007fd27c3a202d in QWidget::create(unsigned long long, bool, bool) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#9  0x00007fd27c3af34e in QWidgetPrivate::setVisible(bool) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#10 0x00007fd27c5804c8 in QDialog::setVisible(bool) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
Comment 3 Méven Car 2023-04-02 18:00:58 UTC
How did you initiate the file transfer exactly ?

Was it in dolphin by drag and drop ? Or using Copy+Paste ? Another way ?

Did you the origin directory and destination directories have any file with the same name ?

(In reply to niklas312 from comment #2)
> Created attachment 157794 [details]
> New crash information added by DrKonqi
> 
> dolphin (22.12.3) using Qt 5.15.8
> 
> I think this is the same issue here. I was copying 134,1 GiB of files to a
> Network  drive. The network drive went offline, so I paused the file
> transfer and resumed it after the drive was back online. Some time after
> that (I'm not sure how long it took, if it was immediately or after some
> time), Dolphin crashed
> 
> -- Backtrace (Reduced):
> #6  0x00007fd27c398f55 in QWidget::testAttribute_helper(Qt::WidgetAttribute)
> const () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
> #7  0x00007fd27c3a22af in QWidgetPrivate::createWinId() () from
> /lib/x86_64-linux-gnu/libQt5Widgets.so.5
> #8  0x00007fd27c3a202d in QWidget::create(unsigned long long, bool, bool) ()
> from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
> #9  0x00007fd27c3af34e in QWidgetPrivate::setVisible(bool) () from
> /lib/x86_64-linux-gnu/libQt5Widgets.so.5
> #10 0x00007fd27c5804c8 in QDialog::setVisible(bool) () from
> /lib/x86_64-linux-gnu/libQt5Widgets.so.5

Could you install framework kio debug symbols ?
Comment 4 niklas312 2023-04-02 20:25:06 UTC
(In reply to Méven Car from comment #3)
> How did you initiate the file transfer exactly ?
> 
> Was it in dolphin by drag and drop ? Or using Copy+Paste ? Another way ?
> 
> Did you the origin directory and destination directories have any file with
> the same name ?
> 
> (In reply to niklas312 from comment #2)
> > Created attachment 157794 [details]
> > New crash information added by DrKonqi
> > 
> > dolphin (22.12.3) using Qt 5.15.8
> > 
> > I think this is the same issue here. I was copying 134,1 GiB of files to a
> > Network  drive. The network drive went offline, so I paused the file
> > transfer and resumed it after the drive was back online. Some time after
> > that (I'm not sure how long it took, if it was immediately or after some
> > time), Dolphin crashed
> > 
> > -- Backtrace (Reduced):
> > #6  0x00007fd27c398f55 in QWidget::testAttribute_helper(Qt::WidgetAttribute)
> > const () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
> > #7  0x00007fd27c3a22af in QWidgetPrivate::createWinId() () from
> > /lib/x86_64-linux-gnu/libQt5Widgets.so.5
> > #8  0x00007fd27c3a202d in QWidget::create(unsigned long long, bool, bool) ()
> > from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
> > #9  0x00007fd27c3af34e in QWidgetPrivate::setVisible(bool) () from
> > /lib/x86_64-linux-gnu/libQt5Widgets.so.5
> > #10 0x00007fd27c5804c8 in QDialog::setVisible(bool) () from
> > /lib/x86_64-linux-gnu/libQt5Widgets.so.5
> 
> Could you install framework kio debug symbols ?

I initiated the file transfer with Copy+Paste inside two different Dolphin-tabs.
The source and destination didn't have any same files, since I copied a completely new folder.

As for the "framework kio debug symbols", of course I can install them I just don't know the package name
Comment 5 Méven Car 2023-04-03 13:25:01 UTC
(In reply to niklas312 from comment #4)
> (In reply to Méven Car from comment #3)
> > 
> > Could you install framework kio debug symbols ?
> 
> I initiated the file transfer with Copy+Paste inside two different
> Dolphin-tabs.
> The source and destination didn't have any same files, since I copied a
> completely new folder.

Thanks.

> 
> As for the "framework kio debug symbols", of course I can install them I
> just don't know the package name

It would depend on your distro.
This should be libkf5kiocore5-dbgsym and libkf5kiofilewidgets5-dbgsym for debian and ubuntu for instance.
Comment 6 niklas312 2023-04-03 18:33:45 UTC
(In reply to Méven Car from comment #5)
> It would depend on your distro.
> This should be libkf5kiocore5-dbgsym and libkf5kiofilewidgets5-dbgsym for
> debian and ubuntu for instance.

Thanks, I installed them now.
Comment 7 Ben Bonacci 2023-05-03 11:05:35 UTC
*** Bug 468345 has been marked as a duplicate of this bug. ***
Comment 8 Akseli Lahtinen 2023-11-27 10:41:31 UTC

*** This bug has been marked as a duplicate of bug 448532 ***