Bug 453997

Summary: left-clicks get swallowed after moving windows, requiring two clicks to perform an action afterwards
Product: [Plasma] kwin Reporter: bastimeyer123
Component: effects-desktop-gridAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: normal CC: nate, notmart
Priority: NOR Keywords: regression
Version: git master   
Target Milestone: ---   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In:

Description bastimeyer123 2022-05-18 16:17:28 UTC
Initial report: BUG 453943

SUMMARY
After the recent QML rewrite of the desktopgrid effect, the next click after moving windows between desktops will now get swallowed, which means in order to go back to one of the desktops after moving a window, you need to click twice.

Clicking while the opening/closing animation is playing or while windows are still animated also doesn't work as expected and the click sometimes will get ignored. This is especially frustrating when the animations are slow / their durations too long.

See https://youtu.be/A0ydBC6tvUQ


STEPS TO REPRODUCE
1. set up a grid
2. open some windows
3. move windows between desktops on the grid
4. try to left-click on a free space to return to one of the desktops


SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Arch Linux
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.4


ADDITIONAL INFORMATION
- KWin built from 09ba8729fc12 (current master) using the modified PKGBUILD of the Arch repos
- kdecoration built from 4123ec8c1993 (current master) using the modified PKGBUILD of the Arch repos
- plasma-wayland-protocols built from 26fb07b9f8d3 (current master) using the modified PKGBUILD of the Arch repos
- the remaining dependencies were all from the official Arch repos
Comment 1 Nate Graham 2022-05-19 16:33:46 UTC
Are you on X11? And if so, can you not reproduce the issue on Wayland?

If that's the case, this is probably the same as Bug 451150 and Bug 451450, which all seem to have the same root cause.
Comment 2 bastimeyer123 2022-05-19 21:15:47 UTC
Nope, seems to be only applicable to X11.
Comment 3 Nate Graham 2022-05-23 14:27:31 UTC

*** This bug has been marked as a duplicate of bug 454275 ***