Bug 444851

Summary: Gwenview crashes when opening a TIFF
Product: gwenview Reporter: Sebita <daffy>
Component: generalAssignee: Gwenview Bugs <gwenview-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash CC: nicolas.fella
Priority: NOR Keywords: drkonqi
Version: 21.08.1   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Sebita 2021-11-02 18:13:47 UTC
Application: gwenview (21.08.1)

Qt Version: 5.15.2
Frameworks Version: 5.86.0
Operating System: Linux 5.11.0-38-generic x86_64
Windowing System: X11
Drkonqi Version: 5.22.5
Distribution: Ubuntu 21.04

-- Information about the crash:
- What I was doing when the application crashed:

Opened a TIFF file from a search result list in Dolphin.
Thumbnails weren't showed when the crash happened.

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Aborted

[KCrash Handler]
#4  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:49
#5  0x00007fa70b5b4864 in __GI_abort () at abort.c:79
#6  0x00007fa70b81ba31 in ?? () from /lib/x86_64-linux-gnu/libstdc++.so.6
#7  0x00007fa70b8274fc in ?? () from /lib/x86_64-linux-gnu/libstdc++.so.6
#8  0x00007fa70b827567 in std::terminate() () from /lib/x86_64-linux-gnu/libstdc++.so.6
#9  0x00007fa70b827809 in __cxa_throw () from /lib/x86_64-linux-gnu/libstdc++.so.6
#10 0x00007fa70b81e452 in ?? () from /lib/x86_64-linux-gnu/libstdc++.so.6
#11 0x00007fa70b38ead3 in ?? () from /lib/x86_64-linux-gnu/libexiv2.so.27
#12 0x00007fa70b33292d in Exiv2::Xmpdatum::write(std::ostream&, Exiv2::ExifData const*) const () from /lib/x86_64-linux-gnu/libexiv2.so.27
#13 0x00007fa70d8bb468 in Gwenview::ImageMetaInfoModel::setExiv2Image(Exiv2::Image const*) () from /lib/x86_64-linux-gnu/libgwenviewlib.so.5
#14 0x00007fa70d8800e0 in Gwenview::Document::setExiv2Image(std::unique_ptr<Exiv2::Image, std::default_delete<Exiv2::Image> >) () from /lib/x86_64-linux-gnu/libgwenviewlib.so.5
#15 0x00007fa70d88b77b in ?? () from /lib/x86_64-linux-gnu/libgwenviewlib.so.5
#16 0x00007fa70bc835c7 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#17 0x00007fa70ba6aa25 in QFutureWatcherBase::event(QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#18 0x00007fa70c9b8783 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#19 0x00007fa70bc4b7ba in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#20 0x00007fa70bc4e7e1 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#21 0x00007fa70bca5ba7 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#22 0x00007fa7092d08eb in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fa709323d28 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fa7092ce023 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007fa70bca5204 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#26 0x00007fa70bc4a11b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#27 0x00007fa70bc52604 in QCoreApplication::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#28 0x0000557374ca153f in ?? ()
#29 0x00007fa70b5b6565 in __libc_start_main (main=0x557374ca0fe0, argc=2, argv=0x7ffc1e066308, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffc1e0662f8) at ../csu/libc-start.c:332
#30 0x0000557374ca1b6e in ?? ()
[Inferior 1 (process 2319) detached]

Possible duplicates by query: bug 444687, bug 443651, bug 443069, bug 441542, bug 441121.

Reported using DrKonqi
Comment 1 Nicolas Fella 2021-12-20 23:46:22 UTC

*** This bug has been marked as a duplicate of bug 441121 ***