Bug 433406

Summary: Dolphin crashed as I tried to access a shared Win10 folder on my network
Product: [Applications] dolphin Reporter: johann.mourlon
Component: generalAssignee: Dolphin Bug Assignee <dolphin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: normal CC: kfm-devel, nate
Priority: NOR    
Version: 20.12.2   
Target Milestone: ---   
Platform: Fedora RPMs   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: crash report

Description johann.mourlon 2021-02-21 21:15:35 UTC
Created attachment 136023 [details]
crash report

SUMMARY
Dolphin crashed as I tried to access a shared Win10 folder on my network.

STEPS TO REPRODUCE
1. Open Dolphin
2. Try to open a Win10 shared folder
3. 

OBSERVED RESULT


EXPECTED RESULT


SOFTWARE/OS VERSIONS
Windows: 10 2H20
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2021-02-21 22:57:04 UTC
Application: dolphin (20.12.2)

Qt Version: 5.15.2
Frameworks Version: 5.78.0
Operating System: Linux 5.10.16-200.fc33.x86_64 x86_64
Windowing system: X11
Distribution: "Fedora release 33 (Thirty Three)"

-- Information about the crash:
<Indiquez-nous en d├ętails ce que vous faisiez lors du plantage de l'application.>

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault

[KCrash Handler]
#4  0x00007f10c43c12cc in KFileItem::~KFileItem() () from /lib64/libKF5KIOCore.so.5
#5  0x00007f10c4957dc7 in KFileItemModel::slotClear() () from /lib64/libdolphinprivate.so.5
#6  0x00007f10c49acdf5 in DolphinView::setUrl(QUrl const&) () from /lib64/libdolphinprivate.so.5
#7  0x00007f10c4c45eeb in DolphinViewContainer::slotUrlNavigatorLocationChanged(QUrl const&) () from /lib64/libkdeinit5_dolphin.so
#8  0x00007f10c2b2f386 in void doActivate<false>(QObject*, int, void**) () from /lib64/libQt5Core.so.5
#9  0x00007f10c4885099 in KUrlNavigator::urlChanged(QUrl const&) () from /lib64/libKF5KIOFileWidgets.so.5
#10 0x00007f10c488b895 in KUrlNavigator::setLocationUrl(QUrl const&) () from /lib64/libKF5KIOFileWidgets.so.5
#11 0x00007f10c4c4537c in DolphinViewContainer::setUrl(QUrl const&) () from /lib64/libkdeinit5_dolphin.so
#12 0x00007f10c4c455b3 in DolphinViewContainer::slotItemActivated(KFileItem const&) () from /lib64/libkdeinit5_dolphin.so
#13 0x00007f10c2b2f386 in void doActivate<false>(QObject*, int, void**) () from /lib64/libQt5Core.so.5
#14 0x00007f10c493edd9 in DolphinView::itemActivated(KFileItem const&) () from /lib64/libdolphinprivate.so.5
#15 0x00007f10c49a678b in DolphinView::slotItemActivated(int) () from /lib64/libdolphinprivate.so.5
#16 0x00007f10c2b2f386 in void doActivate<false>(QObject*, int, void**) () from /lib64/libQt5Core.so.5
#17 0x00007f10c493d132 in KItemListController::itemActivated(int) () from /lib64/libdolphinprivate.so.5
#18 0x00007f10c49720d8 in KItemListController::onRelease(QPointF const&, QFlags<Qt::KeyboardModifier>, QFlags<Qt::MouseButton>, bool) () from /lib64/libdolphinprivate.so.5
#19 0x00007f10c49721c9 in KItemListController::mouseReleaseEvent(QGraphicsSceneMouseEvent*, QTransform const&) () from /lib64/libdolphinprivate.so.5
#20 0x00007f10c4976259 in KItemListController::processEvent(QEvent*, QTransform const&) () from /lib64/libdolphinprivate.so.5
#21 0x00007f10c4976351 in KItemListView::event(QEvent*) () from /lib64/libdolphinprivate.so.5
#22 0x00007f10c3658ec3 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#23 0x00007f10c2affbd8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#24 0x00007f10c3979ddd in QGraphicsScenePrivate::sendEvent(QGraphicsItem*, QEvent*) () from /lib64/libQt5Widgets.so.5
#25 0x00007f10c397a191 in QGraphicsScenePrivate::sendMouseEvent(QGraphicsSceneMouseEvent*) () from /lib64/libQt5Widgets.so.5
#26 0x00007f10c397f9d0 in QGraphicsScene::mouseReleaseEvent(QGraphicsSceneMouseEvent*) () from /lib64/libQt5Widgets.so.5
#27 0x00007f10c398c681 in QGraphicsScene::event(QEvent*) () from /lib64/libQt5Widgets.so.5
#28 0x00007f10c3658ec3 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#29 0x00007f10c2affbd8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#30 0x00007f10c39a9718 in QGraphicsView::mouseReleaseEvent(QMouseEvent*) () from /lib64/libQt5Widgets.so.5
#31 0x00007f10c3699b1e in QWidget::event(QEvent*) () from /lib64/libQt5Widgets.so.5
#32 0x00007f10c37436f2 in QFrame::event(QEvent*) () from /lib64/libQt5Widgets.so.5
#33 0x00007f10c2aff995 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#34 0x00007f10c3658eb2 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#35 0x00007f10c365feeb in QApplication::notify(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#36 0x00007f10c2affbd8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#37 0x00007f10c365eefa in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool, bool) () from /lib64/libQt5Widgets.so.5
#38 0x00007f10c36b2375 in QWidgetWindow::handleMouseEvent(QMouseEvent*) () from /lib64/libQt5Widgets.so.5
#39 0x00007f10c36b56be in QWidgetWindow::event(QEvent*) () from /lib64/libQt5Widgets.so.5
#40 0x00007f10c3658ec3 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#41 0x00007f10c2affbd8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#42 0x00007f10c2fff143 in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) () from /lib64/libQt5Gui.so.5
#43 0x00007f10c2fe08cc in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Gui.so.5
#44 0x00007f10b065547e in xcbSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib64/libQt5XcbQpa.so.5
#45 0x00007f10c0aa9a9f in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#46 0x00007f10c0afba98 in g_main_context_iterate.constprop () from /lib64/libglib-2.0.so.0
#47 0x00007f10c0aa6e73 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#48 0x00007f10c2b4c6f3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#49 0x00007f10c2afe57b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#50 0x00007f10c2b061b4 in QCoreApplication::exec() () from /lib64/libQt5Core.so.5
#51 0x00007f10c4c31d5e in kdemain () from /lib64/libkdeinit5_dolphin.so
#52 0x00007f10c4a371e2 in __libc_start_main () from /lib64/libc.so.6
#53 0x000056525f27b0ae in _start ()
[Inferior 1 (process 3649) detached]

Possible duplicates by query: bug 432483, bug 432268, bug 432132, bug 431980, bug 431536.
Comment 2 Nate Graham 2021-02-23 04:52:55 UTC

*** This bug has been marked as a duplicate of bug 426962 ***