Bug 399914

Summary: [Qt5.12]Various menus open only once
Product: [Plasma] plasmashell Reporter: Matej Mrenica <matejm98mthw>
Component: generalAssignee: David Edmundson <kde>
Status: RESOLVED UPSTREAM    
Severity: normal CC: bugseforuns, fabian, leonard, matejm98mthw, perso, plasma-bugs, rainer
Priority: HI    
Version: 5.14.2   
Target Milestone: 1.0   
Platform: Archlinux   
OS: Linux   
Latest Commit: Version Fixed In:

Description Matej Mrenica 2018-10-17 07:04:16 UTC
STEPS TO REPRODUCE
1. Open System Settings
2. Open menu in top teft corner - it's visible
3. Close it.
4. Open menu in top teft corner again - now it isn't (it opens with size of ~1px)

SOFTWARE VERSIONS
(available in About System)
KDE Plasma Version: 5.14.1
KDE Frameworks Version: 5.51
Qt Version: 5.12-beta2

ADDITIONAL INFORMATION
The same thing happens in SDDM with select-session-menu.
Comment 1 Patrick Silva 2018-10-17 09:58:40 UTC
Same thing on my system.

Operating System: Arch Linux 
KDE Plasma Version: 5.14.1
Qt Version: 5.12.0 beta2
KDE Frameworks Version: 5.51.0
Comment 2 Fabian Vogt 2018-10-17 11:31:43 UTC
Can confirm. I get this on stderr:

file:///usr/lib64/qt5/qml/QtQuick/Controls/Private/MenuContentItem.qml:239: TypeError: Cannot read property 'submenuPopupDelay' of null
file:///usr/lib64/qt5/qml/QtQuick/Controls/Private/MenuContentItem.qml:239: TypeError: Cannot read property 'submenuPopupDelay' of null
file:///usr/lib64/qt5/qml/QtQuick/Controls/Private/MenuContentItem.qml:239: TypeError: Cannot read property 'submenuPopupDelay' of null
file:///usr/lib64/qt5/qml/QtQuick/Controls/Private/MenuContentItem.qml:239: TypeError: Cannot read property 'submenuPopupDelay' of null
Comment 3 Fabian Vogt 2018-10-18 11:42:59 UTC
Reproduced in a minimal testcase and reported upstream as https://bugreports.qt.io/browse/QTBUG-71238
Comment 4 Matej Mrenica 2018-11-08 15:14:25 UTC
Still happens with Qt5.12-beta4
Comment 5 Rainer Finke 2018-11-22 21:19:48 UTC
And still an issue in Qt 5.12 RC1...
Comment 6 Fabian Vogt 2018-11-22 21:38:14 UTC
(In reply to Rainer Finke from comment #5)
> And still an issue in Qt 5.12 RC1...
There's a comment on the fix:

> Let's finally freeze the release content and keep this as a known issue in .0
> release. We will release .1 release soon (at the beginning of 2019) so there
> isn't that much time to wait it. And it is important to get the .0 out now. So
> please re-target this in '5.12' instead

I guess it's up to distros to patch that.
Comment 7 Antonio Rojas 2018-11-25 21:23:15 UTC
*** Bug 401409 has been marked as a duplicate of this bug. ***
Comment 8 Leonard Lausen 2018-11-27 06:34:20 UTC
It seems the fix made it for the QT 5.12 release
Comment 9 Patrick Silva 2018-11-29 17:27:37 UTC
*** Bug 401110 has been marked as a duplicate of this bug. ***