Bug 401409 - Can’t open main menu more than once
Summary: Can’t open main menu more than once
Status: RESOLVED DUPLICATE of bug 399914
Alias: None
Product: systemsettings
Classification: Applications
Component: general (show other bugs)
Version: 5.14.3
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-25 18:47 UTC by ariasuni
Modified: 2018-11-25 21:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ariasuni 2018-11-25 18:47:35 UTC
SUMMARY
We can open we main menu of systemsettings the first time but it doesn’t work afterwards until restart of the application.

STEPS TO REPRODUCE
1. Open the main menu of systemsettings
2. Close it
3. Try to reopen it

OBSERVED RESULT
Doesn’t open a second time. That appears in the terminal output:

file:///usr/lib/qt/qml/QtQuick/Controls/Private/MenuContentItem.qml:239: TypeError: Cannot read property 'submenuPopupDelay' of null

EXPECTED RESULT
Opens 

SOFTWARE/OS VERSIONS
Arch Linux
KDE Plasma Version: 5.14.3
KDE Frameworks Version: 5.52.0
Qt Version: 5.12.0

ADDITIONAL INFORMATION
The problem appears to be because of the update to Qt 5.12.
Comment 1 Antonio Rojas 2018-11-25 21:23:15 UTC

*** This bug has been marked as a duplicate of bug 399914 ***