Bug 381345

Summary: Create a .hidden file automatically to hide crucial Windows system folders by default ("System Volume Information" and $RECYCLE.BIN)
Product: [Frameworks and Libraries] frameworks-kio Reporter: KDE Neon user <emailmeat>
Component: generalAssignee: David Faure <faure>
Status: RESOLVED DUPLICATE    
Severity: normal CC: bhush94, kde, kdelibs-bugs, nate, plasma-bugs
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Neon   
OS: Linux   
Latest Commit: Version Fixed In:

Description KDE Neon user 2017-06-18 05:14:16 UTC
I created a request for an option to respect all Windows hidden files/folder attributes (https://bugs.kde.org/show_bug.cgi?id=364902) when I first gave Linux/KDE Neon as serious try because I had deleted the folder "System Volume Information" from a drive inadvertently, which caused me problems on Windows.

I've since learned that there's also a way to hide specific folders and files on Linux, while maintaining them intact. We just have to create a separate file named .hidden and list what is to be hidden in it.

It would be a great improvement for users if the appropriate component of KDE Plasma created that file automatically with at least "$RECYCLE.BIN", "$Recycle.Bin" and "System Volume Information" listed in it.  These system folders are visible on Dolphin and all other programs as soon as you mount and click on any SSD or HD partition, including external HDs, which have been previously used on Windows.

The few people intentionally looking for those folders know what they are doing, and will know how to view hidden folders, or access them directly through the directory path. Everybody else will have less visual clutter when browsing their drives, and not be able to accidentally delete the folders for not knowing the consequences of it.
Comment 1 Kai Uwe Broulik 2017-06-18 14:23:41 UTC
Re-assigning to KIO as that's the thing that gives us properties about files. Not sure if KIO is the right level of if Solid should do some mounting magic like in the bug report you linked. Also, probably udisks should be setting the flag, as Solid only tells it to mount. Not sure.
Comment 2 Nate Graham 2018-08-22 20:58:07 UTC

*** This bug has been marked as a duplicate of bug 171537 ***