Bug 171537 - Windows system files visible in external ntfs partition or drive
Summary: Windows system files visible in external ntfs partition or drive
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Applications
Component: view-engine: general (show other bugs)
Version: 16.12.2
Platform: Ubuntu Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
: 381345 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-09-23 16:51 UTC by mcas
Modified: 2018-08-22 20:58 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mcas 2008-09-23 16:51:46 UTC
Version:            (using KDE 4.1.1)
OS:                Linux
Installed from:    Ubuntu Packages

This wish was reported on the ubuntu bug tracker under: https://bugs.edge.launchpad.net/ubuntu/+source/kdebase/+bug/205864

Im using the new Kubuntu 8.04 KDE 4, 64 Bit version. My problem is that I have external partitions and hard drives with the ntfs format, and when mounting those drives to a Windows system, Windows will make hidden "Recycler" and "System Volume Information" folders. Sure Windows sucks, but I dont want to delete these folders because it will mess up the drive with Windows when I need to access it through Windows. I would request that these two folders be hidden by default in Dolphin. There should of course be some optional way to show the folders, but Ill leave that up to you guys to figure out. I believe it will be safer and much better looking to have those folders hidden by default.
Comment 1 Dotan Cohen 2008-12-08 12:37:27 UTC
Linux (and Unix in general) has a convention that filenames beginning with a dot are considered hidden files. I suggest that you file a bug with the developers of the NTFS file system and request that they follow this convention, as this has been standard behaviour for decades and only MS filesystem conflict. Please post a link to the bug that you file so that we can follow it.

Does Windows Explorer display hidden *nix files by default when browsing ext3 and other filesystems? Can this be configured in Windows Explorer?
Comment 2 Jeroen van Meeuwen (Kolab Systems) 2012-08-24 16:18:31 UTC
Resetting assignee to default as per bug #305719
Comment 3 Nate Graham 2017-09-03 16:44:20 UTC
There is approximately a 0% chance that Microsoft will add POSIX compatibility to NTFS and start using dotfiles for their hidden files. I think it's a reasonable request to hide these folders by default, and show them alongside dotfiles when the "Show hidden files" sessing is turned on.
Comment 4 Roman Inflianskas 2018-03-26 07:06:46 UTC
Git commit d7cce9937d5e9af2753fadb82d11f308b58bb8fa by Roman Inflianskas.
Committed on 26/03/2018 at 07:06.
Pushed by romaninflianskas into branch 'master'.

Support NTFS hidden files

Summary:
This patch implements function `isHiddenNtfs` which checks extended attribute `HIDDEN` of files from NTFS partitions and populates `UDSEntry` with `KIO::UDSEntry::UDS_HIDDEN`.

{F5747912}

Test Plan:
# Open Dolphin on Windows partition
# Check that "$Recycle.Bin", "MSOCache", "System Volume Information", etc. are hidden
# Show hidden files
# Check that Windows hidden files are displayed now

Reviewers: #dolphin, #frameworks, markg, dfaure

Reviewed By: dfaure

Subscribers: dfaure, markg, elvisangelaccio, ltoscano, anthonyfieroni, broulik, #frameworks, #dolphin

Tags: #frameworks

Differential Revision: https://phabricator.kde.org/D11204

M  +44   -0    src/ioslaves/file/file_unix.cpp

https://commits.kde.org/kio/d7cce9937d5e9af2753fadb82d11f308b58bb8fa
Comment 5 Nate Graham 2018-08-22 20:58:07 UTC
*** Bug 381345 has been marked as a duplicate of this bug. ***