Bug 376865

Summary: In-progress or half-finished animations included when capturing a screenshot by launching the app when it's not already running
Product: [Applications] Spectacle Reporter: 13hurdw
Component: GeneralAssignee: Boudhayan Gupta <me>
Status: RESOLVED FIXED    
Severity: normal CC: ad1rie3, adeptsmail, antonio.prcela, bugseforuns, cousinmarc, drokergeek, enricobe, eric1, fabiotrentino, kde, kde, kdebugs, liubomirwm, mail, nate, nils.acrimont+kde, null, null, paul.brown, pereira.alex, pierpaolo.valerio, pieterkristensen, postix, roope.kiviniemi, saileshpoudel0, thomas.cicciu
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Neon   
OS: Linux   
Latest Commit: Version Fixed In: 23.04
Attachments: Spectacle Loading Cursor Icon Captured in Rectangular Region
screenshot of Spectacle 23.04 beta

Description 13hurdw 2017-02-23 23:23:55 UTC
Created attachment 104200 [details]
Spectacle Loading Cursor Icon Captured in Rectangular Region

neon User Edition

Intel Haswell-ULT Integrated Graphics
Also reproduced in VirtualBox 5.1 live session.

To reproduce:
1. In application launcher, type "Capture"
2. Select "Capture Rectangular Region - Spectacle" option
Always reproducible.

Expected:
Only the mouse cursor gets included in the selection screen capture.

Actual:
See screenshot - the Spectacle cursor icon gets caught in the window selection along with the mouse cursor.
This only occurs when the rectangular capture mode is selected directly from the application launcher; selecting rectangular region from the Spectacle UI works as expected.
Comment 1 Julian Steinmann 2018-07-24 13:39:29 UTC
I do not have such a shortcut in the launcher menu (KDE Neon Developer edition), could you shortly check whether you do still have this entry and if yes if the bug still occurs?
Comment 2 null 2018-07-24 19:55:20 UTC
Yes, this is still a problem, and affects all capture actions (but not launching Spectacle directly).

(Julian: The desktop actions should still be there, otherwise you broke your installation. For example when pinning Spectacle to the taskbar, you should get them when right-clicking.)

org.kde.spectacle.desktop contains "StartupNotify=false", and when you normally launch Spectacle, its taskbar entry is hidden before the screenshot is captured. However, for all of the desktop actions from the context menu (as defined in the lower part of the desktop file) this does not seem to work, for them the taskbar entry (along with all startup animations and bouncy cursors) is still shown and captured.

Kai: The desktop file notification handling does not seem like an issue specific to Spectacle. Do you know which component this should be assigned to?
Comment 3 Julian Steinmann 2018-07-25 07:57:28 UTC
Ah, I figured out why the actions didn't show up when I searched for "Capture": Those entries are translated (to "Aufnehmen" in german). I'm now also able to reproduce this bug with KDE Neon.
Comment 4 Nate Graham 2018-11-14 18:38:05 UTC
*** Bug 391183 has been marked as a duplicate of this bug. ***
Comment 5 Nate Graham 2021-01-11 23:42:39 UTC
*** Bug 431380 has been marked as a duplicate of this bug. ***
Comment 6 Nate Graham 2021-01-11 23:42:47 UTC
*** Bug 425037 has been marked as a duplicate of this bug. ***
Comment 7 Nate Graham 2021-01-11 23:42:53 UTC
*** Bug 423435 has been marked as a duplicate of this bug. ***
Comment 8 Antonio Prcela 2022-07-03 16:48:06 UTC
Can't reproduce this , neither on X11 nor Wayland using Manjaro. Will have to try some other distro.

But what I do notice after the image gets saved: spectacle keeps running in the background
'/usr/bin/spectacle --dbus'
Can you check if an instance of spectacle keeps running?
Comment 9 Nate Graham 2022-07-05 15:36:25 UTC
*** Bug 455126 has been marked as a duplicate of this bug. ***
Comment 10 Nate Graham 2022-07-05 15:36:29 UTC
*** Bug 455629 has been marked as a duplicate of this bug. ***
Comment 11 kde 2022-07-13 11:51:50 UTC
(In reply to Antonio Prcela from comment #8)
I was able to reproduce it on Arch Linux, Wayland.

Regarding your question about an instance of Spectacle still running: it is running, but no `--dbus` option here on my system. My guess is that the process is related to the "after" screenshot GUI (that allows me to edit the captured image, etc).
Comment 12 Nate Graham 2022-07-13 18:25:22 UTC
*** Bug 456548 has been marked as a duplicate of this bug. ***
Comment 13 Nate Graham 2022-07-13 18:25:26 UTC
*** Bug 456646 has been marked as a duplicate of this bug. ***
Comment 14 Antonio Rojas 2022-07-26 19:45:44 UTC
*** Bug 457168 has been marked as a duplicate of this bug. ***
Comment 15 Eric Armbruster 2022-07-27 07:54:23 UTC
To reproduce, go into system settings and set animation speed to the lowest possible value. You should also be able to reproduce this with low-medium high animation speed values.

Without looking into code, I would guess that the delay before taking a screenshot does not take into account the global animation speed and is probably hardcoded or machine dependent.
Comment 16 Yuriy Vidineev 2022-07-29 21:55:35 UTC
Same issue here.

KDE Neon 5.25 User Edition
KDE 5.25.3
KDE Framework 5.96
Qt 5.15.5
Linux 5.15
running X11 on Intel UHD graphics
Comment 17 Nate Graham 2022-08-04 19:16:34 UTC
*** Bug 457467 has been marked as a duplicate of this bug. ***
Comment 18 Unknown 2022-08-04 19:35:15 UTC
Same issue here.

Fedora Linux 36
KDE-Plasma-Version: 5.25.3
KDE-Frameworks-Version: 5.96.0
Qt-Version: 5.15.5
Kernel-Version: 5.18.15-200.fc36.x86_64 (64-bit)
Wayland
Comment 19 Bug Janitor Service 2022-08-05 14:15:17 UTC
A possibly relevant merge request was started @ https://invent.kde.org/graphics/spectacle/-/merge_requests/148
Comment 20 Paul Worrall 2022-08-06 11:16:45 UTC
*** Bug 457544 has been marked as a duplicate of this bug. ***
Comment 21 Nate Graham 2022-08-10 16:12:02 UTC
Git commit a484880c1d3ea7e5c762e739d5ea851c3decef09 by Nate Graham, on behalf of Kai Uwe Broulik.
Committed on 10/08/2022 at 16:11.
Pushed by ngraham into branch 'master'.

Skip minimize and progress logic in case of no timeout

If we minimize the window, there's a chance we'll have a frame of the
minimize animation on the screenshot. Instead, restore the behavior
before introducing the timeout progress indicator and call `hide()`
on ourselves instead.

M  +1    -1    src/Gui/KSMainWindow.cpp

https://invent.kde.org/graphics/spectacle/commit/a484880c1d3ea7e5c762e739d5ea851c3decef09
Comment 22 Nate Graham 2022-08-10 16:14:06 UTC
Git commit 8455f30062f0acfaa542871652cd78332a8508a9 by Nate Graham, on behalf of Kai Uwe Broulik.
Committed on 10/08/2022 at 16:14.
Pushed by ngraham into branch 'release/22.08'.

Skip minimize and progress logic in case of no timeout

If we minimize the window, there's a chance we'll have a frame of the
minimize animation on the screenshot. Instead, restore the behavior
before introducing the timeout progress indicator and call `hide()`
on ourselves instead.


(cherry picked from commit a484880c1d3ea7e5c762e739d5ea851c3decef09)

M  +1    -1    src/Gui/KSMainWindow.cpp

https://invent.kde.org/graphics/spectacle/commit/8455f30062f0acfaa542871652cd78332a8508a9
Comment 23 Antonio Prcela 2022-08-10 17:02:48 UTC
*** Bug 457717 has been marked as a duplicate of this bug. ***
Comment 24 Patrick Silva 2022-12-16 11:24:18 UTC
*** Bug 463102 has been marked as a duplicate of this bug. ***
Comment 25 Bug Janitor Service 2023-01-17 10:06:21 UTC
A possibly relevant merge request was started @ https://invent.kde.org/graphics/spectacle/-/merge_requests/180
Comment 26 David Redondo 2023-01-27 08:51:23 UTC
Git commit 78184363fc36b86fb0bd7296193bde477e99d54a by David Redondo.
Committed on 27/01/2023 at 08:46.
Pushed by davidre into branch 'master'.

Hide windows when there is no delay

The windows where never hiddden in these cases. The opening/closing
animations that could be seen was spectacle closing and opening a
window after the screenshot was taken.

M  +2    -0    src/SpectacleCore.cpp

https://invent.kde.org/graphics/spectacle/commit/78184363fc36b86fb0bd7296193bde477e99d54a
Comment 27 Patrick Silva 2023-03-10 18:05:53 UTC
*** Bug 467156 has been marked as a duplicate of this bug. ***
Comment 28 Patrick Silva 2023-03-19 23:37:23 UTC
Created attachment 157429 [details]
screenshot of Spectacle 23.04 beta

This bug persists with Spectacle 23.04 beta. Please see the screenshot attached to this comment.

Operating System: Arch Linux 
KDE Plasma Version: 5.27.3
KDE Frameworks Version: 5.104.0
Qt Version: 5.15.8
Graphics Platform: Wayland
Comment 29 Nate Graham 2023-03-27 18:29:14 UTC
Can confirm, unfortunately. Full Screen and Rectangular Region screenshots taken form the main window with 0 delay still exhibit the issue for me on Wayland.
Comment 30 Nate Graham 2023-03-27 19:43:51 UTC
I've split out issues regarding the main window itself inappropriately appearing in screenshots into Bug 423435. The originally reported issue here should be fixed now.
Comment 31 Noah Davis 2023-04-11 16:21:36 UTC
*** Bug 463102 has been marked as a duplicate of this bug. ***