Bug 374054

Summary: System tray doesn't display the number of unread messages anymore
Product: [Applications] kmail2 Reporter: Samuel Gilbert <samuel.gilbert>
Component: UIAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED INTENTIONAL    
Severity: normal CC: kde, kdudka, montel, mtijink.bugs
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Archlinux   
OS: Linux   
Latest Commit: Version Fixed In:

Description Samuel Gilbert 2016-12-22 18:49:34 UTC
Kmail used to be able to display the number of unread messages on the system tray icon.  This is no longer the case.  In version 5.4.0, the icon is only displayed if there is at least one unread message.  There is no indication of the number of unread messages.

This is a regression compared to previous versions.  From the other bugs reports, it is clear that there is no "one size fits all" solution.  The behaviour of the system tray must be customized with the options.  This was the case in the past.
Comment 1 Laurent Montel 2016-12-26 14:35:10 UTC
Nope it's not a regression I decided to remove it as we are not able to see number when number was too big.
You can see info when you put mouse under it.

Regards
Comment 2 Christoph Feck 2016-12-30 18:16:28 UTC
*** Bug 373852 has been marked as a duplicate of this bug. ***
Comment 3 Matthijs 2017-01-07 14:42:19 UTC
Could you please reconsider? After all, anyone can just disable the option if the number is too big, and it was useful for me and others.

If not, could you point me to the commit so I can re-add it for myself? I was not able to find the relevant commit.
Comment 4 Christoph Feck 2017-02-07 02:01:02 UTC
*** Bug 375054 has been marked as a duplicate of this bug. ***
Comment 5 Christian (Fuchs) 2017-02-07 09:38:01 UTC
Another vote for reconsidering. 
For most people the number is never bigger than 2 digits, so it works perfectly fine. 

Having to move the mouse there is taking a long time and bad UX wise, whilst big numbers are an edge case.
Comment 6 Kamil Dudka 2017-08-21 10:51:31 UTC
Removing this feature was a really bad idea.  Please consider adding it back.
Comment 7 Kamil Dudka 2018-01-03 13:20:38 UTC
(In reply to Matthijs from comment #3)
> If not, could you point me to the commit so I can re-add it for myself?

See attachment #109488 [details] -- it has solved the problem for me.