Bug 330676

Summary: PIcture download
Product: digikam Reporter: Yofranch <yoann.francheteau>
Component: Database-AlbumsAssignee: Digikam Developers <digikam-bugs-null>
Status: RESOLVED FIXED    
Severity: crash CC: caulier.gilles, fredericg_99, gabor.fekete, pbhj, tpr, yoann.francheteau
Priority: NOR Keywords: drkonqi
Version: 4.0.0   
Target Milestone: ---   
Platform: openSUSE RPMs   
OS: Linux   
Latest Commit: Version Fixed In: 4.1.0
Attachments: New crash information added by DrKonqi
New crash information added by DrKonqi

Description Yofranch 2014-02-02 18:53:56 UTC
Application: digikam (4.0.0-beta3)
KDE Platform Version: 4.11.4
Qt Version: 4.8.5
Operating System: Linux 3.11.6-4-desktop x86_64
Distribution: "openSUSE 13.1 (Bottle) (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:I tried to download new picture from my camera (alpha 77, raw file format) and the application endup.

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7ff501bf2900 (LWP 3989))]

Thread 5 (Thread 0x7ff4ded5f700 (LWP 3994)):
#0  0x00007ff4f88460af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff4fc399b66 in wait (time=18446744073709551615, this=0x11bdbb0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x11bdaa0, mutex=mutex@entry=0x11bda98, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00000000005ef38e in Digikam::ScanController::run (this=0x11bd800) at /usr/src/debug/digikam-software-compilation/core/digikam/database/scancontroller.cpp:725
#4  0x00007ff4fc39968f in QThreadPrivate::start (arg=0x11bd800) at thread/qthread_unix.cpp:338
#5  0x00007ff4f88420db in start_thread () from /lib64/libpthread.so.0
#6  0x00007ff4fa8f290d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7ff4de55e700 (LWP 3995)):
#0  0x00007ff4f2f45ffa in ?? () from /usr/lib64/libglib-2.0.so.0
#1  0x00007ff4f2f46289 in g_mutex_lock () from /usr/lib64/libglib-2.0.so.0
#2  0x00007ff4f2f05750 in g_main_context_acquire () from /usr/lib64/libglib-2.0.so.0
#3  0x00007ff4f2f064c5 in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007ff4f2f0670c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007ff4fc4c5d76 in QEventDispatcherGlib::processEvents (this=0x1178950, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#6  0x00007ff4fc497d0f in QEventLoop::processEvents (this=this@entry=0x7ff4de55dca0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007ff4fc498005 in QEventLoop::exec (this=this@entry=0x7ff4de55dca0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007ff4fc396fef in QThread::exec (this=this@entry=0x11c2640) at thread/qthread.cpp:536
#9  0x00007ff4fc479513 in QInotifyFileSystemWatcherEngine::run (this=0x11c2640) at io/qfilesystemwatcher_inotify.cpp:256
#10 0x00007ff4fc39968f in QThreadPrivate::start (arg=0x11c2640) at thread/qthread_unix.cpp:338
#11 0x00007ff4f88420db in start_thread () from /lib64/libpthread.so.0
#12 0x00007ff4fa8f290d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7ff4ddd5d700 (LWP 4000)):
#0  0x00007ff4f88460af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff4fc399b66 in wait (time=18446744073709551615, this=0x1777010) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x129fd60, mutex=mutex@entry=0x129fd58, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007ff4fef23e2a in Digikam::ParkingThread::run (this=0x129fd40) at /usr/src/debug/digikam-software-compilation/core/libs/threads/threadmanager.cpp:119
#4  0x00007ff4fc39968f in QThreadPrivate::start (arg=0x129fd40) at thread/qthread_unix.cpp:338
#5  0x00007ff4f88420db in start_thread () from /lib64/libpthread.so.0
#6  0x00007ff4fa8f290d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7ff4b8f7b700 (LWP 4064)):
#0  0x00007ff4f88460af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff4fc399b66 in wait (time=18446744073709551615, this=0x485cd40) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x396ed88, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00000000007ea13c in Digikam::CameraController::run (this=0x4f74b50) at /usr/src/debug/digikam-software-compilation/core/utilities/importui/backend/cameracontroller.cpp:401
#4  0x00007ff4fc39968f in QThreadPrivate::start (arg=0x4f74b50) at thread/qthread_unix.cpp:338
#5  0x00007ff4f88420db in start_thread () from /lib64/libpthread.so.0
#6  0x00007ff4fa8f290d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7ff501bf2900 (LWP 3989)):
[KCrash Handler]
#6  Digikam::Album::globalID (this=0x0) at /usr/src/debug/digikam-software-compilation/core/digikam/album/album.cpp:227
#7  0x00000000007d87a3 in Digikam::ImportUI::slotDownload (this=0x4e05210, onlySelected=<optimized out>, deleteAfter=<optimized out>, album=0x0) at /usr/src/debug/digikam-software-compilation/core/utilities/importui/main/importui.cpp:1506
#8  0x00000000007d9786 in slotDownloadSelected (this=<optimized out>) at /usr/src/debug/digikam-software-compilation/core/utilities/importui/main/importui.cpp:1426
#9  Digikam::ImportUI::qt_static_metacall (_o=0x4e05210, _c=32596424, _id=0, _a=0x10) at /usr/src/debug/digikam-software-compilation/build/core/utilities/importui/importui.moc:199
#10 0x00007ff4fc4b111e in QObject::event (this=this@entry=0x4e05210, e=e@entry=0x5926570) at kernel/qobject.cpp:1203
#11 0x00007ff4fb608e4b in QWidget::event (this=this@entry=0x4e05210, event=event@entry=0x5926570) at kernel/qwidget.cpp:8846
#12 0x00007ff4fb9be643 in QMainWindow::event (this=this@entry=0x4e05210, event=event@entry=0x5926570) at widgets/qmainwindow.cpp:1478
#13 0x00007ff4fcfb6561 in KMainWindow::event (this=this@entry=0x4e05210, ev=ev@entry=0x5926570) at /usr/src/debug/kdelibs-4.11.4/kdeui/widgets/kmainwindow.cpp:1084
#14 0x00007ff4fcfee009 in KXmlGuiWindow::event (this=0x4e05210, ev=0x5926570) at /usr/src/debug/kdelibs-4.11.4/kdeui/xmlgui/kxmlguiwindow.cpp:126
#15 0x00007ff4fb5b98ac in QApplicationPrivate::notify_helper (this=this@entry=0x10b8e40, receiver=receiver@entry=0x4e05210, e=e@entry=0x5926570) at kernel/qapplication.cpp:4562
#16 0x00007ff4fb5bfe70 in QApplication::notify (this=this@entry=0x7ffff4f424b0, receiver=receiver@entry=0x4e05210, e=e@entry=0x5926570) at kernel/qapplication.cpp:4348
#17 0x00007ff4fcf0218a in KApplication::notify (this=0x7ffff4f424b0, receiver=0x4e05210, event=0x5926570) at /usr/src/debug/kdelibs-4.11.4/kdeui/kernel/kapplication.cpp:311
#18 0x00007ff4fc4990ad in QCoreApplication::notifyInternal (this=0x7ffff4f424b0, receiver=receiver@entry=0x4e05210, event=event@entry=0x5926570) at kernel/qcoreapplication.cpp:949
#19 0x00007ff4fc49c0ff in sendEvent (event=0x5926570, receiver=0x4e05210) at kernel/qcoreapplication.h:231
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x1017e50) at kernel/qcoreapplication.cpp:1573
#21 0x00007ff4fc49c5a3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1466
#22 0x00007ff4fc4c6493 in sendPostedEvents () at kernel/qcoreapplication.h:236
#23 postEventSourceDispatch (s=0x10afe60) at kernel/qeventdispatcher_glib.cpp:280
#24 0x00007ff4f2f06316 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#25 0x00007ff4f2f06668 in ?? () from /usr/lib64/libglib-2.0.so.0
#26 0x00007ff4f2f0670c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#27 0x00007ff4fc4c5d55 in QEventDispatcherGlib::processEvents (this=0x101dd40, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#28 0x00007ff4fb656936 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x00007ff4fc497d0f in QEventLoop::processEvents (this=this@entry=0x7ffff4f41f90, flags=...) at kernel/qeventloop.cpp:149
#30 0x00007ff4fc498005 in QEventLoop::exec (this=this@entry=0x7ffff4f41f90, flags=...) at kernel/qeventloop.cpp:204
#31 0x00007ff4fc49d13b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1221
#32 0x00007ff4fb5b806c in QApplication::exec () at kernel/qapplication.cpp:3823
#33 0x000000000049d623 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/digikam-software-compilation/core/digikam/main/main.cpp:236

Reported using DrKonqi
Comment 1 Yofranch 2014-02-04 15:52:43 UTC
Created attachment 84992 [details]
New crash information added by DrKonqi

digikam (4.0.0-beta3) on KDE Platform 4.11.5 using Qt 4.8.5

- What I was doing when the application crashed: Downloading my pictures from my sony alpha 77, raw format. I tried several and unic picture, same problem.

-- Backtrace (Reduced):
#6  Digikam::Album::globalID (this=0x0) at /usr/src/debug/digikam-software-compilation/core/digikam/album/album.cpp:227
#7  0x00000000007d87a3 in Digikam::ImportUI::slotDownload (this=0x1cf3680, onlySelected=<optimized out>, deleteAfter=<optimized out>, album=0x0) at /usr/src/debug/digikam-software-compilation/core/utilities/importui/main/importui.cpp:1506
#8  0x00000000007d9786 in slotDownloadSelected (this=<optimized out>) at /usr/src/debug/digikam-software-compilation/core/utilities/importui/main/importui.cpp:1426
#9  Digikam::ImportUI::qt_static_metacall (_o=0x1cf3680, _c=58384056, _id=0, _a=0x10) at /usr/src/debug/digikam-software-compilation/build/core/utilities/importui/importui.moc:199
[...]
#11 0x00007f94ac8bc752 in QAction::triggered (this=this@entry=0x4f094e0, _t1=false) at .moc/release-shared/moc_qaction.cpp:276
Comment 2 Teemu Rytilahti 2014-02-04 21:23:06 UTC
For some reason album pointer is null, relevant code is this:
            pAlbum = dynamic_cast<PAlbum*>(album);
            group.writeEntry(d->configLastTargetAlbum, album->globalID());
Comment 3 caulier.gilles 2014-02-05 07:15:01 UTC
Teemu,

dynamic cast check pointer validity and return null if conversion fail.

Just check if point is null at least to prevent crash

Gilles Caulier
Comment 4 caulier.gilles 2014-05-16 07:30:40 UTC
digiKam 4.0.0 is out :

http://www.digikam.org/node/713

Please check if this entry still valid with this new version.

Thanks in advance

Gilles Caulier
Comment 5 Jekyll Wu 2014-06-03 00:42:48 UTC
*** Bug 335708 has been marked as a duplicate of this bug. ***
Comment 6 Yofranch 2014-06-03 10:26:31 UTC
After killing DigikamRC in /home/#user#/.kde4/share/config folder everything went ok.
Comment 7 caulier.gilles 2014-06-03 11:47:07 UTC
Thanks for the feedback.

I close this file now. Reopen if necessary...

Gilles Caulier
Comment 8 Jekyll Wu 2014-06-08 00:20:39 UTC
*** Bug 335927 has been marked as a duplicate of this bug. ***
Comment 9 caulier.gilles 2014-08-22 19:00:24 UTC
*** Bug 338482 has been marked as a duplicate of this bug. ***
Comment 10 Frederic Grelot 2014-08-22 20:38:10 UTC
> I close this file now. Reopen if necessary...

Should it not be reopened since it's still valid?... (see #338482 against 4.0.0)
Comment 11 Gabor Fekete 2015-12-26 14:04:20 UTC
Created attachment 96300 [details]
New crash information added by DrKonqi

digikam (4.0.0) on KDE Platform 4.14.2 using Qt 4.8.6

- What I was doing when the application crashed: The program crashed each time I tried to download pictures from Nikon D3200

-- Backtrace (Reduced):
#6  Digikam::Album::globalID (this=0x0) at /build/buildd/digikam-4.0.0/core/digikam/album/album.cpp:227
#7  0x00000000007d3d43 in Digikam::ImportUI::slotDownload (this=0x423e040, onlySelected=<optimized out>, deleteAfter=<optimized out>, album=0x0) at /build/buildd/digikam-4.0.0/core/utilities/importui/main/importui.cpp:1475
#8  0x00000000007d4d26 in slotDownloadSelected (this=<optimized out>) at /build/buildd/digikam-4.0.0/core/utilities/importui/main/importui.cpp:1395
#9  Digikam::ImportUI::qt_static_metacall (_o=0x423e040, _c=69889032, _id=0, _a=0x10) at /build/buildd/digikam-4.0.0/obj-x86_64-linux-gnu/core/utilities/importui/importui.moc:199
[...]
#11 0x00007f5bec5b7a62 in QAction::triggered (this=this@entry=0x5a81b40, _t1=false) at .moc/release-shared/moc_qaction.cpp:276