Bug 330516

Summary: Muon crash during downloading software update
Product: Discover Reporter: Meriuță Cornel <meriutacornel>
Component: Updates (interactive)Assignee: Jonathan Thomas <echidnaman>
Status: RESOLVED DUPLICATE    
Severity: crash CC: aleixpol, sitter
Priority: NOR Keywords: drkonqi
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Meriuță Cornel 2014-01-28 20:03:56 UTC
Application: muon-updater (2.1.2)
KDE Platform Version: 4.12.1
Qt Version: 4.8.6
Operating System: Linux 3.13.0-5-generic x86_64
Distribution: Ubuntu Trusty Tahr (development branch)

-- Information about the crash:
- What I was doing when the application crashed:
sudo apt-get update. After openning Muon and while dowloading updates for the software, this crashed
- Unusual behavior I noticed:

- Custom settings of the application:

-- Backtrace:
Application: Administratorul de actualizări Muon (muon-updater), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f29fa12c7c0 (LWP 6019))]

Thread 3 (Thread 0x7f29e6bd4700 (LWP 6020)):
#0  0x00007f29f4b3d35d in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f29f4b3d6c9 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f29f4afc7a9 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f29f4afcccb in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f29f4afce3c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f29f7f0a836 in QEventDispatcherGlib::processEvents (this=0x7f29e00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#6  0x00007f29f7edc09f in QEventLoop::processEvents (this=this@entry=0x7f29e6bd3de0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f29f7edc395 in QEventLoop::exec (this=this@entry=0x7f29e6bd3de0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f29f7dd8c4f in QThread::exec (this=this@entry=0x11dbdb0) at thread/qthread.cpp:537
#9  0x00007f29f7ebd813 in QInotifyFileSystemWatcherEngine::run (this=0x11dbdb0) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007f29f7ddb31f in QThreadPrivate::start (arg=0x11dbdb0) at thread/qthread_unix.cpp:349
#11 0x00007f29f4fd6182 in start_thread (arg=0x7f29e6bd4700) at pthread_create.c:312
#12 0x00007f29f778fb5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7f29d66dc700 (LWP 6122)):
#0  __GI___pthread_getspecific (key=3) at pthread_getspecific.c:31
#1  0x00007f29f4b220f0 in g_thread_self () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f29f4afbe6c in g_main_context_acquire () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f29f4afcbf5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f29f4afce3c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f29f7f0a836 in QEventDispatcherGlib::processEvents (this=0x7f29c80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#6  0x00007f29f7edc09f in QEventLoop::processEvents (this=this@entry=0x7f29d66dbde0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f29f7edc395 in QEventLoop::exec (this=this@entry=0x7f29d66dbde0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f29f7dd8c4f in QThread::exec (this=this@entry=0x22b66b0) at thread/qthread.cpp:537
#9  0x00007f29f7ebd813 in QInotifyFileSystemWatcherEngine::run (this=0x22b66b0) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007f29f7ddb31f in QThreadPrivate::start (arg=0x22b66b0) at thread/qthread_unix.cpp:349
#11 0x00007f29f4fd6182 in start_thread (arg=0x7f29d66dc700) at pthread_create.c:312
#12 0x00007f29f778fb5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f29fa12c7c0 (LWP 6019)):
[KCrash Handler]
#6  UpdateModel::setResources (this=0x11b9ed0, resources=...) at /build/buildd/muon-2.1.2/updater/UpdateModel/UpdateModel.cpp:248
#7  0x00000000004111a9 in UpdaterWidget::populateUpdateModel (this=this@entry=0x1178b50) at /build/buildd/muon-2.1.2/updater/UpdaterWidget.cpp:163
#8  0x000000000041127e in UpdaterWidget::activityChanged (this=0x1178b50) at /build/buildd/muon-2.1.2/updater/UpdaterWidget.cpp:148
#9  0x000000000040d2b5 in UpdaterWidget::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at /build/buildd/muon-2.1.2/obj-x86_64-linux-gnu/updater/moc_UpdaterWidget.cpp:72
#10 0x00007f29f7ef1868 in QMetaObject::activate (sender=0x1106d60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3539
#11 0x00007f29f7ef1868 in QMetaObject::activate (sender=sender@entry=0x130efe0, m=m@entry=0x7f29f9f454c0 <AbstractBackendUpdater::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7ffffb961e80) at kernel/qobject.cpp:3539
#12 0x00007f29f9d1e602 in AbstractBackendUpdater::progressingChanged (this=this@entry=0x130efe0, _t1=false) at /build/buildd/muon-2.1.2/obj-x86_64-linux-gnu/libmuon/moc_AbstractBackendUpdater.cpp:190
#13 0x00007f29e4ed800c in ApplicationUpdates::setProgressing (this=0x130efe0, progressing=<optimized out>) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:371
#14 0x00007f29f7ef1868 in QMetaObject::activate (sender=sender@entry=0x1309f00, m=m@entry=0x7f29f9f45180 <AbstractResourcesBackend::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#15 0x00007f29f9d1f040 in AbstractResourcesBackend::fetchingChanged (this=this@entry=0x1309f00) at /build/buildd/muon-2.1.2/obj-x86_64-linux-gnu/libmuon/moc_AbstractResourcesBackend.cpp:156
#16 0x00007f29e4ecae33 in ApplicationBackend::setFetching (this=0x1309f00, f=<optimized out>) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:642
#17 0x00007f29e4ecd461 in ApplicationBackend::reload (this=0x1309f00) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationBackend.cpp:175
#18 0x00007f29e4ed80c4 in ApplicationUpdates::transactionFinished (this=0x130efe0) at /build/buildd/muon-2.1.2/libmuon/backends/ApplicationBackend/ApplicationUpdates.cpp:210
#19 0x00007f29f7ef1868 in QMetaObject::activate (sender=0x11dcb70, m=m@entry=0x7f29e48649c0 <QApt::Transaction::staticMetaObject>, local_signal_index=local_signal_index@entry=8, argv=argv@entry=0x7ffffb962140) at kernel/qobject.cpp:3539
#20 0x00007f29e464f441 in QApt::Transaction::finished (this=<optimized out>, _t1=QApt::ExitSuccess) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:338
#21 0x00007f29e46421af in QApt::Transaction::updateProperty (this=0x11dcb70, type=0, variant=...) at /build/buildd/qapt-2.0.65/src/transaction.cpp:546
#22 0x00007f29e464f974 in QApt::Transaction::qt_static_metacall (_o=0x11dcb70, _c=<optimized out>, _id=<optimized out>, _a=0x7ffffb962360) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transaction.cxx:164
#23 0x00007f29f7ef1868 in QMetaObject::activate (sender=sender@entry=0x1149b20, m=m@entry=0x7f29e4864aa0 <OrgKubuntuQaptworkerTransactionInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7ffffb962360) at kernel/qobject.cpp:3539
#24 0x00007f29e46503d6 in OrgKubuntuQaptworkerTransactionInterface::propertyChanged (this=this@entry=0x1149b20, _t1=11, _t2=...) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:246
#25 0x00007f29e465077c in OrgKubuntuQaptworkerTransactionInterface::qt_static_metacall (_o=_o@entry=0x1149b20, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=4, _a=_a@entry=0x7ffffb962620) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:111
#26 0x00007f29e46510f7 in OrgKubuntuQaptworkerTransactionInterface::qt_metacall (this=0x1149b20, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0x7ffffb962620) at /build/buildd/qapt-2.0.65/obj-x86_64-linux-gnu/src/moc_transactiondbus.cxx:164
#27 0x00007f29f6f811f6 in QDBusConnectionPrivate::deliverCall (this=0x1103300, object=0x1149b20, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:951
#28 0x00007f29f7ef5c0e in QObject::event (this=0x1149b20, e=<optimized out>) at kernel/qobject.cpp:1194
#29 0x00007f29f88cfe2c in QApplicationPrivate::notify_helper (this=this@entry=0xf6b790, receiver=receiver@entry=0x1149b20, e=e@entry=0x2391e40) at kernel/qapplication.cpp:4567
#30 0x00007f29f88d64a0 in QApplication::notify (this=this@entry=0x7ffffb962dc0, receiver=receiver@entry=0x1149b20, e=e@entry=0x2391e40) at kernel/qapplication.cpp:4353
#31 0x00007f29f95dcaaa in KApplication::notify (this=0x7ffffb962dc0, receiver=0x1149b20, event=0x2391e40) at ../../kdeui/kernel/kapplication.cpp:311
#32 0x00007f29f7edd4cd in QCoreApplication::notifyInternal (this=0x7ffffb962dc0, receiver=receiver@entry=0x1149b20, event=event@entry=0x2391e40) at kernel/qcoreapplication.cpp:953
#33 0x00007f29f7ee0b2d in sendEvent (event=0x2391e40, receiver=0x1149b20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#34 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0xf35500) at kernel/qcoreapplication.cpp:1577
#35 0x00007f29f7ee0fd3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1470
#36 0x00007f29f7f0af53 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#37 postEventSourceDispatch (s=0xf67180) at kernel/qeventdispatcher_glib.cpp:280
#38 0x00007f29f4afcb54 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#39 0x00007f29f4afcd98 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#40 0x00007f29f4afce3c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007f29f7f0a815 in QEventDispatcherGlib::processEvents (this=0xf36e00, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#42 0x00007f29f8971bb6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#43 0x00007f29f7edc09f in QEventLoop::processEvents (this=this@entry=0x7ffffb962cc0, flags=...) at kernel/qeventloop.cpp:149
#44 0x00007f29f7edc395 in QEventLoop::exec (this=this@entry=0x7ffffb962cc0, flags=...) at kernel/qeventloop.cpp:204
#45 0x00007f29f7ee1b69 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#46 0x00007f29f88ce37c in QApplication::exec () at kernel/qapplication.cpp:3828
#47 0x000000000040ce11 in main (argc=5, argv=0x7ffffb962ef8) at /build/buildd/muon-2.1.2/updater/main.cpp:59

The reporter indicates this bug may be a duplicate of or related to bug 327544.

Possible duplicates by query: bug 330484, bug 330421, bug 329760, bug 329755, bug 329725.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-01-28 23:08:32 UTC

*** This bug has been marked as a duplicate of bug 327544 ***