Bug 322487

Summary: Composition fails and KWin crashes after Ctrl+Shift+F12
Product: [Plasma] kwin Reporter: Northsoft <northsoft>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Mageia RPMs   
OS: Linux   
Latest Commit: Version Fixed In:

Description Northsoft 2013-07-17 13:28:49 UTC
Application: kwin (4.8.5 (4.8.5))
KDE Platform Version: 4.8.5 (4.8.5)
Qt Version: 4.8.4
Operating System: Linux 3.4.52-desktop-1.mga2 x86_64
Distribution: "Mageia 2"

-- Information about the crash:
- What I was doing when the application crashed:
1. Screensaver was active.
2. I've entered password and unlocked system.
- Unusual behavior I noticed:
3. Composition is down, KWin crashes, no titles and control buttons there
4. I start konsole and call kwin & from konsole, and after calling Ctrl+Shift+F12 to reenable composition KWin crashes.
Asus N61Jv, Intel i5 520m optimused with nV.GTX325m.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fd86e8c8720 (LWP 9321))]

Thread 2 (Thread 0x7fd867947700 (LWP 9323)):
#0  0x00007fd87e38e594 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fd87fa7fb92 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7fd87fd78e80) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007fd87fa7fbc9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007fd87e38ab99 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fd882ff9f7d in clone () from /lib64/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fd86e8c8720 (LWP 9321)):
[KCrash Handler]
#6  brw_update_renderbuffer_surface (brw=0x1b5cdb0, rb=0x19ee730, unit=0) at brw_wm_surface_state.c:954
#7  0x00007fd7dfd92360 in brw_update_renderbuffer_surfaces (brw=0x1b5cdb0) at brw_wm_surface_state.c:1047
#8  0x00007fd7dfd7be78 in brw_upload_state (brw=0x1b5cdb0) at brw_state_upload.c:503
#9  0x00007fd7dfd6901f in brw_try_draw_prims (max_index=<optimized out>, min_index=<optimized out>, ib=0x0, nr_prims=1, prim=0x7fffbc37b310, arrays=0x1ba08c8, ctx=0x1b5cdb0) at brw_draw.c:482
#10 brw_draw_prims (ctx=0x1b5cdb0, arrays=0x1ba08c8, prim=0x7fffbc37b310, nr_prims=1, ib=0x0, index_bounds_valid=<optimized out>, min_index=0, max_index=5, tfb_vertcount=0x0) at brw_draw.c:566
#11 0x00007fd7df9d4384 in vbo_draw_arrays (ctx=0x1b5cdb0, mode=4, start=0, count=<optimized out>, numInstances=1) at vbo/vbo_exec_array.c:600
#12 0x00007fd87f4a70c7 in KWin::GLVertexBufferPrivate::corePainting (this=0x182a170, region=<optimized out>, primitiveMode=4) at /usr/src/debug/kde-workspace-4.8.5/kwin/libkwineffects/kwinglutils.cpp:1188
#13 0x00007fd87f4a71c5 in KWin::GLVertexBuffer::render (this=0x17db1b0, region=<optimized out>, primitiveMode=4) at /usr/src/debug/kde-workspace-4.8.5/kwin/libkwineffects/kwinglutils.cpp:1297
#14 0x00007fd88336b4df in renderQuads (normalized=<optimized out>, tex=<optimized out>, quads=<optimized out>, region=..., this=<optimized out>) at /usr/src/debug/kde-workspace-4.8.5/kwin/scene_opengl.cpp:788
#15 KWin::SceneOpenGL::Window::renderQuads (this=<optimized out>, region=..., quads=<optimized out>, tex=<optimized out>, normalized=<optimized out>) at /usr/src/debug/kde-workspace-4.8.5/kwin/scene_opengl.cpp:768
#16 0x00007fd8833728d2 in KWin::SceneOpenGL::Window::performPaint (this=0x1902d50, mask=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.5/kwin/scene_opengl.cpp:592
#17 0x00007fd88335b059 in KWin::Scene::finalDrawWindow (this=<optimized out>, w=<optimized out>, mask=9, region=<optimized out>, data=<optimized out>) at /usr/src/debug/kde-workspace-4.8.5/kwin/scene.cpp:438
#18 0x00007fd88337da25 in KWin::EffectsHandlerImpl::drawWindow (this=0x1db3690, w=0x1df02e0, mask=9, region=<optimized out>, data=...) at /usr/src/debug/kde-workspace-4.8.5/kwin/effects.cpp:286
#19 0x00007fd88113b18b in KWin::Effect::drawWindow (this=<optimized out>, w=0x1df02e0, mask=9, region=<optimized out>, data=<optimized out>) at /usr/src/debug/kde-workspace-4.8.5/kwin/libkwineffects/kwineffects.cpp:181
#20 0x00007fd88337d9b9 in KWin::EffectsHandlerImpl::drawWindow (this=0x1db3690, w=0x1df02e0, mask=9, region=<optimized out>, data=...) at /usr/src/debug/kde-workspace-4.8.5/kwin/effects.cpp:283
#21 0x00007fd88335a5d5 in KWin::Scene::finalPaintWindow (this=<optimized out>, w=0x1df02d0, mask=9, region=<optimized out>, data=<optimized out>) at /usr/src/debug/kde-workspace-4.8.5/kwin/scene.cpp:429
#22 0x00007fd88337dcb5 in KWin::EffectsHandlerImpl::paintWindow (this=0x1db3690, w=0x1df02e0, mask=9, region=<optimized out>, data=...) at /usr/src/debug/kde-workspace-4.8.5/kwin/effects.cpp:249
#23 0x00007fd864aa64fb in KWin::TranslucencyEffect::paintWindow (this=<optimized out>, w=0x1df02e0, mask=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.5/kwin/effects/translucency/translucency.cpp:169
#24 0x00007fd88337dc49 in KWin::EffectsHandlerImpl::paintWindow (this=0x1db3690, w=0x1df02e0, mask=9, region=<optimized out>, data=...) at /usr/src/debug/kde-workspace-4.8.5/kwin/effects.cpp:246
#25 0x00007fd88335b258 in KWin::Scene::paintWindow (this=<optimized out>, w=0x1902d50, mask=9, region=<optimized out>, quads=...) at /usr/src/debug/kde-workspace-4.8.5/kwin/scene.cpp:385
#26 0x00007fd88335bdfd in KWin::Scene::paintSimpleScreen (this=0x1822ba0, orig_mask=8, region=) at /usr/src/debug/kde-workspace-4.8.5/kwin/scene.cpp:330
#27 0x00007fd88335a504 in KWin::Scene::finalPaintScreen (this=0x1822ba0, mask=8, region=<optimized out>, data=<optimized out>) at /usr/src/debug/kde-workspace-4.8.5/kwin/scene.cpp:198
#28 0x00007fd88337de87 in KWin::EffectsHandlerImpl::paintScreen (this=0x1db3690, mask=8, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.5/kwin/effects.cpp:222
#29 0x00007fd88113b2f8 in KWin::Effect::paintScreen (this=<optimized out>, mask=8, region=<optimized out>, data=...) at /usr/src/debug/kde-workspace-4.8.5/kwin/libkwineffects/kwineffects.cpp:141
#30 0x00007fd88337de2b in KWin::EffectsHandlerImpl::paintScreen (this=0x1db3690, mask=8, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.5/kwin/effects.cpp:219
#31 0x00007fd88335cc05 in KWin::Scene::paintScreen (this=0x1822ba0, mask=0x7fffbc37c4e8, region=0x7fffbc37c5d0) at /usr/src/debug/kde-workspace-4.8.5/kwin/scene.cpp:156
#32 0x00007fd8833733dd in KWin::SceneOpenGL::paint (this=0x1822ba0, damage=..., toplevels=<optimized out>) at /usr/src/debug/kde-workspace-4.8.5/kwin/scene_opengl_glx.cpp:459
#33 0x00007fd883357198 in KWin::Workspace::performCompositing (this=0x16a1d30) at /usr/src/debug/kde-workspace-4.8.5/kwin/composite.cpp:417
#34 0x00007fd87e733969 in QObject::event (this=0x16a1d30, e=<optimized out>) at kernel/qobject.cpp:1156
#35 0x00007fd87d88aec4 in notify_helper (e=0x7fffbc37ccb0, receiver=0x16a1d30, this=0x162a6d0) at kernel/qapplication.cpp:4562
#36 QApplicationPrivate::notify_helper (this=0x162a6d0, receiver=0x16a1d30, e=0x7fffbc37ccb0) at kernel/qapplication.cpp:4534
#37 0x00007fd87d88fc93 in QApplication::notify (this=0x7fffbc37d0d0, receiver=0x16a1d30, e=0x7fffbc37ccb0) at kernel/qapplication.cpp:4423
#38 0x00007fd882a61ac6 in KApplication::notify (this=0x7fffbc37d0d0, receiver=0x16a1d30, event=0x7fffbc37ccb0) at /usr/src/debug/kdelibs-4.8.5/kdeui/kernel/kapplication.cpp:311
#39 0x00007fd87e71abec in QCoreApplication::notifyInternal (this=0x7fffbc37d0d0, receiver=0x16a1d30, event=0x7fffbc37ccb0) at kernel/qcoreapplication.cpp:946
#40 0x00007fd87e74ba92 in sendEvent (event=0x7fffbc37ccb0, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#41 QTimerInfoList::activateTimers (this=0x162b0c8) at kernel/qeventdispatcher_unix.cpp:622
#42 0x00007fd87e74c494 in QEventDispatcherUNIX::processEvents (this=0x15cbad0, flags=...) at kernel/qeventdispatcher_unix.cpp:941
#43 0x00007fd87d92efa8 in QEventDispatcherX11::processEvents (this=0x15cbad0, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#44 0x00007fd87e719722 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#45 0x00007fd87e719977 in QEventLoop::exec (this=0x7fffbc37d010, flags=...) at kernel/qeventloop.cpp:204
#46 0x00007fd87e71e725 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#47 0x00007fd88330c8b6 in kdemain (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/kde-workspace-4.8.5/kwin/main.cpp:541
#48 0x00007fd882f4132d in __libc_start_main () from /lib64/libc.so.6
#49 0x0000000000400671 in _start () at ../sysdeps/x86_64/elf/start.S:113

Possible duplicates by query: bug 321352, bug 320624, bug 319758, bug 319007, bug 317796.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2013-07-17 13:41:44 UTC
"kcmshell4 kwincomspositing", 3rd tab - is  "suspend compositing for fullscreen windows" checked? Can you still reproduce this when unchecking it?
What about entries in /var/log/Xorg.0.log (for the KWin maintainer, the synaptics driver flooded the X11 event queue, leading to a hung GPU)

*** This bug has been marked as a duplicate of bug 299333 ***