Bug 320371

Summary: Panels not hidden when they should be
Product: digikam Reporter: DrSlony <bugs>
Component: Albums-MainViewAssignee: Digikam Developers <digikam-bugs-null>
Status: RESOLVED FIXED    
Severity: normal CC: bugs, caulier.gilles
Priority: NOR    
Version: 3.2.0   
Target Milestone: ---   
Platform: Gentoo Packages   
OS: Linux   
Latest Commit: Version Fixed In: 3.3.0
Attachments: ImportUI full-screen options
LightTable full-screen options
ImageEditor full-screen options
AlbumUI full-screen options

Description DrSlony 2013-05-28 00:28:34 UTC
Hide toolbars/thumbbar/sidebars does not work correctly.

Reproducible: Always

Steps to Reproduce:
Settings > Configure digikam > Album View > Hide toolbars, Hide thumbbar, Hide sidebars
Press Ctrl+Shift+f, and things seem to work correctly.
Restart digiKam.
Press Ctrl+Shift+f, now the window border and the bottom bar with the filters disappears, but the toolbars, thumbbar and sidebars do not.
Settings > Configure digikam, don't change anything, just click OK to close it.
Press Ctrl+Shift+f, now the panels hide correctly.
Comment 1 caulier.gilles 2013-05-28 04:15:22 UTC
When you close digiKam to restart, you still in Full Screen mode ?

Gilles Caulier
Comment 2 DrSlony 2013-05-28 11:17:20 UTC
I go back to normal mode before closing.

Now that you asked I tried going to fullscreen mode and hitting Alt+F4 to close digiKam. When I restart digiKam the menus are hidden and hitting Ctrl+Shift+f doesn't get them back! Only people who know of the Ctrl+m shortcut will be able to get them back.

I've recorded a screencast for you. It shows how the panels are not hidden despite the hide buttons being ticked, then it shows that the panels do hide if I simply go into Configure digiKam and just press OK, and then it shows that when I close digiKam while in fullscreen mode (using Alt+F4), the menu bar is missing after restarting, and I had to use Ctrl+m to get it back.
http://filebin.net/nsiav9f7yo
Comment 3 caulier.gilles 2013-05-28 11:21:46 UTC
With 3.2.0 release i factored Fullscreen mode code and rewritten a lots of stuff...

I'm sure to have tested all these case here, and all are not reproducible...

The question is why ???

main window affected to factored code are :

- AlbumGUI
- ImportUI
- LightTable
- BQM
- ImageEditor

For each window, full screen settings is recorded in digikamrc config file from your home dir.

Can you reproduce the dysfunction with all windows ?

Gilles Caulier
Comment 4 caulier.gilles 2013-05-28 12:05:54 UTC
Git commit 439316380574b6dc8b3c3ed37efa1e74656c342f by Gilles Caulier.
Committed on 28/05/2013 at 14:01.
Pushed by cgilles into branch 'master'.

factoring everywhere Genreal config group used to store main windows settings in RC file
Ensure that full screen settings is loaded at initialization of AlbumGUI.
Related: bug 320016, bug 319876

M  +11   -9    digikam/main/digikamapp.cpp
M  +6    -6    digikam/utils/albumsettings.cpp
M  +1    -1    digikam/utils/albumsettings.h
M  +4    -4    utilities/setup/setupalbumview.cpp

http://commits.kde.org/digikam/439316380574b6dc8b3c3ed37efa1e74656c342f
Comment 5 DrSlony 2013-05-28 13:50:45 UTC
When I enable
Settings > Configure digikam > Light Table > Hide toolbars, Hide sidebars
and restart digiKam, all panels still hide as they should in the Light Table, so that part works. Seems that just the album view does not.

I found no "Hide toolbars/sidebars" options for ImportUI, BQM or ImageEditor.
Comment 6 caulier.gilles 2013-05-28 17:46:12 UTC
Created attachment 80132 [details]
ImportUI full-screen options
Comment 7 caulier.gilles 2013-05-28 17:46:44 UTC
Created attachment 80133 [details]
LightTable full-screen options
Comment 8 caulier.gilles 2013-05-28 17:47:09 UTC
Created attachment 80134 [details]
ImageEditor full-screen options
Comment 9 caulier.gilles 2013-05-28 17:47:35 UTC
Created attachment 80135 [details]
AlbumUI full-screen options
Comment 10 caulier.gilles 2013-05-28 17:48:53 UTC
Only LightTable as thumbbar settings not present, because this tool will become unsuitable without it...

BQM do not have settings panel for full screen.

Gilles Caulier
Comment 11 DrSlony 2013-05-28 19:48:24 UTC
Having ticked all those boxes:
AlbumGUI - does not hide what it should
ImportUI - no problem
Light Table - no problem
Image Editor - no problem
Comment 12 caulier.gilles 2013-05-28 21:22:36 UTC
yes this i have suspected...

Gilles Caulier