Bug 318919

Summary: Excessive widget size limits - System Monitor
Product: [Plasma] plasma4 Reporter: Mircea Kitsune <sonichedgehog_hyperblast00>
Component: widget-systemmonitorAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED UNMAINTAINED    
Severity: minor CC: sonichedgehog_hyperblast00
Priority: NOR    
Version: 4.10.2   
Target Milestone: ---   
Platform: Other   
OS: Linux   
URL: http://i41.tinypic.com/25i2dlj.jpg
Latest Commit: Version Fixed In:

Description Mircea Kitsune 2013-04-26 11:39:55 UTC
I recently posted my belief that several plasma widget have size limits which are too big, making them difficult or impossible to use due to the space they take on the desktop. http://forum.kde.org/viewtopic.php?f=73&t=110386 As advised, I'm making a ticket for each plasmoid which I believe to have excessive size limits which should be lowered.

This one is for the System Monitor widget. Its horizontal size limit is very excessive, and takes up 1 / 5 of my screen at a resolution of 1680 x 1050. I must avoid using it because it covers too much of my desktop, and instead placed the individual Temperature / CPU / Memory / Drive / Network plasmoids which can be shrunk to the right size.

I assume this might be due to the icons at the top, which allow you to add or remove monitors from the widget. My suggestion would be shrinking those icons if the widget is squeezed horizontally, or changing them with something else which doesn't impose such a large horizontal limit.

Here's a screenshot of the widget at its minimum size, which is visibly very large: http://i41.tinypic.com/25i2dlj.jpg

Reproducible: Always
Comment 1 Mircea Kitsune 2013-04-26 12:36:22 UTC
Here is a list of all widgets reported in this set, in case anyone's interested in related issues:

Excessive widget size limits - System Monitor: https://bugs.kde.org/show_bug.cgi?id=318919

Excessive widget size limits - Weather Forecast: https://bugs.kde.org/show_bug.cgi?id=318920

Excessive widget size limits - LCD Weather: https://bugs.kde.org/show_bug.cgi?id=318921

Excessive widget size limits - Shelf: https://bugs.kde.org/show_bug.cgi?id=318922

Excessive widget size limits - Calendar: https://bugs.kde.org/show_bug.cgi?id=318923
Comment 2 Nate Graham 2018-06-08 19:40:30 UTC
Hello!

This bug report was filed for KDE Plasma 4, which reached end-of-support status in August 2015. KDE Plasma 5's desktop shell has been almost completely rewritten for better performance and usability, so it is likely that this bug is already resolved in Plasma 5.

Accordingly, we hope you understand why we must close this bug report. If the issue described  here is still present in KDE Plasma 5.12 or later, please feel free to open a new ticket in the "plasmashell" product after reading https://community.kde.org/Get_Involved/Bug_Reporting

If you would like to get involved in KDE's bug triaging effort so that future mass bug closes like this are less likely, please read https://community.kde.org/Get_Involved#Bug_Triaging

Thanks for your understanding!

Nate Graham