Bug 311682

Summary: kwin crashed while stellarium was runnung
Product: [Plasma] kwin Reporter: g1suh <ken_speakman>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: 4.9.3   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description g1suh 2012-12-14 11:43:18 UTC
Application: kwin (4.9.3)
KDE Platform Version: 4.9.3
Qt Version: 4.8.3
Operating System: Linux 3.5.0-19-generic x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:
- What I was doing when the application crashed: using the satellites plugin in stellarium - I was trying to select a specific satellite for display.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f969f44c780 (LWP 2444))]

Thread 2 (Thread 0x7f9694a66700 (LWP 2450)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f96af3f1cd7 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f96af3f1d09 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f96a74f5e9a in start_thread (arg=0x7f9694a66700) at pthread_create.c:308
#4  0x00007f96b24c8cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f969f44c780 (LWP 2444)):
[KCrash Handler]
#6  brw_update_renderbuffer_surface (brw=0x22ee2c0, rb=0x227f2c0, unit=0) at brw_wm_surface_state.c:1109
#7  0x00007f96969f8aa0 in brw_update_renderbuffer_surfaces (brw=0x22ee2c0) at brw_wm_surface_state.c:1205
#8  0x00007f96969e2ae2 in brw_upload_state (brw=brw@entry=0x22ee2c0) at brw_state_upload.c:498
#9  0x00007f96969d01d7 in brw_try_draw_prims (max_index=35, min_index=424799160, ib=<optimized out>, nr_prims=<optimized out>, prim=0x7fff1951eba0, arrays=<optimized out>, ctx=0x22ee2c0) at brw_draw.c:493
#10 brw_draw_prims (ctx=0x22ee2c0, prim=0x7fff1951eba0, nr_prims=<optimized out>, ib=<optimized out>, index_bounds_valid=<optimized out>, min_index=0, max_index=35, tfb_vertcount=0x0) at brw_draw.c:589
#11 0x00007f969654fb54 in vbo_draw_arrays (ctx=0x22ee2c0, mode=4, start=0, count=36, numInstances=1, baseInstance=<optimized out>) at ../../../../../src/mesa/vbo/vbo_exec_array.c:645
#12 0x00007f96aee4789e in KWin::GLVertexBufferPrivate::corePainting (this=0x22bb850, region=..., primitiveMode=4, hardwareClipping=<optimized out>) at ../../../kwin/libkwineffects/kwinglutils.cpp:1218
#13 0x00007f96aee47dbd in KWin::GLVertexBuffer::render (this=this@entry=0x22ab8b0, region=..., primitiveMode=primitiveMode@entry=4, hardwareClipping=hardwareClipping@entry=false) at ../../../kwin/libkwineffects/kwinglutils.cpp:1341
#14 0x00007f96aee47e41 in KWin::GLVertexBuffer::render (this=0x22ab8b0, primitiveMode=4) at ../../../kwin/libkwineffects/kwinglutils.cpp:1333
#15 0x00007f96b2854731 in KWin::SceneOpenGL::paintBackground (this=this@entry=0x22a3fa0, region=...) at ../../kwin/scene_opengl.cpp:210
#16 0x00007f96b2844270 in KWin::Scene::paintSimpleScreen (this=this@entry=0x22a3fa0, orig_mask=orig_mask@entry=0, region=...) at ../../kwin/scene.cpp:323
#17 0x00007f96b2841ee2 in KWin::Scene::finalPaintScreen (this=0x22a3fa0, mask=0, region=..., data=...) at ../../kwin/scene.cpp:192
#18 0x00007f96b2861523 in KWin::EffectsHandlerImpl::paintScreen (this=0x262fdf0, mask=mask@entry=0, region=..., data=...) at ../../kwin/effects.cpp:246
#19 0x00007f96b0cb3bf7 in KWin::Effect::paintScreen (this=this@entry=0x2632040, mask=mask@entry=0, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#20 0x00007f96b28614cb in KWin::EffectsHandlerImpl::paintScreen (this=0x262fdf0, mask=mask@entry=0, region=..., data=...) at ../../kwin/effects.cpp:243
#21 0x00007f96b0cb3bf7 in KWin::Effect::paintScreen (this=this@entry=0x2744f80, mask=mask@entry=0, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#22 0x00007f96b28614cb in KWin::EffectsHandlerImpl::paintScreen (this=0x262fdf0, mask=0, region=..., data=...) at ../../kwin/effects.cpp:243
#23 0x00007f96b284352b in KWin::Scene::paintScreen (this=0x22a3fa0, mask=0x7fff1951f24c, region=0x7fff1951f2f0) at ../../kwin/scene.cpp:146
#24 0x00007f96b28580ed in KWin::SceneOpenGL::paint (this=0x22a3fa0, damage=..., toplevels=...) at ../../kwin/scene_opengl_glx.cpp:499
#25 0x00007f96b283d228 in KWin::Workspace::performCompositing (this=0x220a560) at ../../kwin/composite.cpp:443
#26 0x00007f96ae15926c in QObject::event (this=0x220a560, e=<optimized out>) at kernel/qobject.cpp:1157
#27 0x00007f96ad4ebe9c in QApplicationPrivate::notify_helper (this=this@entry=0x2120470, receiver=receiver@entry=0x220a560, e=e@entry=0x7fff1951f9d0) at kernel/qapplication.cpp:4562
#28 0x00007f96ad4f030a in QApplication::notify (this=0x7fff19520010, receiver=0x220a560, e=0x7fff1951f9d0) at kernel/qapplication.cpp:4423
#29 0x00007f96b1fb71d6 in KApplication::notify (this=0x7fff19520010, receiver=0x220a560, event=0x7fff1951f9d0) at ../../kdeui/kernel/kapplication.cpp:311
#30 0x00007f96ae14456e in QCoreApplication::notifyInternal (this=0x7fff19520010, receiver=0x220a560, event=0x7fff1951f9d0) at kernel/qcoreapplication.cpp:915
#31 0x00007f96ae175462 in sendEvent (event=0x7fff1951f9d0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#32 QTimerInfoList::activateTimers (this=0x2120fb8) at kernel/qeventdispatcher_unix.cpp:611
#33 0x00007f96ae1754c0 in QEventDispatcherUNIX::activateTimers (this=this@entry=0x20c5ad0) at kernel/qeventdispatcher_unix.cpp:868
#34 0x00007f96ae175618 in QEventDispatcherUNIX::processEvents (this=0x20c5ad0, flags=...) at kernel/qeventdispatcher_unix.cpp:930
#35 0x00007f96ad591a3f in QEventDispatcherX11::processEvents (this=0x20c5ad0, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#36 0x00007f96ae1432bf in QEventLoop::processEvents (this=this@entry=0x7fff1951fd20, flags=...) at kernel/qeventloop.cpp:149
#37 0x00007f96ae143548 in QEventLoop::exec (this=0x7fff1951fd20, flags=...) at kernel/qeventloop.cpp:204
#38 0x00007f96ae148708 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#39 0x00007f96b27f6e14 in kdemain (argc=1, argv=0x7fff19520158) at ../../kwin/main.cpp:545
#40 0x00007f96b23f676d in __libc_start_main (main=0x4006a0 <main(int, char**)>, argc=1, ubp_av=0x7fff19520158, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff19520148) at libc-start.c:226
#41 0x00000000004006d1 in _start ()

Possible duplicates by query: bug 310612, bug 310417, bug 310027, bug 309415, bug 307027.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2012-12-14 12:54:40 UTC
driver bug, review comment #17 in the dupe

*** This bug has been marked as a duplicate of bug 299333 ***