Bug 311671

Summary: kwin crashes when screensaver is active for more than one day
Product: [Plasma] kwin Reporter: cki <christofk>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: openSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description cki 2012-12-14 08:26:40 UTC
Application: kwin (4.9.4 "release 1")
KDE Platform Version: 4.9.4 "release 4"
Qt Version: 4.8.3
Operating System: Linux 3.6.10-1-desktop x86_64
Distribution: "openSUSE 12.2 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I wanted to unlock screensaver after leaving the pc for more than one day.
A vmware machine is running on that pc

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f0f53296780 (LWP 4314))]

Thread 3 (Thread 0x7f0f35436700 (LWP 4356)):
#0  0x00007f0f4e36b8f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f0f355e54e3 in ?? () from /usr/lib64/dri/r600_dri.so
#2  0x00007f0f4e367e0e in start_thread () from /lib64/libpthread.so.0
#3  0x00007f0f52abe2bd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f0f2ffff700 (LWP 4361)):
#0  0x00007f0f4e36b8f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f0f4f9b3247 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f0f4fcc0640 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f0f4f9b3279 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f0f4e367e0e in start_thread () from /lib64/libpthread.so.0
#4  0x00007f0f52abe2bd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f0f53296780 (LWP 4314)):
[KCrash Handler]
#6  0x00007f0f355caa3d in ?? () from /usr/lib64/dri/r600_dri.so
#7  0x00007f0f355cb889 in ?? () from /usr/lib64/dri/r600_dri.so
#8  0x00007f0f3575d75e in ?? () from /usr/lib64/dri/r600_dri.so
#9  0x00007f0f3575cf3f in ?? () from /usr/lib64/dri/r600_dri.so
#10 0x00007f0f356a28bf in ?? () from /usr/lib64/dri/r600_dri.so
#11 0x00007f0f3569bb63 in ?? () from /usr/lib64/dri/r600_dri.so
#12 0x00007f0f4f4082de in KWin::GLVertexBufferPrivate::corePainting (this=0x117dd40, region=..., primitiveMode=4, hardwareClipping=false) at /usr/src/debug/kde-workspace-4.9.4/kwin/libkwineffects/kwinglutils.cpp:1218
#13 0x00007f0f4f4087fd in KWin::GLVertexBuffer::render (this=0x1178310, region=..., primitiveMode=4, hardwareClipping=false) at /usr/src/debug/kde-workspace-4.9.4/kwin/libkwineffects/kwinglutils.cpp:1341
#14 0x00007f0f52e3e54f in renderQuads (hardwareClipping=false, normalized=<optimized out>, tex=<optimized out>, quads=..., region=..., this=<optimized out>) at /usr/src/debug/kde-workspace-4.9.4/kwin/scene_opengl.cpp:795
#15 KWin::SceneOpenGL::Window::renderQuads (this=<optimized out>, region=..., quads=..., tex=<optimized out>, normalized=<optimized out>, hardwareClipping=false) at /usr/src/debug/kde-workspace-4.9.4/kwin/scene_opengl.cpp:774
#16 0x00007f0f52e4095e in KWin::SceneOpenGL::Window::paintShadow (this=this@entry=0xe6c110, region=..., data=..., hardwareClipping=hardwareClipping@entry=false) at /usr/src/debug/kde-workspace-4.9.4/kwin/scene_opengl.cpp:703
#17 0x00007f0f52e44462 in KWin::SceneOpenGL::Window::performPaint (this=0xe6c110, mask=10, region=..., data=...) at /usr/src/debug/kde-workspace-4.9.4/kwin/scene_opengl.cpp:526
#18 0x00007f0f52e30586 in KWin::Scene::finalDrawWindow (this=<optimized out>, w=0x1390390, mask=10, region=..., data=...) at /usr/src/debug/kde-workspace-4.9.4/kwin/scene.cpp:454
#19 0x00007f0f52e4f04a in KWin::EffectsHandlerImpl::drawWindow (this=0x136be30, w=w@entry=0x1390390, mask=mask@entry=10, region=..., data=...) at /usr/src/debug/kde-workspace-4.9.4/kwin/effects.cpp:310
#20 0x00007f0f345d59ed in KWin::BlurEffect::drawWindow (this=<optimized out>, w=0x1390390, mask=10, region=..., data=...) at /usr/src/debug/kde-workspace-4.9.4/kwin/effects/blur/blur.cpp:405
#21 0x00007f0f52e4efeb in KWin::EffectsHandlerImpl::drawWindow (this=0x136be30, w=w@entry=0x1390390, mask=mask@entry=10, region=..., data=...) at /usr/src/debug/kde-workspace-4.9.4/kwin/effects.cpp:307
#22 0x00007f0f52e2f9fa in KWin::Scene::finalPaintWindow (this=<optimized out>, w=0x1390390, mask=10, region=..., data=...) at /usr/src/debug/kde-workspace-4.9.4/kwin/scene.cpp:439
#23 0x00007f0f52e4ebfa in KWin::EffectsHandlerImpl::paintWindow (this=0x136be30, w=w@entry=0x1390390, mask=mask@entry=10, region=..., data=...) at /usr/src/debug/kde-workspace-4.9.4/kwin/effects.cpp:273
#24 0x00007f0f51275c4a in KWin::Effect::paintWindow (this=<optimized out>, w=0x1390390, mask=10, region=..., data=...) at /usr/src/debug/kde-workspace-4.9.4/kwin/libkwineffects/kwineffects.cpp:157
#25 0x00007f0f52e4eb9b in KWin::EffectsHandlerImpl::paintWindow (this=0x136be30, w=0x1390390, mask=mask@entry=10, region=..., data=...) at /usr/src/debug/kde-workspace-4.9.4/kwin/effects.cpp:270
#26 0x00007f0f52e327cd in KWin::Scene::paintWindow (this=<optimized out>, w=0xe6c110, mask=10, region=..., quads=...) at /usr/src/debug/kde-workspace-4.9.4/kwin/scene.cpp:348
#27 0x00007f0f52e31b2f in KWin::Scene::paintSimpleScreen (this=this@entry=0xf8f4b0, orig_mask=orig_mask@entry=8, region=...) at /usr/src/debug/kde-workspace-4.9.4/kwin/scene.cpp:334
#28 0x00007f0f52e2f942 in KWin::Scene::finalPaintScreen (this=0xf8f4b0, mask=8, region=..., data=...) at /usr/src/debug/kde-workspace-4.9.4/kwin/scene.cpp:192
#29 0x00007f0f52e4edc3 in KWin::EffectsHandlerImpl::paintScreen (this=0x136be30, mask=mask@entry=8, region=..., data=...) at /usr/src/debug/kde-workspace-4.9.4/kwin/effects.cpp:246
#30 0x00007f0f51275cb7 in KWin::Effect::paintScreen (this=this@entry=0x138ba60, mask=mask@entry=8, region=..., data=...) at /usr/src/debug/kde-workspace-4.9.4/kwin/libkwineffects/kwineffects.cpp:142
#31 0x00007f0f52e4ed6b in KWin::EffectsHandlerImpl::paintScreen (this=0x136be30, mask=8, region=..., data=...) at /usr/src/debug/kde-workspace-4.9.4/kwin/effects.cpp:243
#32 0x00007f0f52e30f8b in KWin::Scene::paintScreen (this=0xf8f4b0, mask=0x7fff922db9ac, region=0x7fff922dba50) at /usr/src/debug/kde-workspace-4.9.4/kwin/scene.cpp:146
#33 0x00007f0f52e45bad in KWin::SceneOpenGL::paint (this=0xf8f4b0, damage=..., toplevels=...) at /usr/src/debug/kde-workspace-4.9.4/kwin/scene_opengl_glx.cpp:499
#34 0x00007f0f52e2ac88 in KWin::Workspace::performCompositing (this=0xf224d0) at /usr/src/debug/kde-workspace-4.9.4/kwin/composite.cpp:443
#35 0x00007f0f4e70e31c in QObject::event (this=0xf224d0, e=<optimized out>) at kernel/qobject.cpp:1166
#36 0x00007f0f4d88774c in QApplicationPrivate::notify_helper (this=this@entry=0xe04c00, receiver=receiver@entry=0xf224d0, e=e@entry=0x7fff922dc1e0) at kernel/qapplication.cpp:4557
#37 0x00007f0f4d88bbca in QApplication::notify (this=0x7fff922dc820, receiver=0xf224d0, e=0x7fff922dc1e0) at kernel/qapplication.cpp:4418
#38 0x00007f0f525bb616 in KApplication::notify (this=0x7fff922dc820, receiver=0xf224d0, event=0x7fff922dc1e0) at /usr/src/debug/kdelibs-4.9.4/kdeui/kernel/kapplication.cpp:311
#39 0x00007f0f4e6f9b0e in QCoreApplication::notifyInternal (this=0x7fff922dc820, receiver=0xf224d0, event=0x7fff922dc1e0) at kernel/qcoreapplication.cpp:915
#40 0x00007f0f4e72a561 in sendEvent (event=0x7fff922dc1e0, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#41 QTimerInfoList::activateTimers (this=0xe055f8) at kernel/qeventdispatcher_unix.cpp:626
#42 0x00007f0f4e72aba0 in QEventDispatcherUNIX::activateTimers (this=this@entry=0xdbca70) at kernel/qeventdispatcher_unix.cpp:883
#43 0x00007f0f4e72acf8 in QEventDispatcherUNIX::processEvents (this=0xdbca70, flags=...) at kernel/qeventdispatcher_unix.cpp:945
#44 0x00007f0f4d92887f in QEventDispatcherX11::processEvents (this=0xdbca70, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#45 0x00007f0f4e6f885f in QEventLoop::processEvents (this=this@entry=0x7fff922dc530, flags=...) at kernel/qeventloop.cpp:149
#46 0x00007f0f4e6f8ae8 in QEventLoop::exec (this=0x7fff922dc530, flags=...) at kernel/qeventloop.cpp:204
#47 0x00007f0f4e6fd788 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#48 0x00007f0f52de48a4 in kdemain (argc=3, argv=0x7fff922dc968) at /usr/src/debug/kde-workspace-4.9.4/kwin/main.cpp:545
#49 0x00007f0f529fb455 in __libc_start_main () from /lib64/libc.so.6
#50 0x0000000000400721 in _start () at ../sysdeps/x86_64/elf/start.S:113

Possible duplicates by query: bug 310612, bug 307027, bug 306927, bug 306867, bug 304464.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2012-12-14 12:54:36 UTC
driver bug, review comment #17 in the dupe

*** This bug has been marked as a duplicate of bug 299333 ***