Bug 309801

Summary: kdedinit4 segmentation fault 11
Product: kdelibs Reporter: Günter Opitz-Ohlsen <guenter.opitz-ohlsen>
Component: kdedAssignee: Unassigned bugs mailing-list <unassigned-bugs>
Status: RESOLVED NOT A BUG    
Severity: crash CC: cfeck
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: openSUSE RPMs   
OS: Linux   
Latest Commit: Version Fixed In:

Description Günter Opitz-Ohlsen 2012-11-09 11:20:11 UTC
Application: kded4 ($Id$)
KDE Platform Version: 4.9.80 "release 1"
Qt Version: 4.8.3
Operating System: Linux 3.5.4-1-desktop x86_64
Distribution: "openSUSE 12.2 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed: I logged in under my account on my desktop computer. The screen remained black (no desktop was appearing) and I saw the window with the error message. Launching applications was only possible when I entered ALT+F2.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE-Dienst (kdeinit4), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f39bbac6780 (LWP 8323))]

Thread 4 (Thread 0x7f399b3fc700 (LWP 8328)):
#0  0x00007f39b916c13f in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f39b5eb4684 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f39b5eb47a4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f39ba7bacf6 in QEventDispatcherGlib::processEvents (this=0x7f39940008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f39ba78b85f in QEventLoop::processEvents (this=this@entry=0x7f399b3fbdd0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f39ba78bae8 in QEventLoop::exec (this=0x7f399b3fbdd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f39ba68dfc0 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f39ba76bfcf in QInotifyFileSystemWatcherEngine::run (this=0x1537df0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f39ba690f9c in QThreadPrivate::start (arg=0x1537df0) at thread/qthread_unix.cpp:338
#9  0x00007f39ba3fae0e in start_thread (arg=0x7f399b3fc700) at pthread_create.c:305
#10 0x00007f39b91742bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7f3991b06700 (LWP 8330)):
#0  0x00007f39b5eb47be in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f39ba7bacf6 in QEventDispatcherGlib::processEvents (this=0x7f398c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#2  0x00007f39ba78b85f in QEventLoop::processEvents (this=this@entry=0x7f3991b05e00, flags=...) at kernel/qeventloop.cpp:149
#3  0x00007f39ba78bae8 in QEventLoop::exec (this=0x7f3991b05e00, flags=...) at kernel/qeventloop.cpp:204
#4  0x00007f39ba68dfc0 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#5  0x00007f39ba690f9c in QThreadPrivate::start (arg=0x2893aa0) at thread/qthread_unix.cpp:338
#6  0x00007f39ba3fae0e in start_thread (arg=0x7f3991b06700) at pthread_create.c:305
#7  0x00007f39b91742bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f3991305700 (LWP 8335)):
#0  0x00007f39b916c13f in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f39b5eb4684 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f39b5eb47a4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f39ba7bacf6 in QEventDispatcherGlib::processEvents (this=0x7f39840008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f39ba78b85f in QEventLoop::processEvents (this=this@entry=0x7f3991304dd0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f39ba78bae8 in QEventLoop::exec (this=0x7f3991304dd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f39ba68dfc0 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f39ba76bfcf in QInotifyFileSystemWatcherEngine::run (this=0x2901020) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f39ba690f9c in QThreadPrivate::start (arg=0x2901020) at thread/qthread_unix.cpp:338
#9  0x00007f39ba3fae0e in start_thread (arg=0x7f3991305700) at pthread_create.c:305
#10 0x00007f39b91742bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f39bbac6780 (LWP 8323)):
[KCrash Handler]
#6  0x00000000000056f6 in ?? ()
#7  0x00007f3983bca52c in qt_plugin_instance () at /usr/src/debug/networkmanagement-0.9.60git.1350337370/kded/service.cpp:53
#8  0x00007f39bacee398 in kde4Factory (lib=0x2a68130) at /usr/src/debug/kdelibs-4.9.40_20121020/kdecore/util/klibrary.cpp:149
#9  KLibrary::factory (this=0x2a68130, factoryname=0x28976e8 "kded_networkmanagement") at /usr/src/debug/kdelibs-4.9.40_20121020/kdecore/util/klibrary.cpp:169
#10 0x00007f39bacf3a16 in KPluginLoader::factory (this=0x7fffbbc3f280) at /usr/src/debug/kdelibs-4.9.40_20121020/kdecore/util/kpluginloader.cpp:197
#11 0x00007f39a944d2b1 in Kded::loadModule (this=this@entry=0x125f1c0, s=..., onDemand=onDemand@entry=false) at /usr/src/debug/kdelibs-4.9.40_20121020/kded/kded.cpp:387
#12 0x00007f39a944e327 in Kded::initModules (this=this@entry=0x125f1c0) at /usr/src/debug/kdelibs-4.9.40_20121020/kded/kded.cpp:268
#13 0x00007f39a9450a11 in newInstance (this=<optimized out>) at /usr/src/debug/kdelibs-4.9.40_20121020/kded/kded.cpp:846
#14 KDEDApplication::newInstance (this=<optimized out>) at /usr/src/debug/kdelibs-4.9.40_20121020/kded/kded.cpp:803
#15 0x00007f39bb52bad2 in KUniqueApplicationAdaptor::newInstance (this=0x142c500, asn_id=..., args=...) at /usr/src/debug/kdelibs-4.9.40_20121020/kdeui/kernel/kuniqueapplication.cpp:442
#16 0x00007f39bb52bb54 in qt_static_metacall (_a=0x7fffbbc3f7d0, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at /usr/src/debug/kdelibs-4.9.40_20121020/build/kdeui/kuniqueapplication_p.moc:58
#17 KUniqueApplicationAdaptor::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=0x7fffbbc3f7d0) at /usr/src/debug/kdelibs-4.9.40_20121020/build/kdeui/kuniqueapplication_p.moc:52
#18 0x00007f39bb52bc8b in KUniqueApplicationAdaptor::qt_metacall (this=0x142c500, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffbbc3f7d0) at /usr/src/debug/kdelibs-4.9.40_20121020/build/kdeui/kuniqueapplication_p.moc:102
#19 0x00007f39b7513c1a in QDBusConnectionPrivate::deliverCall (this=this@entry=0x1253c70, object=object@entry=0x142c500, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:947
#20 0x00007f39b7514c46 in QDBusConnectionPrivate::activateCall (this=this@entry=0x1253c70, object=0x142c500, flags=flags@entry=337, msg=...) at qdbusintegrator.cpp:850
#21 0x00007f39b7515686 in QDBusConnectionPrivate::activateObject (this=0x1253c70, node=..., msg=..., pathStartPos=<optimized out>) at qdbusintegrator.cpp:1423
#22 0x00007f39b751577b in QDBusActivateObjectEvent::placeMetaCall (this=0x1375560) at qdbusintegrator.cpp:1537
#23 0x00007f39ba7a14ee in QObject::event (this=0x7fffbbc40680, e=<optimized out>) at kernel/qobject.cpp:1204
#24 0x00007f39b991d854 in QApplication::event (this=0x7fffbbc40680, e=0x1375560) at kernel/qapplication.cpp:2539
#25 0x00007f39b991b74c in QApplicationPrivate::notify_helper (this=this@entry=0x12642b0, receiver=receiver@entry=0x7fffbbc40680, e=e@entry=0x1375560) at kernel/qapplication.cpp:4557
#26 0x00007f39b991fbca in QApplication::notify (this=0x7fffbbc40680, receiver=0x7fffbbc40680, e=0x1375560) at kernel/qapplication.cpp:4418
#27 0x00007f39bb525816 in KApplication::notify (this=0x7fffbbc40680, receiver=0x7fffbbc40680, event=0x1375560) at /usr/src/debug/kdelibs-4.9.40_20121020/kdeui/kernel/kapplication.cpp:311
#28 0x00007f39ba78cb0e in QCoreApplication::notifyInternal (this=0x7fffbbc40680, receiver=receiver@entry=0x7fffbbc40680, event=event@entry=0x1375560) at kernel/qcoreapplication.cpp:915
#29 0x00007f39ba790471 in sendEvent (event=0x1375560, receiver=0x7fffbbc40680) at kernel/qcoreapplication.h:231
#30 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x11e22b0) at kernel/qcoreapplication.cpp:1539
#31 0x00007f39ba7bab43 in sendPostedEvents () at kernel/qcoreapplication.h:236
#32 postEventSourceDispatch (s=0x12658e0) at kernel/qeventdispatcher_glib.cpp:279
#33 0x00007f39b5eb43b5 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#34 0x00007f39b5eb46e8 in ?? () from /usr/lib64/libglib-2.0.so.0
#35 0x00007f39b5eb47a4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#36 0x00007f39ba7bacd6 in QEventDispatcherGlib::processEvents (this=0x11e8790, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#37 0x00007f39b99bba5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#38 0x00007f39ba78b85f in QEventLoop::processEvents (this=this@entry=0x7fffbbc40400, flags=...) at kernel/qeventloop.cpp:149
#39 0x00007f39ba78bae8 in QEventLoop::exec (this=0x7fffbbc40400, flags=...) at kernel/qeventloop.cpp:204
#40 0x00007f39ba790788 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#41 0x00007f39a944ca30 in kdemain (argc=1, argv=0x1249600) at /usr/src/debug/kdelibs-4.9.40_20121020/kded/kded.cpp:924
#42 0x0000000000408856 in launch (argc=argc@entry=1, _name=_name@entry=0x40b243 "kded4", args=args@entry=0x0, cwd=cwd@entry=0x0, envc=envc@entry=0, envs=<optimized out>, envs@entry=0x0, reset_env=reset_env@entry=false, tty=tty@entry=0x0, avoid_loops=avoid_loops@entry=false, startup_id_str=startup_id_str@entry=0x40b0c6 "0") at /usr/src/debug/kdelibs-4.9.40_20121020/kinit/kinit.cpp:726
#43 0x0000000000405f99 in main (argc=4, argv=<optimized out>, envp=0x7fffbbc41070) at /usr/src/debug/kdelibs-4.9.40_20121020/kinit/kinit.cpp:1841

This bug may be a duplicate of or related to bug 282854.

Possible duplicates by query: bug 282854, bug 282489.

Reported using DrKonqi
Comment 1 Christoph Feck 2012-11-09 11:42:00 UTC
Do you mix packages from different repositories? Please try running "kbuildsycoca4 --noincremental" and check, if this makes a difference.
Comment 2 Günter Opitz-Ohlsen 2012-11-09 12:03:03 UTC
Am 09.11.2012 12:42, schrieb Christoph Feck:
> https://bugs.kde.org/show_bug.cgi?id=309801
>
> Christoph Feck <christoph@maxiom.de> changed:
>
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                  CC|                            |christoph@maxiom.de
>
> --- Comment #1 from Christoph Feck <christoph@maxiom.de> ---
> Do you mix packages from different repositories? Please try running
> "kbuildsycoca4 --noincremental" and check, if this makes a difference.
>
Dear Christoph,
yes I think that I mix packages from different repositories. I followed
your recommendation but I had no success. The error messages ist still
appearing twice. Are you interessted in the output of

kbuildsycoca4 --noincremental?

Regards Günter
Comment 3 Christoph Feck 2012-11-10 13:26:16 UTC
Please install KDE (including the Plasma Network Manager) and Qt from a single repository. If unsure, ask in the forum of your distribution, which repositories can be safely mixed.
Comment 4 Günter Opitz-Ohlsen 2012-11-10 16:19:25 UTC
Am 10.11.2012 14:26, schrieb Christoph Feck:
> https://bugs.kde.org/show_bug.cgi?id=309801
>
> --- Comment #3 from Christoph Feck <christoph@maxiom.de> ---
> Please install KDE (including the Plasma Network Manager) and Qt from a single
> repository. If unsure, ask in the forum of your distribution, which
> repositories can be safely mixed.
>
Hi Christoph,

I just did what you recommended and it works. Thanks a lot for your help.

Regards

Günter

www.friededenhuetten.de