Bug 309677

Summary: Gwenview crashes when global menubar is enabled, or when the "Plugins" menu is opened
Product: [Applications] gwenview Reporter: Raul Caba <cabster724>
Component: generalAssignee: Gwenview Bugs <gwenview-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: 2.9.2   
Target Milestone: ---   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description Raul Caba 2012-11-07 06:19:32 UTC
Application: gwenview (2.9.2)
KDE Platform Version: 4.9.3 "release 520"
Qt Version: 4.8.3
Operating System: Linux 3.4.11-2.16-desktop x86_64
Distribution: "openSUSE 12.2 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
Opening gwenview

- Custom settings of the application:
plasmoid window menubar is in use

If I load it up without the plasmoid, it crashes instantly when I open the "Plugins" menu.

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fe978ca1780 (LWP 2750))]

Thread 2 (Thread 0x7fe96556d700 (LWP 2752)):
#0  0x00007fe9756ba13f in poll () from /lib64/libc.so.6
#1  0x00007fe971c71684 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fe971c717a4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fe977b03cc6 in QEventDispatcherGlib::processEvents (this=0x7fe9600008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fe977ad481f in QEventLoop::processEvents (this=this@entry=0x7fe96556cdd0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fe977ad4aa8 in QEventLoop::exec (this=0x7fe96556cdd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fe9779d6fe0 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fe977ab4fcf in QInotifyFileSystemWatcherEngine::run (this=0x248b7f0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fe9779d9fbc in QThreadPrivate::start (arg=0x248b7f0) at thread/qthread_unix.cpp:338
#9  0x00007fe973e47e0e in start_thread () from /lib64/libpthread.so.0
#10 0x00007fe9756c22bd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fe978ca1780 (LWP 2750)):
[KCrash Handler]
#6  QString::operator= (this=0x72006500730097, other=...) at tools/qstring.cpp:1411
#7  0x00007fe95f57f0c9 in KIPI::Plugin::setUiBaseName (this=0x2b25a30, name=<optimized out>) at /usr/src/debug/digikam-software-compilation/extra/libkipi/libkipi/plugin.cpp:309
#8  0x00007fe9641015ff in KIPIIpodExportPlugin::Plugin_iPodExport::Plugin_iPodExport (this=0x2b25a30, parent=0x2554cc0) at /usr/src/debug/digikam-software-compilation/extra/kipi-plugins/ipodexport/plugin_ipodexport.cpp:66
#9  0x00007fe964101af7 in KPluginFactory::createInstance<KIPIIpodExportPlugin::Plugin_iPodExport, QObject> (parentWidget=<optimized out>, parent=<optimized out>, args=...) at /usr/include/kpluginfactory.h:477
#10 0x00007fe976b4cc75 in KPluginFactory::create (this=0x26c27b0, iface=0x7fe977753260 <qt_meta_stringdata_KIPI__Plugin> "KIPI::Plugin", parentWidget=0x0, parent=0x2554cc0, args=..., keyword=...) at /usr/src/debug/kdelibs-4.9.3/kdecore/util/kpluginfactory.cpp:203
#11 0x00007fe977747636 in create<KIPI::Plugin> (args=..., keyword=..., parent=0x2554cc0, parentWidget=0x0, this=0x26c27b0) at /usr/include/kpluginfactory.h:531
#12 createInstance<KIPI::Plugin> (error=0x7fffdb931620, args=..., parent=0x2554cc0, parentWidget=0x0, this=0x2a8d570) at /usr/include/kservice.h:565
#13 createInstance<KIPI::Plugin> (error=0x7fffdb931620, args=..., parent=0x2554cc0, this=0x2a8d570) at /usr/include/kservice.h:542
#14 KIPI::PluginLoader::Info::plugin (this=0x2add480) at /usr/src/debug/libkipi-4.9.3/libkipi/pluginloader.cpp:133
#15 0x0000000000462db8 in _start ()

Possible duplicates by query: bug 307775, bug 307187, bug 306698.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-11-07 06:53:17 UTC

*** This bug has been marked as a duplicate of bug 307775 ***