Bug 309569

Summary: unlocking screen crashes kwin
Product: [Plasma] kwin Reporter: cki <christofk>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: NOR    
Version: 4.9.2   
Target Milestone: ---   
Platform: openSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description cki 2012-11-05 08:48:50 UTC
tried to unlock screen when it was locked for more than one day (friday evening till monday morning). When locking for one day, unlocking is normaly possible. (vmware 8.0.4 with one vm is active)

Reproducible: Always

Steps to Reproduce:
1.lock screen
2.wait three days
3.try to unlock
Actual Results:  
login screen doesn't appear

Expected Results:  
login screen should appear

Application: kwin (4.9.2 "release 511")
KDE Platform Version: 4.9.2 "release 511"
Qt Version: 4.8.3
Operating System: Linux 3.6.4-1-desktop x86_64
Distribution: "openSUSE 12.2 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed: tried to unlock screen when it was locked for more than one day (friday evening till monday morning). When locking for one day, unlocking is normaly possible. (vmware 8.0.4 with one vm is active)

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f6ad7633780 (LWP 2549))]

Thread 3 (Thread 0x7f6aaef7e700 (LWP 2569)):
#0  0x00007f6ad27078f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6aaf12d4e3 in ?? () from /usr/lib64/dri/r600_dri.so
#2  0x00007f6ad2703e0e in start_thread () from /lib64/libpthread.so.0
#3  0x00007f6ad6e5a2bd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f6aae499700 (LWP 2571)):
#0  0x00007f6ad27078f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6ad3d4f247 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f6ad405c640 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f6ad3d4f279 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f6ad2703e0e in start_thread () from /lib64/libpthread.so.0
#4  0x00007f6ad6e5a2bd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f6ad7633780 (LWP 2549)):
[KCrash Handler]
#6  0x00007f6aaf112a3d in ?? () from /usr/lib64/dri/r600_dri.so
#7  0x00007f6aaf113889 in ?? () from /usr/lib64/dri/r600_dri.so
#8  0x00007f6aaf2a575e in ?? () from /usr/lib64/dri/r600_dri.so
#9  0x00007f6aaf2a4f3f in ?? () from /usr/lib64/dri/r600_dri.so
#10 0x00007f6aaf1ea8bf in ?? () from /usr/lib64/dri/r600_dri.so
#11 0x00007f6aaf1e3b63 in ?? () from /usr/lib64/dri/r600_dri.so
#12 0x00007f6ad37a42de in KWin::GLVertexBufferPrivate::corePainting (this=0xdc97a0, region=..., primitiveMode=4, hardwareClipping=false) at /usr/src/debug/kde-workspace-4.9.2/kwin/libkwineffects/kwinglutils.cpp:1218
#13 0x00007f6ad37a47fd in KWin::GLVertexBuffer::render (this=0xdc3d50, region=..., primitiveMode=4, hardwareClipping=false) at /usr/src/debug/kde-workspace-4.9.2/kwin/libkwineffects/kwinglutils.cpp:1341
#14 0x00007f6ad71da3df in renderQuads (hardwareClipping=false, normalized=<optimized out>, tex=<optimized out>, quads=..., region=..., this=<optimized out>) at /usr/src/debug/kde-workspace-4.9.2/kwin/scene_opengl.cpp:795
#15 KWin::SceneOpenGL::Window::renderQuads (this=<optimized out>, region=..., quads=..., tex=<optimized out>, normalized=<optimized out>, hardwareClipping=false) at /usr/src/debug/kde-workspace-4.9.2/kwin/scene_opengl.cpp:774
#16 0x00007f6ad71e083b in KWin::SceneOpenGL::Window::performPaint (this=0x4e33f30, mask=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.9.2/kwin/scene_opengl.cpp:593
#17 0x00007f6ad71cc4e6 in KWin::Scene::finalDrawWindow (this=<optimized out>, w=0x519d890, mask=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.9.2/kwin/scene.cpp:454
#18 0x00007f6ad71eaeea in KWin::EffectsHandlerImpl::drawWindow (this=0xfe5460, w=w@entry=0x519d890, mask=mask@entry=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.9.2/kwin/effects.cpp:310
#19 0x00007f6aae502b2d in KWin::BlurEffect::drawWindow (this=<optimized out>, w=0x519d890, mask=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.9.2/kwin/effects/blur/blur.cpp:405
#20 0x00007f6ad71eae8b in KWin::EffectsHandlerImpl::drawWindow (this=0xfe5460, w=w@entry=0x519d890, mask=mask@entry=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.9.2/kwin/effects.cpp:307
#21 0x00007f6ad71cb95a in KWin::Scene::finalPaintWindow (this=<optimized out>, w=0x519d890, mask=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.9.2/kwin/scene.cpp:439
#22 0x00007f6ad71eaa9a in KWin::EffectsHandlerImpl::paintWindow (this=0xfe5460, w=w@entry=0x519d890, mask=mask@entry=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.9.2/kwin/effects.cpp:273
#23 0x00007f6ad5611c4a in KWin::Effect::paintWindow (this=<optimized out>, w=0x519d890, mask=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.9.2/kwin/libkwineffects/kwineffects.cpp:157
#24 0x00007f6ad71eaa3b in KWin::EffectsHandlerImpl::paintWindow (this=0xfe5460, w=0x519d890, mask=mask@entry=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.9.2/kwin/effects.cpp:270
#25 0x00007f6ad71ce72d in KWin::Scene::paintWindow (this=<optimized out>, w=0x4e33f30, mask=9, region=..., quads=...) at /usr/src/debug/kde-workspace-4.9.2/kwin/scene.cpp:348
#26 0x00007f6ad71cda8f in KWin::Scene::paintSimpleScreen (this=this@entry=0x9c06a0, orig_mask=orig_mask@entry=8, region=...) at /usr/src/debug/kde-workspace-4.9.2/kwin/scene.cpp:334
#27 0x00007f6ad71cb8a2 in KWin::Scene::finalPaintScreen (this=0x9c06a0, mask=8, region=..., data=...) at /usr/src/debug/kde-workspace-4.9.2/kwin/scene.cpp:192
#28 0x00007f6ad71eac63 in KWin::EffectsHandlerImpl::paintScreen (this=0xfe5460, mask=mask@entry=8, region=..., data=...) at /usr/src/debug/kde-workspace-4.9.2/kwin/effects.cpp:246
#29 0x00007f6ad5611cb7 in KWin::Effect::paintScreen (this=this@entry=0xfcd990, mask=mask@entry=8, region=..., data=...) at /usr/src/debug/kde-workspace-4.9.2/kwin/libkwineffects/kwineffects.cpp:142
#30 0x00007f6ad71eac0b in KWin::EffectsHandlerImpl::paintScreen (this=0xfe5460, mask=8, region=..., data=...) at /usr/src/debug/kde-workspace-4.9.2/kwin/effects.cpp:243
#31 0x00007f6ad71cceeb in KWin::Scene::paintScreen (this=0x9c06a0, mask=0x7fffef050a2c, region=0x7fffef050ad0) at /usr/src/debug/kde-workspace-4.9.2/kwin/scene.cpp:146
#32 0x00007f6ad71e1a42 in KWin::SceneOpenGL::paint (this=0x9c06a0, damage=..., toplevels=...) at /usr/src/debug/kde-workspace-4.9.2/kwin/scene_opengl_glx.cpp:481
#33 0x00007f6ad71c6bf8 in KWin::Workspace::performCompositing (this=0xb91a80) at /usr/src/debug/kde-workspace-4.9.2/kwin/composite.cpp:440
#34 0x00007f6ad2aaa31c in QObject::event (this=0xb91a80, e=<optimized out>) at kernel/qobject.cpp:1166
#35 0x00007f6ad1c2374c in QApplicationPrivate::notify_helper (this=this@entry=0x9f9900, receiver=receiver@entry=0xb91a80, e=e@entry=0x7fffef051260) at kernel/qapplication.cpp:4557
#36 0x00007f6ad1c27bca in QApplication::notify (this=0x7fffef0518a0, receiver=0xb91a80, e=0x7fffef051260) at kernel/qapplication.cpp:4418
#37 0x00007f6ad6957616 in KApplication::notify (this=0x7fffef0518a0, receiver=0xb91a80, event=0x7fffef051260) at /usr/src/debug/kdelibs-4.9.2/kdeui/kernel/kapplication.cpp:311
#38 0x00007f6ad2a95b0e in QCoreApplication::notifyInternal (this=0x7fffef0518a0, receiver=0xb91a80, event=0x7fffef051260) at kernel/qcoreapplication.cpp:915
#39 0x00007f6ad2ac6561 in sendEvent (event=0x7fffef051260, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#40 QTimerInfoList::activateTimers (this=0x9fa2f8) at kernel/qeventdispatcher_unix.cpp:626
#41 0x00007f6ad2ac6ba0 in QEventDispatcherUNIX::activateTimers (this=this@entry=0x9b1a70) at kernel/qeventdispatcher_unix.cpp:883
#42 0x00007f6ad2ac6cf8 in QEventDispatcherUNIX::processEvents (this=0x9b1a70, flags=...) at kernel/qeventdispatcher_unix.cpp:945
#43 0x00007f6ad1cc487f in QEventDispatcherX11::processEvents (this=0x9b1a70, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#44 0x00007f6ad2a9485f in QEventLoop::processEvents (this=this@entry=0x7fffef0515b0, flags=...) at kernel/qeventloop.cpp:149
#45 0x00007f6ad2a94ae8 in QEventLoop::exec (this=0x7fffef0515b0, flags=...) at kernel/qeventloop.cpp:204
#46 0x00007f6ad2a99788 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#47 0x00007f6ad7180804 in kdemain (argc=3, argv=0x7fffef0519e8) at /usr/src/debug/kde-workspace-4.9.2/kwin/main.cpp:545
#48 0x00007f6ad6d97455 in __libc_start_main () from /lib64/libc.so.6
#49 0x0000000000400721 in _start () at ../sysdeps/x86_64/elf/start.S:113

Possible duplicates by query: bug 307027, bug 306927, bug 306867, bug 304464, bug 304241.

An https://bugs.kde.org/ berichten
Comment 1 cki 2012-11-05 08:49:42 UTC
doesn'
Comment 2 Thomas L├╝bking 2012-11-05 14:48:56 UTC
Driver bug, workaround:
run "kcmshell4 kwincompositing", in the last tab disable "suspend desktop effects on full windows"

*** This bug has been marked as a duplicate of bug 299333 ***