Bug 306867

Summary: Kwin crashes after desktop switch
Product: [Plasma] kwin Reporter: Zefir <kdebugs>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash Flags: thomas.luebking: Intel+
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Debian testing   
OS: Linux   
Latest Commit: Version Fixed In:

Description Zefir 2012-09-15 22:29:04 UTC
Application: kwin (4.8.4 (4.8.4))
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.2
Operating System: Linux 3.2.0-3-amd64 x86_64
Distribution: Debian GNU/Linux testing (wheezy)

-- Information about the crash:
- What I was doing when the application crashed:

Kwin sometimes crashes when switching to a desktop after it was selected using "Desktop Cube" desktop switching animation/type

- Custom settings of the application:
Desktop Cube & Desktop Cube Animation effects turned on (Desktop Settings)

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f7265dde780 (LWP 3203))]

Thread 2 (Thread 0x7f7242f16700 (LWP 3215)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f72620d41d7 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f72620d4209 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f725a27ab50 in start_thread (arg=<optimized out>) at pthread_create.c:304
#4  0x00007f726561970d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f7265dde780 (LWP 3203)):
[KCrash Handler]
#6  0x00007f7249817cec in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#7  0x00007f7249817880 in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#8  0x00007f7249801b60 in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#9  0x00007f72497ef537 in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#10 0x00007f724990e2f3 in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#11 0x00007f7261afc717 in KWin::GLVertexBufferPrivate::corePainting (this=0x7f724420c8d0, region=..., primitiveMode=4) at ../../../kwin/libkwineffects/kwinglutils.cpp:1188
#12 0x00007f7261afc815 in KWin::GLVertexBuffer::render (this=0x7f72441dc5c0, region=..., primitiveMode=4) at ../../../kwin/libkwineffects/kwinglutils.cpp:1297
#13 0x00007f72659821f0 in renderQuads (normalized=<optimized out>, tex=<optimized out>, quads=..., region=..., this=<optimized out>) at ../../kwin/scene_opengl.cpp:788
#14 KWin::SceneOpenGL::Window::renderQuads (this=<optimized out>, region=..., quads=..., tex=<optimized out>, normalized=<optimized out>) at ../../kwin/scene_opengl.cpp:768
#15 0x00007f7265988b28 in KWin::SceneOpenGL::Window::performPaint (this=0x7f724447c3b0, mask=9, region=..., data=...) at ../../kwin/scene_opengl.cpp:592
#16 0x00007f7265973c8e in KWin::Scene::finalDrawWindow (this=<optimized out>, w=<optimized out>, mask=9, region=..., data=...) at ../../kwin/scene.cpp:438
#17 0x00007f7265993385 in KWin::EffectsHandlerImpl::drawWindow (this=0x15af6b0, w=w@entry=0x7f724447ca40, mask=mask@entry=9, region=..., data=...) at ../../kwin/effects.cpp:286
#18 0x00007f72481371ad in KWin::BlurEffect::drawWindow (this=<optimized out>, w=0x7f724447ca40, mask=9, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:389
#19 0x00007f726599331b in KWin::EffectsHandlerImpl::drawWindow (this=0x15af6b0, w=w@entry=0x7f724447ca40, mask=mask@entry=9, region=..., data=...) at ../../kwin/effects.cpp:283
#20 0x00007f7265972d06 in KWin::Scene::finalPaintWindow (this=<optimized out>, w=0x7f724447ca30, mask=9, region=..., data=...) at ../../kwin/scene.cpp:429
#21 0x00007f7265993685 in KWin::EffectsHandlerImpl::paintWindow (this=0x15af6b0, w=w@entry=0x7f724447ca40, mask=mask@entry=9, region=..., data=...) at ../../kwin/effects.cpp:249
#22 0x00007f726378aaea in KWin::Effect::paintWindow (this=<optimized out>, w=0x7f724447ca40, mask=9, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:156
#23 0x00007f726599361b in KWin::EffectsHandlerImpl::paintWindow (this=0x15af6b0, w=0x7f724447ca40, mask=mask@entry=9, region=..., data=...) at ../../kwin/effects.cpp:246
#24 0x00007f72659736eb in KWin::Scene::paintWindow (this=this@entry=0x7f72441decd0, w=0x7f724447c3b0, mask=9, region=..., quads=...) at ../../kwin/scene.cpp:385
#25 0x00007f7265974589 in KWin::Scene::paintSimpleScreen (this=this@entry=0x7f72441decd0, orig_mask=orig_mask@entry=8, region=...) at ../../kwin/scene.cpp:330
#26 0x00007f7265972c34 in KWin::Scene::finalPaintScreen (this=0x7f72441decd0, mask=8, region=..., data=...) at ../../kwin/scene.cpp:198
#27 0x00007f7265993203 in KWin::EffectsHandlerImpl::paintScreen (this=0x15af6b0, mask=mask@entry=8, region=..., data=...) at ../../kwin/effects.cpp:222
#28 0x00007f726378ab57 in KWin::Effect::paintScreen (this=this@entry=0x162cd90, mask=mask@entry=8, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:141
#29 0x00007f72659931ab in KWin::EffectsHandlerImpl::paintScreen (this=0x15af6b0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:219
#30 0x00007f7265975828 in KWin::Scene::paintScreen (this=0x7f72441decd0, mask=0x7fff0058d37c, region=0x7fff0058d440) at ../../kwin/scene.cpp:156
#31 0x00007f726598964d in KWin::SceneOpenGL::paint (this=0x7f72441decd0, damage=..., toplevels=...) at ../../kwin/scene_opengl_glx.cpp:459
#32 0x00007f726596fa0e in KWin::Workspace::performCompositing (this=0x7f72441dd0d0) at ../../kwin/composite.cpp:412
#33 0x00007f7260df385c in QObject::event (this=0x7f72441dd0d0, e=<optimized out>) at kernel/qobject.cpp:1157
#34 0x00007f726018870c in QApplicationPrivate::notify_helper (this=this@entry=0x137ec20, receiver=receiver@entry=0x7f72441dd0d0, e=e@entry=0x7fff0058db20) at kernel/qapplication.cpp:4556
#35 0x00007f726018cb8a in QApplication::notify (this=0x7fff0058e160, receiver=0x7f72441dd0d0, e=0x7fff0058db20) at kernel/qapplication.cpp:4417
#36 0x00007f726511d8a6 in KApplication::notify (this=0x7fff0058e160, receiver=0x7f72441dd0d0, event=0x7fff0058db20) at ../../kdeui/kernel/kapplication.cpp:311
#37 0x00007f7260ddeb5e in QCoreApplication::notifyInternal (this=0x7fff0058e160, receiver=0x7f72441dd0d0, event=0x7fff0058db20) at kernel/qcoreapplication.cpp:915
#38 0x00007f7260e0fa52 in sendEvent (event=0x7fff0058db20, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#39 QTimerInfoList::activateTimers (this=0x137f618) at kernel/qeventdispatcher_unix.cpp:611
#40 0x00007f7260e0fab0 in QEventDispatcherUNIX::activateTimers (this=this@entry=0x1319ad0) at kernel/qeventdispatcher_unix.cpp:868
#41 0x00007f7260e0fc08 in QEventDispatcherUNIX::processEvents (this=0x1319ad0, flags=...) at kernel/qeventdispatcher_unix.cpp:930
#42 0x00007f726022a5df in QEventDispatcherX11::processEvents (this=0x1319ad0, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#43 0x00007f7260ddd8af in QEventLoop::processEvents (this=this@entry=0x7fff0058de70, flags=...) at kernel/qeventloop.cpp:149
#44 0x00007f7260dddb38 in QEventLoop::exec (this=0x7fff0058de70, flags=...) at kernel/qeventloop.cpp:204
#45 0x00007f7260de2cf8 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#46 0x00007f726592a23e in kdemain (argc=3, argv=0x7fff0058e2e8) at ../../kwin/main.cpp:541
#47 0x00007f726555fead in __libc_start_main (main=<optimized out>, argc=<optimized out>, ubp_av=<optimized out>, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff0058e2d8) at libc-start.c:228
#48 0x0000000000400771 in _start ()

Possible duplicates by query: bug 304464, bug 304241, bug 303041, bug 302588, bug 301529.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2012-09-15 22:45:52 UTC
driver bug

*** This bug has been marked as a duplicate of bug 299333 ***