Bug 306051

Summary: Kontact crashed when closing Address Book properties window [@ KRecursiveFilterProxyModelPrivate::sourceDataChanged]
Product: kdelibs Reporter: Lester Petrie <petrielmjr>
Component: kdeuiAssignee: kdelibs bugs <kdelibs-bugs>
Status: RESOLVED WORKSFORME    
Severity: crash CC: jlehrkamp, kdenis, thomascwells
Priority: NOR    
Version: 4.8.5   
Target Milestone: ---   
Platform: Fedora RPMs   
OS: Linux   
Latest Commit: Version Fixed In:

Description Lester Petrie 2012-08-30 21:18:47 UTC
Application: kontact (4.8.5)
KDE Platform Version: 4.8.5 (4.8.5)
Qt Version: 4.8.2
Operating System: Linux 3.5.2-3.fc17.x86_64 x86_64
Distribution: "Fedora release 17 (Beefy Miracle)"

-- Information about the crash:
- What I was doing when the application crashed:
I had a duplicate entry of my address book under contacts, and I was comparing the properties to verify that they really were the same.  I clicked to close the properties window, and kontact crashed.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f8fe2037880 (LWP 13549))]

Thread 3 (Thread 0x7f8fd6fab700 (LWP 13633)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:166
#1  0x0000003248a1677d in WTF::TCMalloc_PageHeap::scavengerThread (this=0x3249400980) at wtf/FastMalloc.cpp:2495
#2  0x0000003248a16889 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at wtf/FastMalloc.cpp:1618
#3  0x00000032b9c07d14 in start_thread (arg=0x7f8fd6fab700) at pthread_create.c:309
#4  0x00000032b90f167d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f8fd6692700 (LWP 13635)):
#0  0x00000032b9c0e0ad in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x00000032bbc82a5f in read (__nbytes=16, __buf=0x7f8fd6691b60, __fd=<optimized out>) at /usr/include/bits/unistd.h:45
#2  g_wakeup_acknowledge (wakeup=0xfed7c0) at gwakeup.c:212
#3  0x00000032bbc474e9 in g_main_context_check (context=context@entry=0x7f8fd00009a0, max_priority=2147483647, fds=fds@entry=0x7f8fd00029c0, n_fds=n_fds@entry=1) at gmain.c:2980
#4  0x00000032bbc47902 in g_main_context_iterate (context=context@entry=0x7f8fd00009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3143
#5  0x00000032bbc47a84 in g_main_context_iteration (context=0x7f8fd00009a0, may_block=1) at gmain.c:3207
#6  0x00000032397a4506 in QEventDispatcherGlib::processEvents (this=0x7f8fd00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0x000000323977513f in QEventLoop::processEvents (this=this@entry=0x7f8fd6691d20, flags=...) at kernel/qeventloop.cpp:149
#8  0x00000032397753c8 in QEventLoop::exec (this=0x7f8fd6691d20, flags=...) at kernel/qeventloop.cpp:204
#9  0x0000003239678650 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#10 0x000000323967b5eb in QThreadPrivate::start (arg=0xffb880) at thread/qthread_unix.cpp:307
#11 0x00000032b9c07d14 in start_thread (arg=0x7f8fd6692700) at pthread_create.c:309
#12 0x00000032b90f167d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f8fe2037880 (LWP 13549)):
[KCrash Handler]
#6  QSortFilterProxyModelPrivate::updateChildrenMapping (this=this@entry=0x1d83660, source_parent=..., parent_mapping=parent_mapping@entry=0x2101a90, orient=orient@entry=Qt::Vertical, start=start@entry=0, end=end@entry=0, delta_item_count=delta_item_count@entry=1, remove=remove@entry=true) at itemviews/qsortfilterproxymodel.cpp:948
#7  0x000000323c1530c0 in source_items_removed (orient=Qt::Vertical, end=0, start=0, source_parent=..., this=<optimized out>) at itemviews/qsortfilterproxymodel.cpp:890
#8  QSortFilterProxyModelPrivate::source_items_removed (this=0x1d83660, source_parent=..., start=0, end=<optimized out>, orient=Qt::Vertical) at itemviews/qsortfilterproxymodel.cpp:848
#9  0x000000323978cb9f in QMetaObject::activate (sender=0x1d817b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff8289a970) at kernel/qobject.cpp:3547
#10 0x00000032397d5484 in QAbstractItemModel::rowsRemoved (this=<optimized out>, _t1=..., _t2=0, _t3=0) at .moc/release-shared/moc_qabstractitemmodel.cpp:210
#11 0x000000323976fdcd in QAbstractItemModel::endRemoveRows (this=0x1d817b0) at kernel/qabstractitemmodel.cpp:2487
#12 0x000000323c15608a in QSortFilterProxyModelPrivate::remove_source_items (this=this@entry=0x1d81ff0, source_to_proxy=..., proxy_to_source=..., source_items=..., source_parent=..., orient=orient@entry=Qt::Vertical, emit_signal=emit_signal@entry=true) at itemviews/qsortfilterproxymodel.cpp:539
#13 0x000000323c156921 in QSortFilterProxyModelPrivate::_q_sourceDataChanged (this=0x1d81ff0, source_top_left=..., source_bottom_right=...) at itemviews/qsortfilterproxymodel.cpp:1144
#14 0x000000323977e237 in QMetaMethod::invoke (this=this@entry=0x7fff8289ae50, object=object@entry=0x1d817b0, connectionType=connectionType@entry=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1664
#15 0x000000323978060c in QMetaObject::invokeMethod (obj=0x1d817b0, member=<optimized out>, type=Qt::DirectConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1179
#16 0x000000323ce0aaa3 in invokeMethod (val9=..., val8=..., val7=..., val6=..., val5=..., val4=..., val3=..., val2=..., val1=..., val0=..., type=Qt::DirectConnection, member=0x323cfa228b "_q_sourceDataChanged", obj=0x1d817b0) at /usr/include/QtCore/qobjectdefs.h:418
#17 invokeDataChanged (bottomRight=..., topLeft=..., this=<optimized out>) at /usr/src/debug/kdelibs-4.8.5/kdeui/itemviews/krecursivefilterproxymodel.cpp:55
#18 KRecursiveFilterProxyModelPrivate::sourceDataChanged (this=0x1928000, source_top_left=..., source_bottom_right=...) at /usr/src/debug/kdelibs-4.8.5/kdeui/itemviews/krecursivefilterproxymodel.cpp:131
#19 0x000000323978cb9f in QMetaObject::activate (sender=0x1d81350, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff8289b3f0) at kernel/qobject.cpp:3547
#20 0x00000032397d52a7 in QAbstractItemModel::dataChanged (this=<optimized out>, _t1=..., _t2=...) at .moc/release-shared/moc_qabstractitemmodel.cpp:163
#21 0x0000003d37a83333 in KPIM::StatisticsProxyModel::Private::proxyDataChanged (this=0x1d80410, topLeft=..., bottomRight=...) at /usr/src/debug/kdepim-4.8.5/libkdepim/statisticsproxymodel.cpp:200
#22 0x000000323978cb9f in QMetaObject::activate (sender=0x1d81350, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff8289b640) at kernel/qobject.cpp:3547
#23 0x00000032397d52a7 in QAbstractItemModel::dataChanged (this=<optimized out>, _t1=..., _t2=...) at .moc/release-shared/moc_qabstractitemmodel.cpp:163
#24 0x000000323ce08d47 in KIdentityProxyModelPrivate::_k_sourceDataChanged (this=<optimized out>, topLeft=..., bottomRight=...) at /usr/src/debug/kdelibs-4.8.5/kdeui/itemviews/kidentityproxymodel.cpp:573
#25 0x000000323978cb9f in QMetaObject::activate (sender=0x1d85370, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff8289b7f0) at kernel/qobject.cpp:3547
#26 0x00000032397d52a7 in QAbstractItemModel::dataChanged (this=<optimized out>, _t1=..., _t2=...) at .moc/release-shared/moc_qabstractitemmodel.cpp:163
#27 0x000000323ce08d47 in KIdentityProxyModelPrivate::_k_sourceDataChanged (this=<optimized out>, topLeft=..., bottomRight=...) at /usr/src/debug/kdelibs-4.8.5/kdeui/itemviews/kidentityproxymodel.cpp:573
#28 0x000000323978cb9f in QMetaObject::activate (sender=0x19b74a0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff8289b9a0) at kernel/qobject.cpp:3547
#29 0x00000032397d52a7 in QAbstractItemModel::dataChanged (this=<optimized out>, _t1=..., _t2=...) at .moc/release-shared/moc_qabstractitemmodel.cpp:163
#30 0x000000323c1564ca in QSortFilterProxyModelPrivate::_q_sourceDataChanged (this=0x1a440c0, source_top_left=..., source_bottom_right=...) at itemviews/qsortfilterproxymodel.cpp:1193
#31 0x000000323978cb9f in QMetaObject::activate (sender=0x1866c50, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff8289bc40) at kernel/qobject.cpp:3547
#32 0x00000032397d52a7 in QAbstractItemModel::dataChanged (this=<optimized out>, _t1=..., _t2=...) at .moc/release-shared/moc_qabstractitemmodel.cpp:163
#33 0x0000003245efeea5 in Akonadi::EntityTreeModelPrivate::dataChanged (this=this@entry=0x1a42070, top=..., bottom=...) at /usr/src/debug/kdepimlibs-4.8.5/akonadi/entitytreemodel_p.cpp:1574
#34 0x0000003245f08db9 in Akonadi::EntityTreeModelPrivate::monitoredCollectionStatisticsChanged (this=0x1a42070, id=3145, statistics=...) at /usr/src/debug/kdepimlibs-4.8.5/akonadi/entitytreemodel_p.cpp:978
#35 0x000000323978cb9f in QMetaObject::activate (sender=0x1a26860, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff8289be70) at kernel/qobject.cpp:3547
#36 0x0000003245f3dcf7 in Akonadi::Monitor::collectionStatisticsChanged (this=<optimized out>, _t1=3145, _t2=...) at /usr/src/debug/kdepimlibs-4.8.5/x86_64-redhat-linux-gnu/akonadi/monitor.moc:279
#37 0x0000003245f3ed02 in Akonadi::MonitorPrivate::slotStatisticsChangedFinished (this=0x1a3b760, job=0x563c320) at /usr/src/debug/kdepimlibs-4.8.5/akonadi/monitor_p.cpp:324
#38 0x000000323978cb9f in QMetaObject::activate (sender=0x563c320, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff8289c050) at kernel/qobject.cpp:3547
#39 0x000000323ad33b62 in KJob::result (this=this@entry=0x563c320, _t1=_t1@entry=0x563c320) at /usr/src/debug/kdelibs-4.8.5/x86_64-redhat-linux-gnu/kdecore/kjob.moc:207
#40 0x000000323ad33ba0 in KJob::emitResult (this=0x563c320) at /usr/src/debug/kdelibs-4.8.5/kdecore/jobs/kjob.cpp:318
#41 0x000000323978acee in QObject::event (this=0x563c320, e=<optimized out>) at kernel/qobject.cpp:1195
#42 0x000000323bbca37c in QApplicationPrivate::notify_helper (this=this@entry=0xfe8580, receiver=receiver@entry=0x563c320, e=e@entry=0x5693710) at kernel/qapplication.cpp:4551
#43 0x000000323bbce7fa in QApplication::notify (this=0x7fff8289caf0, receiver=0x563c320, e=0x5693710) at kernel/qapplication.cpp:4412
#44 0x000000323ce462b6 in KApplication::notify (this=0x7fff8289caf0, receiver=0x563c320, event=0x5693710) at /usr/src/debug/kdelibs-4.8.5/kdeui/kernel/kapplication.cpp:311
#45 0x00000032397763ee in QCoreApplication::notifyInternal (this=0x7fff8289caf0, receiver=receiver@entry=0x563c320, event=event@entry=0x5693710) at kernel/qcoreapplication.cpp:915
#46 0x0000003239779ea1 in sendEvent (event=0x5693710, receiver=0x563c320) at kernel/qcoreapplication.h:231
#47 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xfb0600) at kernel/qcoreapplication.cpp:1539
#48 0x00000032397a4353 in sendPostedEvents () at kernel/qcoreapplication.h:236
#49 postEventSourceDispatch (s=s@entry=0xfe8f10) at kernel/qeventdispatcher_glib.cpp:279
#50 0x00000032bbc47695 in g_main_dispatch (context=0xfe9140) at gmain.c:2539
#51 g_main_context_dispatch (context=context@entry=0xfe9140) at gmain.c:3075
#52 0x00000032bbc479c8 in g_main_context_iterate (context=context@entry=0xfe9140, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3146
#53 0x00000032bbc47a84 in g_main_context_iteration (context=0xfe9140, may_block=1) at gmain.c:3207
#54 0x00000032397a44e6 in QEventDispatcherGlib::processEvents (this=0xfb1ee0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#55 0x000000323bc6a2ee in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#56 0x000000323977513f in QEventLoop::processEvents (this=this@entry=0x7fff8289c960, flags=...) at kernel/qeventloop.cpp:149
#57 0x00000032397753c8 in QEventLoop::exec (this=0x7fff8289c960, flags=...) at kernel/qeventloop.cpp:204
#58 0x000000323977a1b8 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#59 0x0000000000403459 in main (argc=1, argv=0x7fff8289cc38) at /usr/src/debug/kdepim-4.8.5/kontact/src/main.cpp:218

Possible duplicates by query: bug 304219, bug 304109.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2012-09-02 07:08:29 UTC
The problem is in kdelibs, reassigning.
Comment 2 caulier.gilles 2012-12-02 22:17:14 UTC
*** Bug 310950 has been marked as a duplicate of this bug. ***
Comment 3 Thomas 2013-01-30 18:42:05 UTC
For me, when deleting tags which are unassigned to photos, digikam will not crash if the tags to be deleted are nested under a higher level tag. It only appears to crash when the tag being deleted is a top-level tag.
Comment 4 Denis Kurz 2018-01-31 16:03:53 UTC
You might want to consider if this was caused by a Qt bug that was resolved fixed in 5.8, as described in Bug 361895, Comment 1.
Comment 5 Justin Zobel 2020-12-17 05:33:43 UTC
Thank you for the crash report.

As it has been a while since this was reported, can you please test and confirm if this issue is still occurring or if this bug report can be marked as resolved.

I have set the bug status to "needsinfo" pending your response, please change back to "reported" or "resolved/worksforme" when you respond, thank you.
Comment 6 Bug Janitor Service 2021-01-01 04:34:45 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 7 Bug Janitor Service 2021-01-16 04:34:05 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!