Bug 302865

Summary: Inaccessible reminders
Product: korgac Reporter: Josef Spillner <spillner>
Component: generalAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED UNMAINTAINED    
Severity: normal CC: winter
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Debian testing   
OS: Linux   
Latest Commit: Version Fixed In:

Description Josef Spillner 2012-07-02 07:28:09 UTC
Occasionally I'm using the calendar event reminders as a TODO list ("remind me later"). As soon as the last such reminder has been delayed again, the korgac window closes and there doesn't seem to be a way to bring it back. Left-clicking on it brings up the task list in Kontact (which is not related at all to the calendar in my case) and the RMB context menu also doesn't seem to contain a function to show the reminders.

Beside this temporary inaccessibility, there seems to be a permanent one: If there are past reminders which have been delayed, the respective reminders are not shown again after a system reboot. This makes it hard to track back manually in the calendar which TODOs were still open. To give an example, there's an entry in korgacrc:

[Incidence-5]
RemindAt=2012,3,26,14,45,39
UID=libkcal-497917663.251

Which resolves to the following entry in std.ics:

BEGIN:VEVENT
DTSTAMP:20120702T062738Z
...
CREATED:20120318T231541Z
SUMMARY: Integration ownCloud
DTSTART;TZID=America/Recife:20120319T140000
...
BEGIN:VALARM
DESCRIPTION:
ACTION:DISPLAY
TRIGGER;VALUE=DURATION:-PT15M
END:VALARM
END:VEVENT

This event has definitely not shown up in my reminders list for many weeks. And I didn't perform the ownCloud integration job due to the missing reminder :)

The system runs KDE 4.7 but with KDEPIM being at 4.4.11 (Debian packaging default).

Reproducible: Always
Comment 1 Frank Roscher 2012-12-05 19:58:43 UTC
Git commit d1d99767eed455ee6f152ca9b7461f7a9a9acaa0 by Frank Roscher.
Committed on 05/12/2012 at 20:18.
Pushed by froscher into branch 'master'.

Fix saving and loading of suspended reminders in KOrganizer

We need to wait for all collections to be available when restoring
reminders at startup, or they won't get loaded properly. Additionally,
we must delete reminders one by one as they are dismissed instead of
just cleaning out the config file after each startup.
Related: bug 280321, bug 146336, bug 180413
FIXED-IN: 4.10
REVIEW: 107546

M  +2    -3    korganizer/korgac/alarmdialog.cpp
M  +50   -29   korganizer/korgac/koalarmclient.cpp
M  +2    -0    korganizer/korgac/koalarmclient.h

http://commits.kde.org/kdepim/d1d99767eed455ee6f152ca9b7461f7a9a9acaa0
Comment 2 Allen Winter 2012-12-06 22:36:12 UTC
Frank, can we resolve this as fixed?
Comment 3 Denis Kurz 2016-09-24 21:04:48 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of korgac (version 5.0 or later, as part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 4 Denis Kurz 2017-01-07 22:35:35 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.