Bug 299972

Summary: jointhegame only partly translatable
Product: www.kde.org Reporter: Frederik Schwarzer <schwarzer>
Component: jointhegame.kde.orgAssignee: Emil Sedgh <emilsedgh>
Status: RESOLVED FIXED    
Severity: normal CC: aacid, aspotashev, emilsedgh, gladhorn, imalchow
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Frederik Schwarzer 2012-05-14 01:39:29 UTC
Despite the German translation being almost complete, the website shows many untranslated strings.

Examples:
http://jointhegame.kde.org/?language=de
"Help create beautiful software that gives you full freedom and protects your privacy. "
"Your money funds contributor meetings and infrastructure. "
"It keeps our software safe for the future and raises awareness for Free Software and Free Culture."
...
http://jointhegame.kde.org/join/information?language=de
"Birth Date"
"Password Confirmation"
...
http://jointhegame.kde.org/member/login?language=de
"Password"
"submit"

Some of the strings appear in the PO file and are translated. But some of the strings do not even show up in the PO file and thus cannot be translated.

Reproducible: Always
Comment 1 Frederik Gladhorn 2012-07-19 10:56:51 UTC
Looking at the .po file it seems the strings that were translated but not displayed are starting with an empty string "" and continue on the next line. For example:
msgctxt "join"
msgid ""
"Help create beautiful software that gives you full freedom and protects your "
"privacy."
msgstr ""
"Helfen Sie mit, wunderbare Software zu erschaffen, die Ihnen alle Freiheiten "
"gewährt und Ihre Privatsphäre schützt."

I guess that's a bug in the framework that these are not translated in the end.
Comment 2 Emil Sedgh 2012-07-19 11:13:14 UTC
Thats right. It must be a bug in the framework (Yii).
Im responsible for it but im deeply busy these days. Sorry for the delay on this bug. I hope that sooner or later I will find time to fix it.

Although a simple update to our Yii framework may fix the issue. I should look at Yii's issue tracker to find that out.
Comment 3 Frederik Gladhorn 2012-07-19 12:44:36 UTC
The problem is in framework/i18n/gettext/CGettextPoFile.php
The reg exp only matches single lines.

$pattern='/(msgctxt\s+"(.*?(?<!\\\\))")?'
          . '\s+msgid\s+"(.*?(?<!\\\\))"'
          . '\s+msgstr\s+"(.*?(?<!\\\\))"/';
Comment 4 Frederik Gladhorn 2012-07-19 12:45:29 UTC
This has not changed in recent Yii versions, so updating doesn't help as far as I can tell.
Comment 5 Frederik Gladhorn 2012-07-20 15:56:18 UTC
There is an improved version now. Could you please check if the strings are now translated? The "Join now" button is still a problem.

It would be very helpful to know if there are more untranslated strings now. At least the front page seems fine to me (testing in German).

Cheers
Frederik
Comment 6 Frederik Schwarzer 2012-07-22 06:10:41 UTC
Here (in German) some of the form texts are still untranslated on
http://jointhegame.kde.org/member/login?language=de
and
http://jointhegame.kde.org/join/information?language=de

Other than that it's much better now, thanks. :)
Comment 7 Frederik Gladhorn 2012-07-24 14:09:12 UTC
I wrote a patch that hopefully enables the translation of "Password". If that's successful (when ever the next scritpy run is) I can look into adding other translations this way (forms were affected afaict). I'm at a loss why the footer is not localized.
Comment 8 Emil Sedgh 2012-07-25 05:01:18 UTC
Hi.
I switched the website to use compiled mo files.
There are no more problems with parsing .po files.

Altough the password and footer issues are still there. This means they were not related to po parser.

I will try to find the problem with them as well.

Thanks Frederik for fixing the po parser.
Comment 9 Albert Astals Cid 2012-12-20 11:58:53 UTC
I'm closing this bug as the issues you mention specifically in this have been fixed,

There remain a few issues translation related like  https://bugs.kde.org/show_bug.cgi?id=308404 or https://bugs.kde.org/show_bug.cgi?id=308406 or https://bugs.kde.org/show_bug.cgi?id=308449 or https://bugs.kde.org/show_bug.cgi?id=308451 or https://bugs.kde.org/show_bug.cgi?id=308452

Frederik if you know of a specific issue please open one bug per each of them, it is much easier to track one issue per bug instead of a wholesale