Bug 298005

Summary: tried to connect my local network with static ip
Product: kdelibs Reporter: Simon Andric <simonandric5>
Component: knotifyAssignee: Olivier Goffart <ogoffart>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: 4.0   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Simon Andric 2012-04-12 23:48:43 UTC
Application: knotify4 (4.0)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-23-generic-pae i686
Distribution: Ubuntu precise (development branch)

-- Information about the crash:
- What I was doing when the application crashed:
while i was configuring the local network in my fireofx browser dolphin crashed, plasma restared ,...

i use project neon

symon

The crash can be reproduced every time.

-- Backtrace:
Application: KNotify (knotify4), signal: Aborted
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb52f8740 (LWP 3535))]

Thread 2 (Thread 0xb34e8b40 (LWP 3536)):
#0  0xb56b9c2d in __pthread_mutex_unlock_usercnt (mutex=0xb2b00550, decr=1) at pthread_mutex_unlock.c:36
#1  0xb5c65634 in pthread_mutex_unlock (mutex=0xb2b00550) at forward.c:184
#2  0xb55ae420 in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb556e755 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb556ef6f in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb556f1c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb5ff89de in QEventDispatcherGlib::processEvents (this=0xb2b00468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0xb5fbf4a5 in QEventLoop::processEvents (this=0xb34e8238, flags=...) at kernel/qeventloop.cpp:149
#8  0xb5fbf613 in QEventLoop::exec (this=0xb34e8238, flags=...) at kernel/qeventloop.cpp:204
#9  0xb5ea00f5 in QThread::exec (this=0xa0e8438) at thread/qthread.cpp:501
#10 0xb5f9d512 in QInotifyFileSystemWatcherEngine::run (this=0xa0e8438) at io/qfilesystemwatcher_inotify.cpp:248
#11 0xb5ea28ad in QThreadPrivate::start (arg=0xa0e8438) at thread/qthread_unix.cpp:298
#12 0xb56b6d4c in start_thread (arg=0xb34e8b40) at pthread_create.c:308
#13 0xb5c57ace in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb52f8740 (LWP 3535)):
[KCrash Handler]
#7  0xb777f424 in __kernel_vsyscall ()
#8  0xb5b9b1ef in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#9  0xb5b9e835 in __GI_abort () at abort.c:91
#10 0xb5e963d7 in qt_message_output (msgType=QtFatalMsg, buf=0xa0f7158 "ASSERT: \"dev->backendObject()!=0\" in file /build/buildd/project-neon-kdelibs-2+git20120412+r92545/solid/solid/devicemanager.cpp, line 201") at global/qglobal.cpp:2252
#11 0xb5e96576 in qt_message (msgType=QtFatalMsg, msg=0xb603b034 "ASSERT: \"%s\" in file %s, line %d", ap=0xbfc038a4 "\241\343 \267\374\340 \267\311") at global/qglobal.cpp:2298
#12 0xb5e969a2 in qFatal (msg=0xb603b034 "ASSERT: \"%s\" in file %s, line %d") at global/qglobal.cpp:2481
#13 0xb5e95f8e in qt_assert (assertion=0xb720e3a1 "dev->backendObject()!=0", file=0xb720e0fc "/build/buildd/project-neon-kdelibs-2+git20120412+r92545/solid/solid/devicemanager.cpp", line=201) at global/qglobal.cpp:1999
#14 0xb719cede in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0xa0e78a8, udi=...) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/solid/solid/devicemanager.cpp:201
#15 0xb719d69b in Solid::DeviceManagerPrivate::qt_static_metacall (_o=0xa0e78a8, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbfc039f8) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/obj-i686-linux-gnu/solid/solid/devicemanager_p.moc:55
#16 0xb5fdd259 in QMetaObject::activate (sender=0xa0e82e8, m=0xb7255c88, local_signal_index=1, argv=0xbfc039f8) at kernel/qobject.cpp:3547
#17 0xb71b520a in Solid::Ifaces::DeviceManager::deviceRemoved (this=0xa0e82e8, _t1=...) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/obj-i686-linux-gnu/solid/solid/ifaces/devicemanager.moc:108
#18 0xb72070e7 in Solid::Backends::Fstab::FstabManager::_k_updateDeviceList (this=0xa0e82e8) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/solid/solid/backends/fstab/fstabmanager.cpp:126
#19 0xb7206e84 in Solid::Backends::Fstab::FstabManager::onFstabChanged (this=0xa0e82e8) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/solid/solid/backends/fstab/fstabmanager.cpp:110
#20 0xb719771f in Solid::Backends::Fstab::FstabManager::qt_static_metacall (_o=0xa0e82e8, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbfc03b50) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/obj-i686-linux-gnu/solid/solid/moc_fstabmanager.cpp:56
#21 0xb5fdd259 in QMetaObject::activate (sender=0xa0e8418, m=0xb72531c0, local_signal_index=1, argv=0x0) at kernel/qobject.cpp:3547
#22 0xb7197eab in Solid::Backends::Fstab::FstabWatcher::fstabChanged (this=0xa0e8418) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/obj-i686-linux-gnu/solid/solid/moc_fstabwatcher.cpp:113
#23 0xb720a977 in Solid::Backends::Fstab::FstabWatcher::onFileChanged (this=0xa0e8418, path=...) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/solid/solid/backends/fstab/fstabwatcher.cpp:110
#24 0xb7197d0c in Solid::Backends::Fstab::FstabWatcher::qt_static_metacall (_o=0xa0e8418, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbfc03d18) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/obj-i686-linux-gnu/solid/solid/moc_fstabwatcher.cpp:58
#25 0xb5fdd259 in QMetaObject::activate (sender=0xa0e8460, m=0xb616a8f8, local_signal_index=0, argv=0xbfc03d18) at kernel/qobject.cpp:3547
#26 0xb5f8e2ea in QFileSystemWatcher::fileChanged (this=0xa0e8460, _t1=...) at .moc/debug-shared/moc_qfilesystemwatcher.cpp:109
#27 0xb5f8d518 in QFileSystemWatcherPrivate::_q_fileChanged (this=0xa0e84c0, path=..., removed=false) at io/qfilesystemwatcher.cpp:346
#28 0xb5f8e14e in QFileSystemWatcher::qt_static_metacall (_o=0xa0e8460, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xb2b02418) at .moc/debug-shared/moc_qfilesystemwatcher.cpp:59
#29 0xb5fd778e in QMetaCallEvent::placeMetaCall (this=0xb2b02458, object=0xa0e8460) at kernel/qobject.cpp:525
#30 0xb5fd882c in QObject::event (this=0xa0e8460, e=0xb2b02458) at kernel/qobject.cpp:1195
#31 0xb6668262 in QApplicationPrivate::notify_helper (this=0xa00f208, receiver=0xa0e8460, e=0xb2b02458) at kernel/qapplication.cpp:4554
#32 0xb6665b60 in QApplication::notify (this=0xbfc04648, receiver=0xa0e8460, e=0xb2b02458) at kernel/qapplication.cpp:3936
#33 0xb74ab742 in KApplication::notify (this=0xbfc04648, receiver=0xa0e8460, event=0xb2b02458) at /build/buildd/project-neon-kdelibs-2+git20120412+r92545/kdeui/kernel/kapplication.cpp:311
#34 0xb5fc19de in QCoreApplication::notifyInternal (this=0xbfc04648, receiver=0xa0e8460, event=0xb2b02458) at kernel/qcoreapplication.cpp:876
#35 0xb5fc5145 in QCoreApplication::sendEvent (receiver=0xa0e8460, event=0xb2b02458) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#36 0xb5fc28da in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9feba40) at kernel/qcoreapplication.cpp:1500
#37 0xb5fc2597 in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#38 0xb5ff908e in QCoreApplication::sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#39 0xb5ff8232 in postEventSourceDispatch (s=0xa010c00) at kernel/qeventdispatcher_glib.cpp:279
#40 0xb556ecda in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#41 0xb556f0e5 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#42 0xb556f1c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#43 0xb5ff89be in QEventDispatcherGlib::processEvents (this=0x9fec5c0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#44 0xb6731878 in QGuiEventDispatcherGlib::processEvents (this=0x9fec5c0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#45 0xb5fbf4a5 in QEventLoop::processEvents (this=0xbfc045ac, flags=...) at kernel/qeventloop.cpp:149
#46 0xb5fbf613 in QEventLoop::exec (this=0xbfc045ac, flags=...) at kernel/qeventloop.cpp:204
#47 0xb5fc205a in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#48 0xb66657d4 in QApplication::exec () at kernel/qapplication.cpp:3815
#49 0x0804fead in main (argc=1, argv=0xbfc047a4) at /build/buildd/project-neon-kde-runtime-2+git20120412+r17242/knotify/main.cpp:73

This bug may be a duplicate of or related to bug 291369.

Possible duplicates by query: bug 291961, bug 291369, bug 287560, bug 284718, bug 281086.

Reported using DrKonqi
Comment 1 Christoph Feck 2012-04-13 08:15:12 UTC

*** This bug has been marked as a duplicate of bug 251356 ***