Bug 291599

Summary: muon software center crash
Product: kde Reporter: drum_bass
Component: generalAssignee: Unassigned bugs mailing-list <unassigned-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: adaptee
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description drum_bass 2012-01-15 18:18:49 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
muon software center crashes right after lunch this happens everytime when started.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb785c930 (LWP 1658))]

Thread 2 (Thread 0xb58a8b70 (LWP 1662)):
#0  postEventSourceCheck (source=0x928a308) at kernel/qeventdispatcher_glib.cpp:269
#1  0x05dc2f24 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x05dc38f0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x05dc3c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x00536b37 in QEventDispatcherGlib::processEvents (this=0x91c2c80, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x005071dd in QEventLoop::processEvents (this=0xb58a82b0, flags=...) at kernel/qeventloop.cpp:149
#6  0x00507421 in QEventLoop::exec (this=0xb58a82b0, flags=...) at kernel/qeventloop.cpp:201
#7  0x0040a90b in QThread::exec (this=0x9289d08) at thread/qthread.cpp:498
#8  0x004e7e2d in QInotifyFileSystemWatcherEngine::run (this=0x9289d08) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x0040d7b3 in QThreadPrivate::start (arg=0x9289d08) at thread/qthread_unix.cpp:331
#10 0x00debd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0x00ccb0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb785c930 (LWP 1658)):
[KCrash Handler]
#7  0x00461e11 in QtPrivate::QStringList_contains (that=0xbfeebe54, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfeebe54) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x912fe58) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x912fe58, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfeec074) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0050eb7d in metacall (argv=0xbfeec074, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x912fe58) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x912fe58, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfeec074) at kernel/qmetaobject.cpp:232
#13 0x0051da6a in QMetaObject::activate (sender=0x91a3350, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x91a3350) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x91a3350, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfeec1b8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x0050eb7d in metacall (argv=0xbfeec1b8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x91a3350) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x91a3350, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfeec1b8) at kernel/qmetaobject.cpp:232
#18 0x0051da6a in QMetaObject::activate (sender=0x912fe58, m=0x80950c0, local_signal_index=0, argv=0xbfeec1b8) at kernel/qobject.cpp:3278
#19 0x002317c5 in MuonMainWindow::backendReady (this=0x912fe58, _t1=0x917cf28) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00231933 in MuonMainWindow::initObject (this=0x912fe58) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x912fe58) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x912fe58, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfeec2e4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x0050eb7d in metacall (argv=0xbfeec2e4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x912fe58) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x912fe58, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfeec2e4) at kernel/qmetaobject.cpp:232
#25 0x0051da6a in QMetaObject::activate (sender=0x9199ff0, m=0x63e238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00525375 in QSingleShotTimer::timeout (this=0x9199ff0) at .moc/release-shared/qtimer.moc:82
#27 0x0052542c in QSingleShotTimer::timerEvent (this=0x9199ff0) at kernel/qtimer.cpp:308
#28 0x00520994 in QObject::event (this=0x9199ff0, e=0xbfeec6dc) at kernel/qobject.cpp:1181
#29 0x0401cd54 in notify_helper (e=0xbfeec6dc, receiver=0x9199ff0, this=0x9047d90) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9047d90, receiver=0x9199ff0, e=0xbfeec6dc) at kernel/qapplication.cpp:4458
#31 0x04022103 in QApplication::notify (this=0xbfeec6dc, receiver=0x9199ff0, e=0xbfeec6dc) at kernel/qapplication.cpp:3886
#32 0x0112e681 in KApplication::notify (this=0xbfeec9f0, receiver=0x9199ff0, event=0xbfeec6dc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0050819e in QCoreApplication::notifyInternal (this=0xbfeec9f0, receiver=0x9199ff0, event=0xbfeec6dc) at kernel/qcoreapplication.cpp:787
#34 0x00538c10 in sendEvent (event=0xbfeec6dc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9048a74) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00536122 in timerSourceDispatch (source=0x9048a40) at kernel/qeventdispatcher_glib.cpp:184
#37 0x05dc325f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x05dc3990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x05dc3c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00536ada in QEventDispatcherGlib::processEvents (this=0x902a238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x040d4e3a in QGuiEventDispatcherGlib::processEvents (this=0x902a238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x005071dd in QEventLoop::processEvents (this=0xbfeec954, flags=...) at kernel/qeventloop.cpp:149
#43 0x00507421 in QEventLoop::exec (this=0xbfeec954, flags=...) at kernel/qeventloop.cpp:201
#44 0x0050c19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x0401a8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291592, bug 291590, bug 291588, bug 291581, bug 291580.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-15 18:26:33 UTC

*** This bug has been marked as a duplicate of bug 291262 ***