Bug 288942

Summary: Kmail crashed while re-reading an email
Product: [Applications] kontact Reporter: Alan House <alan.house>
Component: generalAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In:

Description Alan House 2011-12-14 07:46:16 UTC
Application: kontact (4.7.4)
KDE Platform Version: 4.7.4 (4.7.4) (Compiled from sources)
Qt Version: 4.8.0
Operating System: Linux 3.1.5-1.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed:
Scrolling through emails. Re-reading an email and crashed. Email has been read several times without incident. Note Kmail version 4.7.4.

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7ff49b91c840 (LWP 20077))]

Thread 5 (Thread 0x7ff491000700 (LWP 20078)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x00000032f99973cc in WTF::TCMalloc_PageHeap::scavengerThread (this=0x32fa390f80) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x00000032f99974f9 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x0000003e91207d90 in start_thread (arg=0x7ff491000700) at pthread_create.c:309
#4  0x0000003e906ef3dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 4 (Thread 0x7ff4906ff700 (LWP 20079)):
#0  0x00007fffff7ff98f in clock_gettime ()
#1  0x0000003e91a041f1 in __GI_clock_gettime (clock_id=1, tp=0x7ff4906fead0) at ../sysdeps/unix/clock_gettime.c:100
#2  0x0000003e982d2004 in do_gettime (frac=0x7ff4906feae8, sec=0x7ff4906feae0) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x0000003e983a6f9d in QTimerInfoList::updateCurrentTime (this=0x7ff4880020d0) at kernel/qeventdispatcher_unix.cpp:343
#5  0x0000003e983a72d3 in QTimerInfoList::timerWait (this=0x7ff4880020d0, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x0000003e983a5d6c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7ff4906febac) at kernel/qeventdispatcher_glib.cpp:136
#7  0x0000003e93244012 in g_main_context_prepare (context=0x7ff4880009a0, priority=0x7ff4906fec18) at gmain.c:2746
#8  0x0000003e93244e1d in g_main_context_iterate (context=0x7ff4880009a0, block=1, dispatch=1, self=<optimized out>) at gmain.c:3053
#9  0x0000003e9324544c in g_main_context_iteration (context=0x7ff4880009a0, may_block=1) at gmain.c:3136
#10 0x0000003e983a6896 in QEventDispatcherGlib::processEvents (this=0x7ff4880008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#11 0x0000003e98376c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#12 0x0000003e98376ed7 in QEventLoop::exec (this=0x7ff4906fed40, flags=...) at kernel/qeventloop.cpp:204
#13 0x0000003e98278ad7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#14 0x0000003e9827bb1b in QThreadPrivate::start (arg=0x1166fa0) at thread/qthread_unix.cpp:298
#15 0x0000003e91207d90 in start_thread (arg=0x7ff4906ff700) at pthread_create.c:309
#16 0x0000003e906ef3dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7ff42bfff700 (LWP 12763)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x0000003e9827bf8f in wait (time=30000, this=0x7ff43c005ef0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7ff43c005e98, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x0000003e9826f55f in QThreadPoolThread::run (this=0x7ff43c00a140) at concurrent/qthreadpool.cpp:141
#4  0x0000003e9827bb1b in QThreadPrivate::start (arg=0x7ff43c00a140) at thread/qthread_unix.cpp:298
#5  0x0000003e91207d90 in start_thread (arg=0x7ff42bfff700) at pthread_create.c:309
#6  0x0000003e906ef3dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7ff442e41700 (LWP 12764)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x0000003e9827bf8f in wait (time=30000, this=0x7ff43c005ef0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7ff43c005e98, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x0000003e9826f55f in QThreadPoolThread::run (this=0x7ff43800e000) at concurrent/qthreadpool.cpp:141
#4  0x0000003e9827bb1b in QThreadPrivate::start (arg=0x7ff43800e000) at thread/qthread_unix.cpp:298
#5  0x0000003e91207d90 in start_thread (arg=0x7ff442e41700) at pthread_create.c:309
#6  0x0000003e906ef3dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7ff49b91c840 (LWP 20077)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x54d0850, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00000032f20f4ef9 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x54d0850, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x0000003e983909e6 in QObject::event (this=0x54d0850, e=<optimized out>) at kernel/qobject.cpp:1194
#9  0x0000003e989c96f4 in notify_helper (e=0x7ff43c002e30, receiver=0x54d0850, this=0x115bae0) at kernel/qapplication.cpp:4518
#10 QApplicationPrivate::notify_helper (this=0x115bae0, receiver=0x54d0850, e=0x7ff43c002e30) at kernel/qapplication.cpp:4490
#11 0x0000003e989ce573 in QApplication::notify (this=0x7fffff67c140, receiver=0x54d0850, e=0x7ff43c002e30) at kernel/qapplication.cpp:4379
#12 0x00000032f3050766 in KApplication::notify (this=0x7fffff67c140, receiver=0x54d0850, event=0x7ff43c002e30) at /usr/src/debug/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:311
#13 0x0000003e98377b4c in QCoreApplication::notifyInternal (this=0x7fffff67c140, receiver=0x54d0850, event=0x7ff43c002e30) at kernel/qcoreapplication.cpp:876
#14 0x0000003e9837b5da in sendEvent (event=0x7ff43c002e30, receiver=0x54d0850) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x112d050) at kernel/qcoreapplication.cpp:1500
#16 0x0000003e983a6403 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0x1161000) at kernel/qeventdispatcher_glib.cpp:279
#18 0x0000003e93244a7d in g_main_dispatch (context=0x1161610) at gmain.c:2425
#19 g_main_context_dispatch (context=0x1161610) at gmain.c:2995
#20 0x0000003e93245278 in g_main_context_iterate (context=0x1161610, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#21 0x0000003e9324544c in g_main_context_iteration (context=0x1161610, may_block=1) at gmain.c:3136
#22 0x0000003e983a682f in QEventDispatcherGlib::processEvents (this=0x112e510, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#23 0x0000003e98a6c43e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#24 0x0000003e98376c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#25 0x0000003e98376ed7 in QEventLoop::exec (this=0x7fffff67c0d0, flags=...) at kernel/qeventloop.cpp:204
#26 0x0000003e9837b8d5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#27 0x00000000004037b9 in main (argc=1, argv=0x7fffff67c768) at /usr/src/debug/kdepim-4.7.4/kontact/src/main.cpp:218

Possible duplicates by query: bug 288935, bug 288604, bug 288504, bug 288423, bug 288362.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-12-14 09:14:27 UTC

*** This bug has been marked as a duplicate of bug 286307 ***